Industry Giant 2

Industry Giant 2

View Stats:
 This topic has been pinned, so it's probably important
Grester Aug 16, 2015 @ 4:12pm
Frequently Asked Questions / Troubleshooting
I've personally tested the game myself and I must say I'm stunned on how well it works. I'm running windows 10 and so far the game works without compatiblity modes and even the videos that some people need to disable, play. However if you're one of the unfortunate to have problems with the game, save some time and search here for a solution to your problem instead of scrolling through endless posts.

Before starting the FAQ here's a situation that has no solution at least for now:
N/A

General recommendations:
ATI/AMD graphics cards users are advised to turn Catalyst A.I. off by going to 3D settings of Catalyst Control Center.
I also suggest in the main menu options to disable the VSync option (NOT green) as this sometimes produces glitches or reduces game playability.

Q: Does the game include the Gold Edition addon?
A: Yes, this steam release is basically Gold Edition.

Q: Game crashes on start without any error.
A: This happens usually with integrated graphics (Intel HD Graphics), make sure the drivers for that are updated.

Q: When I start the game it says I don't have a compatible graphics card.
A: Go to your steam library, right click in IndustryGiant2 and select properties, select local files and browse local files. The folder where IndustryGiant2 is installed will open, right click on ig2(UNDERSCORE)addon.exe and select properties, go to compatibility and activate compatibility for Windows XP SP3. If it still doesn't work try compatibility for Windows 95/98 however you won't be able to play in HD.

Q: Game crashes when a video starts to play or new vehicle is invented.
A: Start a game so you can access ingame options. Once ingame, in the bottom bar click on options (old CRT screen icon), and disable the videos option. You won't see the videos of when you unlock a new vehicle but your game won't crash either.

Q: Game worked yesterday but not today.
A: The culprit of this is steam cloud. Reinstall the game and disable steam cloud before playing it again. To do this go to the game properties in your steam library, Updates tab and uncheck the steam cloud sync.

Q: The game shows up in a small window at the corner of the screen.
A: You likely have increased the DPI of windows. To disable the DPI setting to conflict with the game, go to your steam library, right click in IndustryGiant2 and select properties, select local files and browse local files. The folder where IndustryGiant2 is installed will open, right click on ig2(UNDERSCORE)addon.exe and select properties, go to compatibility and check 'Disable display scaling on high DPI settings'.

Q: Tooltips glitch/flicker.
A: Disabling steam overlay seems to fix this issue.

Q: A error shows up whenever there's a music change.
A: Mute the music in options.

Q: What happened to the multiplayer from the older releases?
A: They aesthetically removed from the steam release. However it is still available in the game and you can play it by applying this patch available here.
However if you haven't purchased the game yet I recommend buying the GOG version as they haven't removed the multiplayer from there.


Q: Is there a way to automate joining a multiplayer session?
A: Create shortcut of the game's executables with these commands.

Q: What happened to the editor available in the older releases?
A: They also removed from the steam release as they did with the multiplayer. However using the editor from the older releases still works in the steam version, you can get it here.

If you find out about another issue or a possible update on the other situations post a reply.
Last edited by Grester; Jan 6, 2017 @ 2:02pm
< >
Showing 1-15 of 35 comments
Sacrifice Aug 17, 2015 @ 10:43am 
Disabled Catalyst AI using the profiles.xml edit, still flickering. Then tried using Radeonpro, still flickering!
Grester Aug 17, 2015 @ 1:50pm 
Originally posted by Sacrifice:
Disabled Catalyst AI using the profiles.xml edit, still flickering. Then tried using Radeonpro, still flickering!
Have you tried disabling the steam overlay as sugested? Also what version of windows are you using? If it doesn't work try manually installing DirectX8.1 although steam should have done it by itself.
Last edited by Grester; Aug 17, 2015 @ 2:46pm
Sacrifice Aug 17, 2015 @ 3:05pm 
Originally posted by Grester:
Originally posted by Sacrifice:
Disabled Catalyst AI using the profiles.xml edit, still flickering. Then tried using Radeonpro, still flickering!
Have you tried disabling the steam overlay as sugested? Also what version of windows are you using? If it doesn't work try manually installing DirectX8.1 although steam should have done it by itself.

Windows 7, r9 290 crossfire, just tried with overlay, didn't work, I'll try direct x now.
Grester Aug 17, 2015 @ 3:27pm 
Originally posted by Sacrifice:
r9 290 crossfire
Curiously you're not the first one to complain about R9's, there have been other people complaining about their 270 and 280. If DirectX doesn't help try updating GPU drivers and in catalyst try disabling Vsync for the game. (Sort like you can do in NVidia control panel for a specific application). Since you touched the .xml already take a look a this. https://www.youtube.com/watch?v=6pzTsvu5WxQ
Last edited by Grester; Aug 17, 2015 @ 3:41pm
Seth  [developer] Aug 20, 2015 @ 10:05am 
In Addition to the question if the game works on Intel HD Graphics:
Game has been fully tested on both HD 4400 and HD 5200 - so it should run without a problem. :)
Grester Aug 20, 2015 @ 3:38pm 
Originally posted by Seth:
In Addition to the question if the game works on Intel HD Graphics:
Game has been fully tested on both HD 4400 and HD 5200 - so it should run without a problem. :)
Yes, I've strikethrough because there were reports of people saying they were capable of running them.
rovaira2 Aug 20, 2015 @ 10:00pm 
It might be a good idea to have videos not play in game by default; that way novices will start that way without having to figure out how to turn it off. I can do it pretty easy. This is a great game. I just tested it with videos on, but it still did crash after like the 3rd-4th video it played somewhere around 1945-50 (started around 1940 or 1945).

Problem signature:
Problem Event Name: APPCRASH
Application Name: ig2_AddOn.exe
Application Version: 2.3.2.0
Application Timestamp: 55d4e8f6
Fault Module Name: libogg.dll
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 55d23975
Exception Code: c0000005
Exception Offset: 00001c08
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
Woolridge Aug 21, 2015 @ 2:56am 
so in other words, in order to play a remake of IG2 you need to disable almost everything (HD grafics, videos, v-sync etc...) so where is the point in buying this crap then?
i'll stick to my GOG version of the game since it's exactly the same if you need to disable the HD-grafics...
Sacrifice Aug 21, 2015 @ 3:35am 
Originally posted by Woolridge:
so in other words, in order to play a remake of IG2 you need to disable almost everything (HD grafics, videos, v-sync etc...) so where is the point in buying this crap then?
i'll stick to my GOG version of the game since it's exactly the same if you need to disable the HD-grafics...

HD graphics nope AFAIK? (What do you even mean hd graphics?), videos yes, v-sync why would it make that much difference anyway. I hardly ever play ANY game with v-sync on.
Sacrifice Aug 21, 2015 @ 3:36am 
Originally posted by Seth:
In Addition to the question if the game works on Intel HD Graphics:
Game has been fully tested on both HD 4400 and HD 5200 - so it should run without a problem. :)

So, any words on 290's?
fredreed2000 Aug 21, 2015 @ 6:44am 
If you are having issues with the 290 card then I suggest you email the tech support about your issue so they can address It for everyone who has this card. I would also check your drivers to make sure that they are not bad beccause I heard that a lot of these cards of bad drivers that have been downloaded from windows. You are referring to the radeon HD290 series correct?
Grester Aug 21, 2015 @ 7:53am 
Originally posted by Sacrifice:
So, any words on 290's?
Read the topic I made with the video a few days ago.
Highlander0065 Sep 24, 2015 @ 3:13pm 
Not sure if this is the right location to post, but the game doesn't even appear to try to start for me. The error log gives this:

ig2_AddOn caused an Access Violation in module ig2_AddOn.exe at 0023:011e2ff9.
Exception handler called in Main Thread.
IG2 GOLD version 2.2. 52554.
Error occurred at 9/24/2015 17:32:02.
C:\Program Files (x86)\Steam\steamapps\common\Industry Giant 2\ig2_AddOn.exe, run by dfisher.
12 processor(s), type 586.
0 MBytes physical memory.
Read from location 00000000 caused an access violation.

Any thoughts?
Roo Attachments Sep 28, 2015 @ 6:22pm 
Q: Tooltips glitch/flicker.
A: Disabling steam overlay seems to fix this issue.

That dosent work!

Also i have edited my Nvidia control center to force Vsync off , tryed running it in the differant capablity modes and all that and pretty much everything else i could find on the net!

anyone found anything that works? I am using a GTX760
Last edited by Roo Attachments; Sep 28, 2015 @ 6:26pm
Philomel_D8 Dec 6, 2015 @ 5:46pm 
Intel HD4000 still crash on startup, drivers is up to date
< >
Showing 1-15 of 35 comments
Per page: 15 30 50