Act of War: Direct Action

Act of War: Direct Action

kazaric Jun 28, 2013 @ 12:18pm
***Guys, Here is how you fix the game once and for all, simple solution.
First of all, download a file from here (all credit goes to tomsons26)

****But here's the thing, the guide is somewhat misleading so do not follow the guide there, instead, do this :
Ignore the EugLoadingBar the guide told you to, set only the ActofWar.exe in Vista SP1 compatibility mode
Apply the dll you downloaded from there.

Then you should be able to run the game, HOWEVER -> some people may experience another error game is already running, caused by the "Run as Admin?"question box, if this happens to you, try unchecking the "run as administrator" box in ActofWar.exe, if it still doesn't work you will have to try fiddle around with your Windows Security options, If you can get rid of the question box, the game WILL guarantee to run trust me.

Please spread this info to your friends as well if theycan't get the game running, they need to know this, hopefully this thread can be more visible to you people.:hee:

Last edited by kazaric; Jun 28, 2013 @ 7:37pm
< >
Showing 1-9 of 9 comments
Nicholas Jul 7, 2013 @ 4:22pm 
Didnt work.

Blokes guide or your suggestions.

Windows 7 64bit, 8GB Memory.
Viz@r Aug 8, 2013 @ 1:23pm 
It works. To start than copying DLL must also exhibit the properties of exe run as administrator and run in compatibility with Win xp SP2 (it's written in the description in the archive with the DLL). When you run a window that will come out swearing on 64 bit system, but the game still runs a few seconds after closing this window.
There will be only one problem - the screen resolution, there is no full support of 1920x1080 due to the fact that the game is old. Fix for this yet failed to find ...
Just tested it on Win7 x64 and 8GB ram.
Last edited by Viz@r; Aug 8, 2013 @ 1:29pm
Nicholas Aug 9, 2013 @ 8:02am 
I just get a program crash after that message.
Last edited by Nicholas; Aug 9, 2013 @ 8:21am
Serakiel Aug 10, 2013 @ 4:25am 
Hell it works! I've got all the known errors (too much RAM, application already running and "kernel32.dll"), but after some manips, I got it working thanks to the file!

By the way, it seems many gamers still experience the "kernel32.dll" problem: I solved it by selecting the "Windows Server 2008 SP1" compatibility mode and unchecking the "run as administrator" box. The message still pops up at the launching, but the game works anyway! I played it twice, in skirmish, no problem so far.
Serakiel Aug 10, 2013 @ 4:49am 
Just a detail though: it worked when Steam was in offline mode. When I tried to launch it online, I got a dozen of "access violation" messages about various dll and exe files. Then I had to get offline, select another compatibility mode, then select "Windows Server 2008" again to get it re-working. Curious.
kazaric Aug 10, 2013 @ 4:54am 
interesting, never tried the 08 server mode myself, this might probably solve the last issue at last
Nicholas Aug 10, 2013 @ 2:57pm 
Stragne, since the last time I tried this I have installed a new graphics card and change the install directory from the SSD drive to the SATA drive. I can only think it was the SSD install that was causing the problem because my old card and new card are nvidia. I went from 260GTX to MSI 670GTX power Edition

In any case it works now, I am so happy. I love this game to bits.
Lindholm^ Aug 15, 2013 @ 10:20am 
i dont understand how i do this.. but my says "Runtime error 217 at 001B2E14.. plz help me, i miss to play this game! :-)
Nicholas Aug 16, 2013 @ 8:56am 
This worked for me but I am scared to try other methods incase it screws it up.

I made this video myself in hopes of a more visual solution to help people out.

Hope this helps, if you are installing on a SSD drive try installing it to a SATA drive instead or a driver other than what your operating system is on if you can.
Last edited by Nicholas; Aug 16, 2013 @ 8:57am
< >
Showing 1-9 of 9 comments
Per page: 15 30 50