RollerCoaster Tycoon 3: Platinum!

RollerCoaster Tycoon 3: Platinum!

View Stats:
dstyikx Jul 23, 2013 @ 9:07am
Failed to Create Direct3D Device! Help Please!
The game worked fine for an entire day yesterday. Then today, I realised I could change the settings for the resolution, so I clicked High Performance. Suddenly the game crashed, and would no longer work. I tried many of the fixes such as uninstall/reinstall, screen resoultuion change and option.txt files. If anyone could please help me, it would be much appreciated.
< >
Showing 1-5 of 5 comments
Vezixig Jul 24, 2013 @ 10:57am 
Same problem for me
dstyikx Jul 24, 2013 @ 5:18pm 
Fixed it. Find your RTC3Plus.exe file, and right click it. Go to properties and run it in compatibility mode! Works just fine afterwards.
Vezixig Jul 24, 2013 @ 9:00pm 
That really did the trick - thanks :D
Tried XP with SP3 first which didn't work. But Vista compatibility worked fine for me.
제주삼다수 Dec 22, 2015 @ 9:23pm 
Same problem for me to
제주삼다수 Dec 25, 2015 @ 11:53pm 
I found it !!! a way to solve the problem Failed to Create Direct3D Device
I found a way to solve the problem

c driver -> D driver Reinstalling

1.Delete the RCT3's C drive
2.RCT3 reinstall the D drive

The treasure is found comfort
Now you can start the game,
Finally I found a treasure
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Jul 23, 2013 @ 9:07am
Posts: 5