Satellite Reign

Satellite Reign

View Stats:
Rebinding controls doesn't work?
I was trying to get into the game, then pretty clearly noticed the camera controls were in the arrow keys on keyboard, in addition to , and . rotating the camera and thought that was idiotic, they should rather obviously to me be in WASD for moving and Q+E for turning.

I tried to go to the menu and rebind the keys, and it just didn't work, I was clicking on it for a few minutes, trying all kinds of combinations of holding down the key while pressing the key down etc. and I was completely unable to rebind the keys.

I was able to erase a couple of the existing ones and then reset to defaults.

The completely unresponsive menu just ♥♥♥♥♥♥ me off so much I had to quit the game after a few minutes into the tutorial mission.
< >
Showing 1-15 of 21 comments
Disky  [developer] Jan 18, 2016 @ 4:52pm 
I've not heard of this issue with the key rebinding before..

BTW the reason we dont bind wasd to scroll is because that whole area of the keyboard is used as shortcuts to abilities.

You can pan the world by holding middle mouse (or by moving the mouse to the edge of the screen (if edge scroll is enabled).

Does the rebind never work, or did you only try it once? You should be able to click the box with the current key binding in, then whatever key you press next is assigned in that box. (I'm wondering if your alt or control or shift was stuck down, or the game thought it was stuck down)

Mike.



PhellAsleep Jan 18, 2016 @ 4:59pm 
Is there a way to rebind the hold middle mouse key camera pan to another mouse key? I don't see any options to rebind mouse keys or mouse key combinations (ie. Stealth kill) to anything else.
twitch.tv/lietu Jan 19, 2016 @ 8:24am 
I tried it just once so far, will give it another go maybe in a few days.

I did exactly that, so click on the box and then tried to press something else, but it didn't seem to even listen for input.

I doubt I had any keys stuck, and I actually also tried clicking with ctrl, alt and shift held down etc. other random things that I could think of that could have caused issues but I couldn't figure it out. I tried leaving the menu and going back in and things like that as well.

Using mouse to pan around felt rather clumsy when I want to use it to control the agents, and moving my hand between e.g. the number keys and arrow keys felt rather clumsy as well which is why I thought WASD+Q/E would work best for the camera controls.
Vanshi Shogaku Jan 25, 2016 @ 7:44am 
Same problem here, can't change the key bindings, no response from menu. I can delete existing bindings and restore default, but can't bind any custom button. Tried it first in mission, then exited to main menu but no luck.

edit: tried again, "Ctrl" and "Shift" keys can be bind everywhere, nothing else.
Last edited by Vanshi Shogaku; Jan 25, 2016 @ 8:34am
twitch.tv/lietu Jan 25, 2016 @ 8:00am 
Yea I just started the game to try it out, loaded my profile, opened the menu and tested the rebinding UI .. still doesn't work at all.
Amphetamine Mar 5, 2017 @ 10:12pm 
Same here, bind screen recognises LShift, RShift, LCTRL, RCTRL, LALT, RALT (RALT is recognised as RCTRL though). Can't get any other keys to bind though. As with top poster, I was hoping to rebind to WASD+QE for pan+rotate.

Sorry, Arrows and puntuation are not convenient for pan + rotate since there's over 3" of space between them on my keytboard...
Vi7riol May 27, 2017 @ 7:08pm 
Same problem here, I cannot change bound keys. Any update/help on this would be appreciated.
Gillsing May 28, 2017 @ 12:06am 
I haven't seen any mentions of OS and keyboard, which seems like it could matter. I know that I can rebind keys just fine, but my Saitek Eclipse II keyboard isn't entirely compatible with my Linux. Whenever I use a media button Linux interprets that as holding down a mouse button and never letting go. So in order to safely switch the LED colour from default, I have to get to that before Linux Mint starts up. Or else I'd be forced to log out and back in again to clear away that 'mouse button' being held down.

Now, if that was the kind of problem anyone here was having, I'm sure it would've been noticed. But maybe there's some other problem that only appears for Unity? Or some other special circumstances which don't come up when doing other things on your computers?
twitch.tv/lietu May 28, 2017 @ 1:46am 
So I just tested again, the rebind menu has two columns that are not explained in any way as far as I can see. The left-hand column does not seem to work at all, the right hand column does work.

The main issue remaining is the almost complete lack of visual cues for it expecting input, normally people either have a dialog open that says something like "Press a key for Scroll Map Left", or just clear the field, maybe insert an underscore in it so it's clear that it's now waiting for new input.

And this is on Windows 10.
AcidCrashX Jun 23, 2017 @ 10:45am 
having the same issue currently. no fix has been posted on this thread, was there any update?
Bastidge Child Jun 23, 2017 @ 8:48pm 
I couldn't rebind 'P' to the 'UP cursor', so used my steelseries keyboard software to fool the game.
This is still a problem. I tried unbinding WASD to rebind them for the camera and even when they are not bound to any commands, you can't set them for the camera.

I know this game came out a while ago already, but it'd be great if we could rebind keys at will instead of having these silly restrictions.
Orangbo Apr 22, 2018 @ 5:41pm 
I fixed it by binding a secondary key to the default A and S (so now I have to press ctrl-A and ctrl-S to attack and stop). Hopefully we can stop the necroes now.
Last edited by Orangbo; Apr 22, 2018 @ 5:42pm
ej Apr 24, 2018 @ 3:47am 
Originally posted by disky:
BTW the reason we dont bind wasd to scroll is because that whole area of the keyboard is used as shortcuts to abilities.

You can pan the world by holding middle mouse (or by moving the mouse to the edge of the screen (if edge scroll is enabled).
THIS is why I gave this game such a negative review. Total lack of common sense. WASD is good enough for Starcraft 2 or NS2, but, apparently, not good enough for your game. And you made sure the player can't easily fix your blunders.
Of course, it is better to fill the keyboard with shortcuts the player will not even get to use before giving up on your game.
Sorry. I believe my rudeness is justified. It pains me to see a great potential wasted by incompetent implementation.
Last edited by ej; Apr 24, 2018 @ 3:54am
A more annoing case is in linux, normally the ALT key is for window management so no ALT keybinds will work easy; within the tutorial there is a part when you need to use that key to use a rope and then agian with ALT key assesinate some guy, this is undoable.

The worst part is in the settings menu there is no ALT keybind to edit so no Shft+Alt+click to edit Nor Alt+click keybind to edit...
< >
Showing 1-15 of 21 comments
Per page: 15 30 50