Satellite Reign

Satellite Reign

View Stats:
exekutive May 13, 2018 @ 11:22am
CBD checkpoint mission
I think I got Duncan killed (The Eternals operative who is supposed set up your dummy company). How long does it take for him to return from the hospital? I've done a couple of other missions to pass the time, but he still hasn't shown up at Sinclair Memorial. Is there a countdown timer anywhere?
< >
Showing 1-8 of 8 comments
Gillsing May 13, 2018 @ 12:01pm 
In my experience it should only take ten minutes or less before a killed VIP comes back from the hospital. Maybe you have to restart the game if some bug prevents him from returning.
exekutive May 13, 2018 @ 12:02pm 
You mean start the campaign again from the beginning? I have exited and reloaded the game already.
Gillsing May 13, 2018 @ 12:47pm 
Well, that is weird. Is there no ping for the mission telling you where he is?
exekutive May 13, 2018 @ 1:13pm 
If I click 'activate ping' at the bottom of the mission page, it pings the Eternals Armory. I tried going there, even though I already completed it, and I just got some cash.
https://imgur.com/27i0hiW
Last edited by exekutive; May 13, 2018 @ 1:45pm
Gillsing May 13, 2018 @ 2:23pm 
So somehow the game got itself stuck in a state where it thinks you already picked up the VIP? I wonder how that happened. Maybe it happens when the VIP dies, and the player saves the game while the VIP is 'in the hospital' and then quits the game before the VIP gets out and the player saves the game after the game has changed the ping from the facility to the VIP?

If that's what you did. But it doesn't sound like that's what you did. It sounds like you just waited, and the VIP was never released from hospital. Easy to miss those little messages, but I'm sure you checked the Sinclair Memorial area before shutting down the game.

If you're dead set on completing that mission you probably have to revert back to a manual save before you picked up Duncan. Otherwise you can just force or sneak your way through one of the checkpoints to CBD.
Last edited by Gillsing; May 13, 2018 @ 2:25pm
exekutive May 13, 2018 @ 2:44pm 
I don't know how it happened. I can still buy the pass right? Or is there a way to hack the save files? The bugs in this game are so frustrating.
Last edited by exekutive; May 13, 2018 @ 2:44pm
Gillsing May 13, 2018 @ 2:50pm 
Oh yeah, you can still buy the Gate Pass 2. Never done that, so it slipped my mind.
I just had this exact glitch. I got the guest party incapacitated, tried loading to the last autosave, and he's just gone. The objective ping remains on the armoury as if the guest is still present, but like when reloading a save whilst a hacked NPC is under player control, the guest has vanished.

I was so close to being done with him. I hadn't noticed that the zipline outside the armoury was electrified. Before I knew what was happening, an Eternal ran towards the already weakened guest, and he was taken down.

God knows why I decided to return to this game after 3 years. Sometimes there's just a desire to finish something that's been paid for.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50