XCOM 2
Vantskruv Feb 5, 2016 @ 1:41am
Solved the stutter problems
I had massive stuttering issues.

EDIT-------
Note that this does not fix perfomance issues as FPS. It only fixes extreme stuttering while scrolling the map and when actions occur.
I noticed that the stutter issues is marginalized mainly via the PoolSize setting. The other settings I'm not sure of how much the improve, or at all.
See second post.
-----------

WARNING----------
Settings in X-COM will reset for every restart of the game, as the game cannot write to the file because of the procedure below. Do set the prefered settings before setting the configuration file to read-only.
--------------

NOTE-----------
Check that the configuration file is not changed after have been starting and closing the game, this is to make sure the game does not overwrite the settings you made, cause of failed to set file to read-only incorrectly.
----------------

Solved the problems as told according to this thread (should work for both Windows and Linux users):
http://steamcommunity.com/app/200510/discussions/0/846960628563773260#p1

The game is running much more smooth and stuttering is almost removed (though still there is some small stuttering).

As I run Linux, I cannot point where the configuration files are placed on Windows.
The configuration file for Linux is at:
$/HOME/.local/share/feral-interactive/XCOM2/VFS/Local/my games/XCOM2/XComGame/Config/XComEngine.ini

NOTE: The XComEngine.ini configuration file in the subdirectories of the game in the Steam directory, are not used.

NOTE: The configuration file needs to be set as readonly (as it is otherwise overwritten). To do that for my Linux distribution, it was not enough to just right-click the file and set it to readonly.
To set it to readonly I did this in the terminal:
$ sudo chattr +i XComEngine.ini

My system:
OS and drivers----
Linux Debian Testing 64 bit
NVIDIA Drivers 352.79

Hardware-----
NVIDIA GTX 780Ti 3GB VRAM
Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
Memory 32GB RAM
Last edited by Vantskruv; Feb 5, 2016 @ 10:49am
< >
Showing 1-15 of 34 comments
Vantskruv Feb 5, 2016 @ 1:47am 
Here are the settings for XComEngine.ini copied from the link in this topic:

"bUseTextureStreaming=True" (these are default for most but not all UE3 games)
"bUseBackgroundLevelStreaming=True"
"MipFadeInSpeed0=0" (these even out mipmap loads and draw time)
"MipFadeOutSpeed0=0"
"MipFadeInSpeed1=0"
"MipFadeOutSpeed1=0"
"PhysXGpuHeapSize=64" (these balance physx calls even on cpu based physx titles)
"PhysXMeshCacheSize=16"
"bSmoothFrameRate=TRUE" (this really does need to be on, ignore what you've read)
"MinSmoothedFrameRate=30" (keep these right here. setting higher/lower does no good)
"MaxSmoothedFrameRate=400"
"bInitializeShadersOnDemand=True" (reduces overall shader batch call size)
"DisableATITextureFilterOptimizationChecks=False" (driver based opt is MUCH faster)
"UseMinimalNVIDIADriverShaderOptimization=False" (same here)
"PoolSize=256" or (vidmem/poolsize exmpl: 512/128, 1024/256, etc, DO NOT exceed 768)
"bAllowMultiThreadedShaderCompile=True" (should already be on by default)
"ThreadedShaderCompileThreshold=4" (formulate like this: # of cpu-cores (not threads) -2)
"OnlyStreamInTextures=True" (reduces overall texture batch call size)

NOTE:
The 'ThreadedShaderCompileThreshold should be only set to how many physical cores on the CPU you have minus 2. I.e. my 4790k has 4 physical cores (8 virtual cores total). So I set this value to 2.

NOTE:
A user in the linked thread above, said to set the 'PoolSize' to 25% of the total memory you have on your GPU. I.e. I have 3071MB VRAM. So I set the value to 768 (3071*0.25).
KyrenCross Feb 5, 2016 @ 2:06am 
where do you place this? The ini files in the XComEngine in Xcom 2 is very different.

Nvm, it's all over the place, will try this. Hope it really does remove those stutters.
Last edited by KyrenCross; Feb 5, 2016 @ 2:08am
Theophany Feb 5, 2016 @ 2:08am 
Originally posted by KyrenCross:
where do you place this? The ini files in the XComEngine in Xcom 2 is very different.
C:\Users\[your name]\Documents\My Games\XCOM2\XComGame\Config

EDIT : Some lines are present in 2 or even 3 different places in the file, it is possible you have to modify them all (i.e MinSmoothedFrameRate)
Last edited by Theophany; Feb 5, 2016 @ 2:12am
Vantskruv Feb 5, 2016 @ 2:27am 
EDIT: I changed my mind, it does work. It removed most of the extreme stutterings I have while scrolling the map.

Forget it, I did lure myself believing I did run at maximum graphics settings. Actually I was running at minimum settings.

This does not work, sorry fellows. :(

Edit: And also it locks your graphics settings, which is not good.
Last edited by Vantskruv; Feb 5, 2016 @ 10:51am
The Renderer Feb 5, 2016 @ 2:28am 
This did nothing for me, actually made it a little worse.
KyrenCross Feb 5, 2016 @ 2:51am 
Tried this and still stutters in the Fallout Shelter View mode. The FPS is 60 but scrolling in that space have that annoying stutter that makes the game feel cheap.
Vantskruv Feb 5, 2016 @ 10:44am 
Actually, I'm turning around again. Mainly the PoolSize setting is removing most of the stuttering issues.

I.e. while scrolling the map, I hade extreme stuttering, even at minimum settings. Setting the PoolSize to the calculated value, it is much more smooth scrolling the map.
Jolly Feb 5, 2016 @ 10:46am 
I turned shadows to lowest, lowered some of the things from 16x to 4x or so, and turned off bloom (probably doesn't help much but I don't like bloom anyways) and this all drastically improved my performance (game autodetected to max).

There have been other settings combos posted and/or suggestion to run in full screen window (disables vsync).
Vantskruv Feb 5, 2016 @ 10:56am 
Originally posted by KyrenCross:
Tried this and still stutters in the Fallout Shelter View mode. The FPS is 60 but scrolling in that space have that annoying stutter that makes the game feel cheap.

Are you sure the configuration file is set to read-only, and even though it is, checked that it is not changed by the game?

Maybe it does not work for some PC-configurations...
Theophany Feb 6, 2016 @ 2:26am 
Originally posted by Vantskruv:
Are you sure the configuration file is set to read-only, and even though it is, checked that it is not changed by the game?
I noticed that the game unchecks the "read only" box, not sure if it reverses all the changes tho.
Vantskruv Feb 6, 2016 @ 3:18am 
Happened the same with me on Linux, but solved the Linux way.
Should it not be possible to that in Windows, i.e. setting write only for administrator sort of?
Odd fella Feb 6, 2016 @ 3:32am 
Did the official reviewers such as IGN mention this issue?
Vantskruv Feb 6, 2016 @ 5:27am 
They are probaly paid, therefore not trustable. Note though not everyone have these problems...so previous statement may not be the case (this is just a assumption).

Anyway, the changes I made in previous posts, makes the game almost stutter free and the performance is relative good on low graphics settings. I like the graphics and the game is awesome. Let us wait and give the devs a chance to patch and optimize the game, hopefully in the end the game will run great (even though I'm irritated they have not optimized and tested enough before release).
Theophany Feb 6, 2016 @ 6:10am 
Reviewers mentionned performance issues (IGN, Total Biscuit...), actually it's one the first points about the game I encountered when I googled "xcom 2 review" wednesay.
Same goes for the forum, plenty of performance concerned threads before the release.

I prepurchased the game wednesday in the evening, knowing about performance issues, knowing about the controversed turn limit in a lot of missions. And I did it while having access to the same information network than everyone else -> internet
Those claming they bought the game without knowing about turn limit and performance issues because it was HIDDEN by Firaxis or the reviewers and not because their own LACK of any research are lying (to themselves as well ?).

You can even see performance issues in Firaxis streams of the game, so it's not like we have been cheated or misinformed^^


Anyway, thank you for the poolsize tip, seems to smooth the game ! And yes there is a way to force read only on Windows : Properties -> Security -> check refuse box of writing for every group/user name.
http://computerstepbystep.com/wpimages/wp8c16e652_01.png
(click on Edit)
ElokoMs Feb 6, 2016 @ 6:33am 
I have 4096 MB VRAM on my card. Should I use 768 as max, like mentioned above, or the 25% value?
Last edited by ElokoMs; Feb 6, 2016 @ 6:37am
< >
Showing 1-15 of 34 comments
Per page: 1530 50

Date Posted: Feb 5, 2016 @ 1:41am
Posts: 34