The Red Solstice
Glenry Dec 27, 2017 @ 9:35am
fullscreen issues?
Hello - I recently tried to head back into the game and I can't seem to get fullscreen to work, and I have no clue why.
I can set the resolutions up to 1440p, which is weird because I'm using a 4k monitor and 4k desktop resolution (I assume the game just doesnt have 4k support, which is fine), but everytime I hit "fullscreen" and have to restart the game, it just opens up into a 1440p window and doesnt stretch to fit the entire screen.

Any idea??

thanks in advance.
< >
Showing 1-14 of 14 comments
magnum  [developer] Dec 27, 2017 @ 1:34pm 
4k is definitely not supported, as to why it wont stay fullscreen i have to check around.
Did you try any other resolution with fullscreen?
Glenry Dec 27, 2017 @ 1:55pm 
Just 1080 (1920x1080), anything lower than that and I wouldn't want to play it anyway. haha. All resolutions tried do the same thing - so 2560x1440, 2560x1600, 1920x1080. All say "fullscreen", but are essentially a windowless border. If I change my desktop resolution to 1440p, than start the game, it goes full screen properly, but I don't see why I should have to do that to play it. :(
ps - thanks for the quick reply!
Last edited by Glenry; Dec 27, 2017 @ 1:56pm
Same issue. 4k monitor and 1080p second screen.
Full screen is a box and changing the resolution only changes the shape, not the size of the box. (ratios change)

Moving a 1080p window onto a 1080p screen results in a window 2/3rds the size of the screen.

Alt+enter does not work nor does switching to fullscreen in the options menu.

Also the mouse doesn't capture on the window so it is essentially unplayable.
Tow3r Jan 16 @ 12:01am 
Same problem here, my monitor has 2560x1080. I'm not able to play in fullscreen, even if I change the game resolution to 1920x1080, I always get a smaller window in the middle of the screen (window borderless) or in the upper left corner (fullscreen).
Last edited by Tow3r; Jan 16 @ 12:01am
Vaguely related issue, the borderless fullscreen option in the game is NOT a true borderless fullscreen, as the screen flickers when tabbing away from it.
zoo Jan 16 @ 5:31am 
Go into your control panel -depending on OS using- or right-click desktop and select your graphics card (your not using onboard are you?) Go through and check the resolution settings inc refresh rate for setup display. Also make sure you have 'maintain aspect ratio' on, so the image will fit the screen.
Glenry Jan 21 @ 5:52pm 
I am not using onboard graphics, no... I don't know any onboards capable of 4k resolution, but I could be wrong I guess. Its a GTX 1070, just a single one, no SLI...
I will do as zoo has directed and see if anything changes. I was away for awhile so I've let these comments go unanswered for awhile and I apologize! Thanks all for their help and contrubutions - I might have stumbled onto a bug of some kind that maybe the devs arent aware of? At any rate, I'm glad I'm not the sole isolated incident.
zoo Jan 22 @ 6:13am 
Also, make sure you don't have DSR on? http://nvidia.custhelp.com/app/answers/detail/a_id/3587/~/how-to-enable-dynamic-super-resolution-in-games.

Especially in Nvidia 'global settings' as it will try and force all games into a higher resolution, regardless.
Last edited by zoo; Jan 22 @ 6:15am
Glenry Jan 22 @ 10:20am 
Nothing has worked thus far, the same problems still occur. And thanks for another idea Zoo, but I've never had DSR engaged on my system because I have a 4k monitor, I don't have any reason to upscale the image.
Sigh - this is really frustrating. All I wanted to do was play a video game! lol
zoo Jan 22 @ 10:53am 
Originally posted by Glenry:
Nothing has worked thus far, the same problems still occur. And thanks for another idea Zoo, but I've never had DSR engaged on my system because I have a 4k monitor, I don't have any reason to upscale the image.
Sigh - this is really frustrating. All I wanted to do was play a video game! lol

May i suggest deleting the config and letting it generate a new one
https://pcgamingwiki.com/wiki/The_Red_Solstice#Configuration_file.28s.29_location

C:\Users\username\AppData\Local\TheRedSolstice Make sure you have 'show hidden' folders enabled

Within the settings.ini file you will see the following;

copied from my laptop hence the weird resolution
win.fullscreen = "true"
win.height = "768"
win.noborder = "true"
win.width = "1366"

Try editing it (to the resolution you want) and then save the settings file and then make it 'read only' so that it can't be changed.

If that doesn't work then delete it -nothing to loose.
Last edited by zoo; Jan 22 @ 10:53am
fodder Apr 17 @ 8:36am 
generating a new one just gives you the desktop resolution (ie.. 4k borderless window).
Using an ultrawide monitor here, 2560x1080, and it is working properly. Cutscenes and in-game.

Please try going into your Nvidia panel --> Adjust desktop size and postion --> Override the scaling mode set by games and programs.

I have "Perform scaling on" to Display.

Select a scaling mode: "Aspect ratio"

I have seen others set these differently but these settings have worked for me in all of the games I play. You will probably get black bars on cutscenes in games, but that can be fixed with a hex editor if you know what you're doing!
The author of this thread has indicated that this post answers the original topic.
I've got a thread that details how to fix this issue here for 4k resolution, should work for you: https://steamcommunity.com/app/265590/discussions/2/3377008022025819462/
Glenry Apr 28 @ 3:45pm 
Thanks to all that replied - not sure which fixes worked for which people, but the most recent solution posted by [RX]Taksi worked perfectly for me and solved my issue. I have copied and pasted the information from his link below.
Thanks again!!! I can FINALLY play this game! haha.

There are a few steps for 4K in TRS:

Part 1 - Fix the game's DPI :
1) Find the TRS "Game.exe" executable. From Steam Library right click -> Properties -> Local Files -> Browse Local Files -> "bin" folder
2) Right click "Game.exe" ->Properties
3) Select the second tab "Compatibility"
4) Check "Override high DPI scaling behavior", Scaling Performed by "Application"

Part 2 - Add the resolution to the ini file
1) Find your "settings.ini", but don't be fooled by the one in that folder!
2) From windows explorer, the path should be: "%APPDATA%\..\Local\TheRedSolstice" or your local app data directory if that doesn't work.
3) Open settings.ini in notepad or the editor of your choice
4) Change the following lines to match this:
win.fullscreen = "true"
win.height = "2160"
win.noborder = "false"
win.width = "3840"

Part 3 - Profit!
1) Have fun on Mars
Last edited by Glenry; Apr 28 @ 3:46pm
< >
Showing 1-14 of 14 comments
Per page: 15 30 50