CONSORTIUM
CONSORTIUM > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
Stesen  [developer] Apr 30, 2015 @ 12:06pm
Wine Support
Hello everybody!

I'm quite pleased to announce that I have just completed a full playthrough of Consortium under Wine 1.7.33 (PlayOnLinux) on Ubuntu 15.04. While the experience isn't perfect, we have done what we can to get it working in the continued absence of a native port. Now that I can confirm it's (essentially) fully playable, I thought I'd share this with any Linux gamers who might see it.

First off, a few notes:

  • This is NOT, nor is it intended to be, a replacement for a native Linux port of Consortium, and nor is the development of one off the table. It is simply a way to fill the gap in the interim, given that getting the game at least acceptably playable under Wine was a plausible short-term goal. While a native Linux port cannot be 100% guaranteed, it is VERY likely that one will eventually come. We currently have some talented people working on finishing the OSX porting effort (which WILL 100% be forthcoming!), and given that OSX is a Unix-based operating system, going from there to Linux should not be a particularly tall order.

  • Since this is not yet an official port, I cannot say that support is 100% official. Please do not flood the iDGi inboxes with support emails if things don't work as expected. Linux systems can vary wildly and I'm currently the only Linux user on the team (as far as I'm aware). I do follow these forums pretty closely, however, and I will happily try my best to troubleshoot any issues that you post in this thread. Just don't expect me to work miracles if your system configuration is considerably different than my basic Ubuntu.

  • I make the assumption, for sake of at least some degree of brevity, that if you're reading this thread, you know how to install Wine and get Steam itself running in it. If not, I suggest you look up PlayOnLinux. It provides fairly pain-free setup and it's what I used if you're looking for the greatest consistency with my setup. You can, of course, also just use a non-Steam build of Consortium if you have one.


Now! On to business!


Setup:

There really isn't a ton of work necessary to get the game running. Just a couple of tweaks.

First: The Steam in-game overlay MUST be turned off. If this is left on, the game will crash at the first keyboard/mouse input you give it.

Second: Due to issues with Wine and our shaders, the game's static FX (quantum signal distortions) must be disabled. To make this a persistent change, create a file in consortium/cfg in the game's installation directory called autoexec.cfg with these two lines:

r_signal_fx "0"
host_writeconfig

Then add the following arguments to the game's launch options:

+exec autoexec.cfg

This setting can also be set in the in-game developer console. Note that setting via the console is NOT persistent.

If this is not turned off, you will not be able to see most of the time.


And that's it! That's all you should need to do.


A few more notes:

Due to some more baked-in FX that can't be as easily disabled, you will not be able to see during the very beginning and end of the game (when you're in "quantum limbo"). For the beginning of the game, I've provided (linked at the bottom of this post) a save file right after that opening sequence. For the end of the game, you'll have to muddle through in the dark (your games will all be different then, I can't make a save for that). However, this is fairly easy: As soon as you see the thing you're approaching at the end of the game (the Churchill Tower) come into view, remove your hand from the mouse. When you find yourself in the void, tap the D key a couple quick times (you don't spawn perfectly lined up), and then just hold W.

Regarding performance: My framerate fluctuated between fantastic and meh. Overall, it averaged to a bit lower than in Windows, but never seemed particularly unplayable to me. More-or-less typical for Wine games.


Other known Wine bugs:

  • You may find if you leave the main menu open for too long, or sometimes just randomly when initially loading the game, that sound is REALLY distorted. If this happens, restarting the game SHOULD fix it. If you're more than a few seconds into playing the game and it hasn't happened, you should be good. This does not seem to apply to leaving the pause menu open.

  • Once had the movement controls get stuck after a map change. Again, restarting the game fixed it. Only happened once.

  • Immediately following a Steam update, I found the game unplayable (it loaded in an even worse distorted sound state and a stupid-low framerate). The game worked again after I rebooted. Considering this only ever happened after a Steam update, I'm currently connecting the two.

  • The moving walls in the minigame flicker ever so slightly, and it fails to hide the system cursor.

  • The signal bar likes to sit at "awaiting instructions" sometimes. But I think this might actually be tied to turning static off.



That's it! Enjoy!


Save file for beginning of game:
Save for Steam & Humble versions: http://interdimensionalgames.com/files/1__1430344287.sav
Special save for GOG version (saves are incompatible with other two): http://interdimensionalgames.com/files/1__1435003344.sav

Usage: place this in consortium/SAVE/[your Steam account #] inside the game's installation directory. For non-Steam versions, the save file will just be directly inside the SAVE folder.

This save file is configured to appear under Universe 1. If you'd like to a use a different universe, just change the first number of the filename before inserting.
Last edited by Stesen; May 18, 2016 @ 11:59am
< >
Showing 1-15 of 27 comments
jlddodger Jun 19, 2015 @ 3:28pm 
Hi, I followed your instructions above, but it seems that Consortium is deleting your provided save file everytime it loads. Did I miss something? I put the file in .\consortium\SAVE.
Stesen  [developer] Jun 19, 2015 @ 5:54pm 
Are you using a Steam version of the game? If you are, it needs to go in a subfolder of SAVE that has your Steam ID# as its name. It just occurred to me that the game might not make that folder until you've saved at least once. Never thought of that before. Try starting a new game, saving in the darkness, and seeing if the folder with your account ID is created. It shouldn't delete anything you put in there.

If that's the solution, let me know so I can edit the instructions above.
Stesen  [developer] Jun 19, 2015 @ 5:55pm 
If it's a non-Steam version... then that's just odd. In that case I'll need to download a non-Steam build to my machine and do another test with that in a new prefix.
jlddodger Jun 21, 2015 @ 7:34pm 
Okay, so here is what I did. I removed the SAVE folder. I started a First Time game and the saved when I had control. The SAVE folder then was created and contained:

- 1__1434939977.gsav
- 1__1434939977.sav
- 1__1434939977.tga
- zenlil_1.hl1
- zenlil_1.hl2
- zenlil_1.hl3

I added the 1__1430344287.sav file to this folder and then started Consortium. When I selected to load from save, I only saw my save game that was still in the blurry area, but not the other game. When I exited Consortium I noticed that the 1__1430344287.sav file was gone.

I am using a non-steam copy of the game. Specifically, I bought it through GOG Games.

Thanks for your assistance.
Stesen  [developer] Jun 21, 2015 @ 7:56pm 
That is absolutely bizarre. I'll grab a non-steam build to my Ubuntu and test that myself. I'm not aware of any code to clear out that folder (considering dropping the files in there is literally all we do when we ask for them to help find bugs).
Stesen  [developer] Jun 22, 2015 @ 1:30pm 
Okay. I can confirm that the GOG version of the game is deleting my save. That doesn't really make sense, but my best guess is that there's something different about Steam saves that is triggering the GOG version's mechanism to delete old, incompatible saves.

Following that, here is an equivalent save made with the GOG version of the game:
http://1drv.ms/1H9E0uX

See if that one takes.


Also, in playing around I've discovered a 100% foolproof way to prevent the game from deleting the config line that turns off the broken FX. Rather than editing config.cfg directly, make a file in the same folder called autoexec.cfg, add the following two lines to it:

r_signal_fx "0"
host_writeconfig

And then add these arguments to the game's shortcut/desktop item/terminal command/however else you're launching it:

+exec autoexec.cfg

(I'll edit that last bit back into my instructions)
jlddodger Jun 22, 2015 @ 8:15pm 
It worked. The GOG save file made the difference. I only played about a minute before I had to relinquish the computer, but the interface worked well. I'll post more when I have played more.

Double thanks.
Stesen  [developer] Jun 22, 2015 @ 9:11pm 
No problem.
Glad to hear it!
jlddodger Jun 24, 2015 @ 6:41pm 
So, I frustrated the heck out of myself. I finally realized that the Keyboard configuration was mostly disabled (e.g. I couldn't holster my weapon or open my inventory). Once I restored the defaults and changed a few bindings, everything went much better.
Stesen  [developer] Jun 24, 2015 @ 9:28pm 
Huh. That's odd. And after you fixed the keybindings, you could still see? (making sure those autoexec lines I gave you aren't somehow in conflict with normal functionality)
jlddodger Jun 25, 2015 @ 5:10am 
Yes. I could. There were a couple times when the lights in a room turned off at a strange time, but otherwise things seem to function normally.
Stesen  [developer] Jun 25, 2015 @ 8:59am 
Alright! Good to hear! Let me know if you have any more issues!
Cinnamon May 18, 2016 @ 11:52am 
Links for saves are brokens. WOuld it be possible to fix that?
Stesen  [developer] May 18, 2016 @ 12:00pm 
Sorry about that! I just made new ones. Edited them into the main post.
Cinnamon May 18, 2016 @ 8:01pm 
Thanks!! ^^
< >
Showing 1-15 of 27 comments
Per page: 15 30 50

CONSORTIUM > General Discussions > Topic Details