World of Guns: Gun Disassembly

World of Guns: Gun Disassembly

View Stats:
Shinken Jan 12, 2016 @ 2:40pm
[Linux] HOW TO: fix crash on startup (OpenGL problem)
I did it! It works again!

If you want to play on Linux and run into the problem that you only get a black window which disappears very fast when you launch the game this might help:

1. find out which opengl and mesa version you got:
Get glxinfo:

sudo apt-get install mesa-utils

try this command:

glxinfo | grep "OpenGL version"

if you get 3.3 or newer you're good (or it's another problem). If you only get 3.0 you need to look at your mesa version. It should at be at least 10.4.X. If it's older you need to update it.


2. Update Mesa in case you have an old version:
The best way to update it is by upgrading to a newer Kernel release version of your distribution. For example when you have Ubuntu 14.04 (Trusty) you can upgrade with this command to the currently (January 2016) newest Trusty version (3.19):

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libgl1-mesa-glx-lts-vivid libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid:i386

It may destroy your installation though, so be careful. Here's more info on the topic:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

There are probably also other methods to get newer mesa drivers which work with other distributions as well. You'll find them :-P.


3. Force OpenGL 3.3:
The game may already work when you update mesa, but there's a chance this is not enough, esp. when you use an Intel graphics card. You may need to force the newer OpenGL version as well!
You can do this by going into the properties of WOG in your library and click on "set launch options...". Add

MESA_GL_VERSION_OVERRIDE=3.3COMPAT %command%

and save. This will set the environment variable to force the new opengl version when you start the game.


--------------------------------------------------------------------------------------------------------------
--------------------------------------------------------------------------------------------------------------

Old Post:

It worked before but now I just get a small black window which disappears very fast.

I'm using Ubuntu 14.04

Here's the Player.log from /home/user/.config/unity3d/Noble Empire/WOG:
http://pastebin.com/0SVj0n3c

EDIT:
Seeing this line in the Player.log:
"PlayerInitEngineGraphics: GPU not supported; OpenGL 3.2 is required. Your GPU (Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2) or OpenGL drivers only supports OpenGL 3.0"

I tried manually updating my mesa drivers (which were very old because I'm using the LTS) to a version which actually supports OpenGL versions beyond 3.0 on my graphics card (which is technically capable of 3.3)

It didn't helped though :(

EDIT2: Apparantly the new mesa driver didn't install correctly and I had to revert back to the old one. Upgrading the drivers with my Ubuntu version (14.04.3) seems to be complicated - I better wait for 14.04.4 which is scheduled to be released in February which should come with updated drivers.

Anyway it is annoying because the game worked before. Why did you upgrade OpenGL version of the game?

EDIT3: I managed to update my kernel to 14.04.03 (it was stuck at 14.04.02) which has Mesa 10.5.9 which should support up to OpenGL 3.3 - in theory.

The problem is that the Intel graphics part of mesa still only supports 3.0 and probably does so in the forseeable future.
There's the MESA_GL_VERSION_OVERRIDE=3.3COMPAT argument which maybe helps? I have no idea how to feed this to a steam game though.
Last edited by Shinken; Jan 13, 2016 @ 2:50am
< >
Showing 1-14 of 14 comments
Shinken Jan 13, 2016 @ 2:35am 
BTW I still think this is a horrible decision by the developer.

It's the equivalent of having a DirectX 9 (=OpenGL 3.0) game and then force DirectX 10 (= OpenGL 3.2/3.3) unannounced in an update two years after release.

Great way to make your customers angry.


Also Linux usually lags 2-3 years behind in graphics drivers thanks to not being a top priority for intel, amd etc.
So it's the equivalent of having a DX10 only game in 2012. Only a few bleeding edge tech games did that back then like Battlefield 3 or Assassins Creed III, which are probably not the benchmark WoG graphics can be compared to.
Last edited by Shinken; Jan 13, 2016 @ 2:51am
-=NE=-  [developer] Jan 13, 2016 @ 9:53am 
Originally posted by Shinken:
BTW I still think this is a horrible decision by the developer.

It's the equivalent of having a DirectX 9 (=OpenGL 3.0) game and then force DirectX 10 (= OpenGL 3.2/3.3) unannounced in an update two years after release.

Great way to make your customers angry.


Also Linux usually lags 2-3 years behind in graphics drivers thanks to not being a top priority for intel, amd etc.
So it's the equivalent of having a DX10 only game in 2012. Only a few bleeding edge tech games did that back then like Battlefield 3 or Assassins Creed III, which are probably not the benchmark WoG graphics can be compared to.
Sorry, Unity did this....
Shinken Jan 13, 2016 @ 10:43am 
Originally posted by -=NE=-:
Sorry, Unity did this....

I'm pretty sure you can force Unity to use "legacy" opengl modes
http://docs.unity3d.com/Manual/OpenGLCoreDetails.html

I would recommend doing this, if it's somehow possible.

Even if it's only a short term solution as Unity drops legacy OpenGL support in 5.5 in June, it would give many Linux players much needed time. When we have the next LTS versions for the big Linux distros next spring would be much better time to jump to OpenGL 3.X, because then most users probably have reasonably fresh drivers by default when they switch to the next LTS versions.

Thank you for listening! :D
Last edited by Shinken; Jan 13, 2016 @ 11:54am
Jet Jaguar XP Jan 13, 2016 @ 3:50pm 
Setting the "Launch Option" below as explained by Shinken worked for me.

MESA_GL_VERSION_OVERRIDE=3.3COMPAT %command%

Oh, and installing the latest Intel graphics drivers for Ubuntu 15.04.
Last edited by Jet Jaguar XP; Jan 13, 2016 @ 3:51pm
-=NE=-  [developer] Feb 5, 2016 @ 6:10am 
it seems like UNity got new update with another try to fix the issue with Intel for Linux...
THESASSYPANDA Feb 28, 2016 @ 5:30am 
guys it still doesnt work for me im a linux noob and im using KDE plasma and my graphics card is a nvidia nvs 150 if that helps
Binnie Jun 8, 2016 @ 7:17pm 
I had to also add MESA_GLSL_VERSION_OVERRIDE=330 (on Linux Mint 17.3 64 bit, Intel GPU).
Mx. Blue Skye Jun 12, 2016 @ 7:25pm 
im using 12.04.

how do i update it?
White Rabbit Aug 10, 2016 @ 2:10pm 
I'm on Debian Stable, OpenGL version string 4.5.13399, but I only got the crash when I tried to turn on AA in-game. Uninstalling and re-downloading didn't work, so is there any way I can change the settings in a config file?
i need info in spanish
nulipo Oct 12, 2016 @ 4:47am 
I get this:
OpenGL version string: 4.5.13399 Compatibility Profile Context 15.201.1151
Yet I still see only black screen when starting game.
这上面说的是什么?
Burnout Nov 21, 2016 @ 9:51am 
Yay! Since the last few updates WoG just works under Linux. I've played for ~3hrs and had no problems at all. (Kubuntu 14.04 AMD GPU)
:steamhappy:
Last edited by Burnout; Nov 21, 2016 @ 9:51am
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Date Posted: Jan 12, 2016 @ 2:40pm
Posts: 14