Cube & Star: An Arbitrary Love

Cube & Star: An Arbitrary Love

View Stats:
I seem to be having trouble getting some of the achievements for buildings and for meeting certain creatures. Is there something I'm missing?
< >
Showing 1-15 of 70 comments
Fritz  [developer] Feb 16, 2014 @ 12:43pm 
I'll check it out on my side - it could be an issue with the newest update (might have missed an import or something).

I'm testing as we speak.

I'll keep you posted!

Armok: God of Blood Feb 16, 2014 @ 12:56pm 
Thanks. I'm also not entirely sure how joy, logic, and passion work together. It's like semi-random color combination where the color produced by one combination can range from gray to vibrant hues.
Hmm, after the last update that just came achievements don't seem to work anymore at all I noticed. They're listed in-game (on the full list) but don't appear as they unlock, neither in the game nor in steam.
But in general I have to say that the achievements are a great help to learn and understand the game more, where not much explanation is given, I really like it!
Fritz  [developer] Feb 16, 2014 @ 9:56pm 
Hi Dallus - what platform are you on?

The most recent update added both 32 and 64 bit PC...

Oh man. And just as I typed this... I realised the issue.

I'm using a 32-bit Steam library. I need to switch it out for 64-bit.

Thanks for your kind words on the Achievements! I really love achievements. It's kind of like... that one thing we don't get in life: A list.

I guess that's why people like the Bible!

I'll fix that post-haste and pop out another update.

yea, 64-bit, that might be it. Thank you! :D
squerc Feb 17, 2014 @ 1:54pm 
I'm not gettin any ach either, I'll wait for that to be fixed to start my journey here so, gogo fix it asap
Originally posted by squerchh:
I'm not gettin any ach either, I'll wait for that to be fixed to start my journey here so, gogo fix it asap
One does not simply command the devs! Begone! :spazterror:
Fritz  [developer] Feb 17, 2014 @ 10:15pm 
The plugin for achievements I'm using just, _just_ - the day before I implemented it - took away 64-bit support.

So I'm adding a new plugin as we speak.

I'm on the case!

Fritz  [developer] Feb 17, 2014 @ 10:47pm 
I've just wound back the 64-bit build to be in line with the 32-bit build - so your achievements should be working as expected now (hopefully - unless it's something insane that isn't appearing on my side. Buuuuut it shouldn't be. Life wouldn't hate me that much).

Once I've got this plugin all sorted - I'll nudge it back up to 64-bit.

It's still not counting or unlocking on my side - just on the list in-game as before :o
Tried several restarts of the game and steam, but nothing.
They're working fine for my friend who just started playing tho. Must be the 64-bit thing still, idk.
Fritz  [developer] Feb 17, 2014 @ 11:36pm 
The steam backend hasn't updated yet I think - I've not the new version through on my side yet.

I think it takes a little to push through. I'll refresh here, see what happens.

Edit: My mistake - it has. It must be something else. Give me a little, I'll see what I can come up with.

Last edited by Fritz; Feb 17, 2014 @ 11:38pm
squerc Feb 18, 2014 @ 5:05am 
for what I see my achievments do unlock now thx
Fritz  [developer] Feb 18, 2014 @ 8:55am 
Oh that's excellent news! A good way to start the day thanks squerchh.

I'll keep working on the 64-bit version - and update soon.

taytothief Mar 5, 2014 @ 6:44pm 
Achievements aren't working for me here. They're working fine in-game, but not showing up on Steam.
Kitusss Mar 11, 2014 @ 10:47am 
Same here. I still can't unlock any Steam achievements, even though I'm quite certain I should have a lot of them by now.
< >
Showing 1-15 of 70 comments
Per page: 15 30 50