Mount & Blade II: Bannerlord

Mount & Blade II: Bannerlord

Apaukolypse Nov 30, 2021 @ 6:49pm
Game keeps crashing when doing battles near the Aserai.
I am using a few mods, but one of them is BetterExceptionWindow, and it tracked the XML issues to the Native module, mainly the maps in the area.

Any fixes?
Originally posted by TaleWorlds Community Team:
Hi Apaukolypse!

Sorry to see you're experiencing this issue! If you are using any mods that can be causing this issue, you can try to remove them and see if this solves your problem.
https://steamcommunity.com/app/261550/discussions/17/2968397584539744282/

In case this doesn't solve your problem; I'm moving this thread into the [EN] Technical Support board for our support members to check, thanks for reporting.
< >
Showing 1-7 of 7 comments
Deluxe Dec 1, 2021 @ 3:55am 
It still can be caused by the mods, if they provide parameters to the native module, it is not able to deal with. Since I (and probably others as well) did not face this issue, I guess it is caused by a mod.
A moderator of this forum has indicated that this post answers the original topic.
Hi Apaukolypse!

Sorry to see you're experiencing this issue! If you are using any mods that can be causing this issue, you can try to remove them and see if this solves your problem.
https://steamcommunity.com/app/261550/discussions/17/2968397584539744282/

In case this doesn't solve your problem; I'm moving this thread into the [EN] Technical Support board for our support members to check, thanks for reporting.
elysebluemoon_TW Dec 2, 2021 @ 7:33am 
Unfortunately, we cannot offer technical support for modded games and I cannot forward this to the developers without first making sure that mods aren't causing the problems. Please read our full statement regarding modding related issues.
https://steamcommunity.com/app/261550/discussions/17/2968397584539419311/
As save files remain altered and some leftover mod files remain even after deleting the mods, a clean install and creating a new campaign is necessary to see if the problem is isolated to the modded game or if it's a problem from our end.
Alternatively, I can move this thread to the General Discussions board where the community might help with which mod is or isn't compatible with the game's current version, or you can contact the mod developers.

Please let me know when you can perform a clean install and test this on an unmodded new campaign.
(BSS-4150)
Apaukolypse Dec 2, 2021 @ 8:12pm 
Originally posted by elysebluemoon_TW:
Unfortunately, we cannot offer technical support for modded games and I cannot forward this to the developers without first making sure that mods aren't causing the problems. Please read our full statement regarding modding related issues.
https://steamcommunity.com/app/261550/discussions/17/2968397584539419311/
As save files remain altered and some leftover mod files remain even after deleting the mods, a clean install and creating a new campaign is necessary to see if the problem is isolated to the modded game or if it's a problem from our end.
Alternatively, I can move this thread to the General Discussions board where the community might help with which mod is or isn't compatible with the game's current version, or you can contact the mod developers.

Please let me know when you can perform a clean install and test this on an unmodded new campaign.
(BSS-4150)

Thank you for your help!

I will go ahead and try a couple of things:

First, I will try running the game without any mods. Guess it shouldnt be too hard for me to just run over to Aserai land and start a siege in a fresh game.

If the problem still persists, I will try a clean install.

Im not sure if its any help, but the exception window mod I was using tracked the issue to. Native > Atmospheres -> Interpolated, and it was basically every xml file in that folder.

Will update on how things go. If it is the mods that are the issue, then yeah, I am gonna assume I would have to go elsewhere for help.
Apaukolypse Dec 2, 2021 @ 8:35pm 
Strange.

I was able to fight battles with Desert bandits in places that caused me to crash earlier. (In fresh Modded AND Unmodded saves).

I also walked around the castles and towns whos sieges I would crash trying to load into earlier (Modded AND Unmodded).

I'm not really sure what to think. The BetterExceptionWindow mod told me the exception was coming from the earlier filepath, it said the crash was happening because "No index within range" or something to that effect.

Confusing. I wonder if the crashes were caused by a specific unit that I haven't run into in my fresh saves? The mods I am using DO add new units, and the crash happened specifically when I was fighting the Aserai in that area.
elysebluemoon_TW Dec 3, 2021 @ 2:29am 
Could you get in touch with the mod developer and ask them if their modifications alter these xml files?
elysebluemoon_TW Dec 16, 2021 @ 12:01am 
As the required information was not provided within 2 weeks, this thread is moved to the Resolved Issues board. If the issue still continues, please create a new thread.
< >
Showing 1-7 of 7 comments
Per page: 1530 50

Date Posted: Nov 30, 2021 @ 6:49pm
Posts: 7