Lifeless Planet

Lifeless Planet

View Stats:
 This topic has been pinned, so it's probably important
David Board  [developer] Mar 25, 2016 @ 12:11pm
Linux Version Live!
Happy to announce the Linux/SteamOS version is now out of beta! For those using the beta branch, you can now play the game as you did before without going through the betas tab. The version is unchanged from the last beta so you shouldn't notice any differences.

Please let me know if you encounter any issues--especially on SteamOS.

-Dave



-------------------------------------------------------------------------------
Archiving the old beta notes in case we run into any issues:

Hi guys, I'm happy to finally make the Linux Beta available for your review. This is an "early access" of sorts in that I need the community's help to test out this build and let us know if it's working well.

Hardware requirements should hold pretty close to the PC (windows) specs. In regards to Linux, you'll need a 64-bit OS.

Known Issues:
-There's no Steam Achievements support right now. - FIXED?
-We noticed choppy sounds at the start of the game.

If you've purchased the game, here's how you get access to the Linux beta:
1. Open properties for Lifeless Planet in your Steam library (right click game title)
2. Go to the Betas tab.
3. Enter access code: "mysteriousPlan"
4. Select "devbeta2 - Linux Beta" from the list

Please understand this is an early Beta and our first go at a Linux build for any game... so apologies in advance if it fails to run or is buggy. If you don't want to help testing, better to wait for the final release. THANK YOU in advance for those of you who can provide feedback and help with this project. I can only provide my thanks, but it's a very sincere thanks!


EDIT - Dec 25, 2016

The new beta is up! Improved graphics from the PS4 release (running on Unity 5 now, new player model, etc). We think all known bugs including steam achievements are fixed. Please check it out with the instructions above, and we'll set it official in a few weeks if all goes well. Thanks as always for your support!

-Dave
Last edited by David Board; Feb 1 @ 12:22pm
< >
Showing 1-15 of 114 comments
hchilde Mar 25, 2016 @ 12:41pm 
Lifeless Planet is not available on on your current platform
psymin Mar 25, 2016 @ 12:43pm 
I've got the game in my library, but it isn't visible under linux in the linux client yet. If we could see it, we could enable the beta :)

Edit: My bad, I can see it in the windows games list, but it needs to be visible under linux for it to be able to be installed. Sorry for speaking incorrectly :)
Last edited by psymin; Mar 25, 2016 @ 12:56pm
psymin Mar 25, 2016 @ 12:46pm 
One of the things that probably needs to happen is have depot ID 261533 associated with package 33769 and maybe 44151 as well. That depot is the linux depot and those IDs are for the store or cd key copies.

Edit: I see that the proper depot is associated with package 33768 "Lifeless Planet Developer Comp" so that means it probably works for you but not us :)
Last edited by psymin; Mar 25, 2016 @ 12:49pm
dubigrasu Mar 25, 2016 @ 12:51pm 
Well, I can see it and already enabled the "devbeta2 - Linux Beta" but still no download (not my platform).
psymin Mar 25, 2016 @ 12:55pm 
Also, Step 3 and Step 4 should be switched. Looks like the beta option is revealed after entering the code. Still no linux though.
Micha Mar 25, 2016 @ 12:56pm 
Thanks really looking forward to play Lifeless Planet.

Unfortunately, it doesn't work for me. I entered the code and selected the beta but I cannot install it because steam says it's not available on my platform.

What's odd about it that normally the name of the beta is written in brackets next to the game's name in my library but not this one. Also after I restart Steam the beta is not selected anymore. I hope this helps figuring out what's wrong.
TinMan1325 Mar 25, 2016 @ 2:24pm 
Thanks for bringing this to Linux, I bought it quite some time ago assuming it would get ported and it's finally here :)

I'm also experiencing the same as everyone else. I enter the code and then select the beta but I'm still not able to install the game
adolson Mar 25, 2016 @ 2:33pm 
I obviously have the same issue, but am really looking forward to testing it out!
David Board  [developer] Mar 25, 2016 @ 4:22pm 
Ok, sorry for the mix-up... working on it!
David Board  [developer] Mar 25, 2016 @ 4:26pm 
Ok give it a go now...
TinMan1325 Mar 25, 2016 @ 4:28pm 
Downloaded 0 bytes/ 0 bytes

Also, in your OP, steps 3 and 4 should be switched around. You have to enter the code first then you can select the beta
David Board  [developer] Mar 25, 2016 @ 5:03pm 
Thanks, I fixed the steps... Also edited the beta setup, so hopefully works now.
TinMan1325 Mar 25, 2016 @ 5:05pm 
It's still not downloading anything for me. The install option is there but it isn't downloading
adolson Mar 25, 2016 @ 5:13pm 
Downloading 540MB here. Thanks!
David Board  [developer] Mar 25, 2016 @ 5:13pm 
Try switching out of the beta (opt out) from the betas tab, delete files (if any) and then switch back... I really think it's set up right now. It's possible Steam just needs some time to push out the changes...
< >
Showing 1-15 of 114 comments
Per page: 15 30 50