Assassin's Creed Liberation

Assassin's Creed Liberation

View Stats:
Hyun Jan 17, 2014 @ 9:41am
Really Low FPS
Am I the only one getting really low fps?
Heres a vid I made with fps display:

http://www.youtube.com/watch?v=SwdjalXCOU0

Im not sure if its a driver issue or whatnot...
But Im pretty sure I should be getting almost double fo that.
Or is this just another terribly optimized ubisoft crap?lol
Last edited by Hyun; Jan 17, 2014 @ 9:45am
< >
Showing 1-15 of 21 comments
Spawk Jan 17, 2014 @ 10:24am 
Disable AA. Problem solved.
☩ SVERIGE ☩ Jan 17, 2014 @ 10:51am 
UBISOFT :D
Hyun Jan 17, 2014 @ 10:53am 
Originally posted by Ultimacy:
Disable AA. Problem solved.
Not helpful at all.
I have max AA on BF4 and I get 50-70 fps avg on multiplayer maps.
Spawk Jan 17, 2014 @ 10:54am 
Originally posted by Hyun:
Originally posted by Ultimacy:
Disable AA. Problem solved.
Not helpful at all.
I have max AA on BF4 and I get 50-70 fps avg on multiplayer maps.
The game has a problem with AA at the moment. But hey, if you don't believe me, not my loss.
I don't think Ultimacy is wrong or unhelpful, in that for many games (especially ones ported from handheld systems to PC) this is a good first step. BF4 was optimized extremely well so it could handle AA with no problems, but Liberation HD doesn't have the same level of polish. I like it a lot, it just..doesn't have BF4 level of polish. It's a $20 game, why on earth would it?
Hyun Jan 17, 2014 @ 11:02am 
Originally posted by Ultimacy:
Originally posted by Hyun:
Not helpful at all.
I have max AA on BF4 and I get 50-70 fps avg on multiplayer maps.
The game has a problem with AA at the moment. But hey, if you don't believe me, not my loss.
Lol your first comment made me think youre just suggesting to turn down my settings which is a no brainer.
But if youre saying there is an actual problem with the AA, then Ill try disable it when I get back on.
Noaisin Jan 17, 2014 @ 12:21pm 
Did you try turning off vsync? my fps got way better when I turned it off. :golden:
Hyun Jan 17, 2014 @ 12:29pm 
Originally posted by iiSeanii:
Did you try turning off vsync? my fps got way better when I turned it off. :golden:
I ALWAYS .Always.always.always.always.always
Turn off vsync.
lol.

Oh..but I have it on adaptive + triple buffering in Nvidia control panel.
Spawk Jan 17, 2014 @ 12:32pm 
Originally posted by Hyun:
I ALWAYS .Always.always.always.always.always
Turn off vsync.
lol.
Why? Do none of your games run well enough to warrant Vsync?
Painless Jan 17, 2014 @ 2:05pm 
Personally...
I don't like the tearing. So turning on vsync is usually a must for me.
Although I have noticed that vsync with this game limits your fps to 30.
I remember another game doing that but can't remember it's name.
If I disable vsync my frames jump to 40 to 50.
Keeping in mind I have an older PC with 2 Xeon processors and a GTX 550Ti video card.

I have also noticed that the AA has some black smoke like artifacts associated with it.
Turning off the AA makes it disappear.
Last edited by Painless; Jan 17, 2014 @ 2:06pm
Spawk Jan 17, 2014 @ 3:57pm 
Originally posted by Führer ScHwAn:
Personally...
I don't like the tearing. So turning on vsync is usually a must for me.
Although I have noticed that vsync with this game limits your fps to 30.
Well yeah, but only if your frame rate drops below 60 fps.
I got the same problem. But after I turned off the AA, then I got smooth 60fps
Last edited by MemPhiZ ZX - #RIPStanLee ;_;; Jan 17, 2014 @ 4:09pm
em_t_hed Jan 17, 2014 @ 7:12pm 
really low fps in new york...
Stewi Jan 17, 2014 @ 10:35pm 
Vsync and AA off, then I pulled shadows down to medium. I can't really tell the difference between medium and high shadows in this game.
rzn6jw Jan 17, 2014 @ 11:16pm 
I've had extreme stuttering since I installed the game. Turned off AA, VSync, other parameters to NORMAL, forced AA and VSync with triple buffering and still can't stop the stuttering. It's like 20fps, 5fps, 20fps, 5fps, etc. I'm running Win 7 Pro 64-bit with an AMD Phenom II x6 1100T BE and two GTX660s in SLI with 32G DDR3 1600 memory. I've even tried running with SLI disabled and it didn't matter.

AC Black Flag runs great with all settings maxed and SLI. So what gives with this game? As it stands, it's unplayable on my PC.

I also uninstalled the current nVidia driver 332.21 and reinstalled 331.65 (the driver UbiSoft says they used to test the game against) and it still didn't work. I'd really like my money back!!
Last edited by rzn6jw; Jan 17, 2014 @ 11:18pm
< >
Showing 1-15 of 21 comments
Per page: 15 30 50

Date Posted: Jan 17, 2014 @ 9:41am
Posts: 21