Loren The Amazon Princess

Loren The Amazon Princess

View Stats:
Winter Wolves  [developer] Apr 9, 2015 @ 10:40am
version 1.3.4 with NEW easy uncensor workaround!
LAST UPDATE: I put the beta version now in the live branch, so you don't need anymore to select beta, the workaround will work in the base/live version!
HOW TO UNCENSOR: make sure the game is not running, browse the game installation directory, find a "game" subdirectory in which you'll find a file called censored.txt. Delete it and start the game: now you can choose "Suggestive Contents" in the options screen to enable it.

UPDATE: 23.08.2015 I just uploaded version 1.3.4 which uses a newer version of Ren'Py, with new features:
- scaled fonts: now when playing in fullscreen at higher resolution the fonts won't be blurred anymore but scaled up to match the resolution, very clear to read :)
- fixed Toobar bug: in chapter 2 you must first visit Grimoire to recruit Apolimesho before triggering the dark elves scene, if you took Dora's path in chapter 1

As always let me know if you found any problem. The uncensor trick below is always valid.

OLDER NEWS:
I have uploaded in the beta branch the version 1.3.3 which has the following features:
- uses new Ren'Py version which might fix several issues on some systems (fullscreen problem, etc)
- enables Linux achievements!
- but most importantly allows a new way to uncensor the game on Steam ;) in just ONE easy step: make sure the game is not running, browse the game installation directory, find a "game" subdirectory in which you'll find a file called censored.txt. Delete it and start the game. Voilà!

Screenshots of the procedure:
http://imgur.com/cQlmqrz
http://imgur.com/Ne3EAdl
http://imgur.com/R23oJ60
http://imgur.com/1xwGUgD

Please note: all OSes have same folder structure. So the trick is valid on Windows/Mac/Linux.
You only need to make sure you're in the beta branch (to get on it, click BETA in the properties menu, and the game will update).
Last edited by Winter Wolves; Jan 3, 2017 @ 12:20am
< >
Showing 1-15 of 132 comments
Chizu? Apr 9, 2015 @ 7:31pm 
Awesome, the nice simple way to uncensor it is a great addition.
Winter Wolves  [developer] Apr 10, 2015 @ 12:18am 
Cool, once enough people tell me that the beta works fine (there are several changes to the engine) will make it the default version!
[255]ThePhiphi Apr 12, 2015 @ 12:01am 
Hi! Thank you for the good work, this game is really good!
I have a problem, though... I don't know if it's due to the new beta or my old saves or my new computer, but I can't play the game anymore...
I had a few different error alerts.
Like "we can't update the game"
or updating worked but "The game can't be launched due to an unknown error"
or game launched and worked but I couldn't load my previous saves :
"I'm sorry, but an uncaught exception occurred. While running game code:
File "renpy/common/_layout/screen_main_menu.rpym", line 11, in script
File "renpy/common/00action_file.rpy", line 285, in python
ImportError: No module named styleclass"

Would you have any piece of advice to make it work? Thanks!
Last edited by [255]ThePhiphi; Apr 12, 2015 @ 12:05am
Winter Wolves  [developer] Apr 12, 2015 @ 12:06am 
You need to post here the errors, but is strange since I was able to load the old saves just right!
Winter Wolves  [developer] Apr 12, 2015 @ 12:37am 
From what you type it seems you mixed two installations somehow, remove everything or install it on another folder and should work.
[255]ThePhiphi Apr 12, 2015 @ 12:53am 
Wow you're fast! Thank you a lot!
Well... I'll try to be more precise, sorry. I've been trying all sorts of things. Here it is:

No beta: Installation is okay, game works. If I try to load one of my saves, I have that error "no styleclass"
If I try to switch to beta, I have an error at the end of the download. "Error during the update (problem when writing on disk)" But I guess that could be my computer's fault...
At that point, if I uninstall and install again without beta, I'll have the same error again and again. I basically have to reboot...(or install somewhere else, you're entirely right!)
If I try to switch to beta again, same result, with or without a reboot.

Now if I reboot and install the beta directly. Well same error...
And oh that's new! I tried to install it elsewhere and it worked! Except now when I launch the game: "executable missing"... or this time "impossible to launch game (unknown error)"
After either of those, I try to check the files and Steam detects a problem and tries to download it and here's the same "error during the update" error... (and no .exe anymore in the file)
I'll try to reboot and test that test, but I won't hold my breath...

Basically, I can't update the game, whatever happens. Maybe a "read only" problem?
Winter Wolves  [developer] Apr 12, 2015 @ 3:23am 
I think you have some file permission error, or some "clever" (hehe) antivirus running that is messing up with the files. Anyway it's something related to your computer (I had no other reports of such problems).
[255]ThePhiphi Apr 12, 2015 @ 4:16am 
For the install of the beta, yes I agree. But for the save file?
Edit: Damn, I didn't change my antivirus, I just had a new version. I just found the "events list" and yes, lorenrpg.exe is there...
Last edited by [255]ThePhiphi; Apr 12, 2015 @ 4:17am
Winter Wolves  [developer] Apr 12, 2015 @ 4:34am 
That error on saves should happen if you try to load from an OLDER version a NEWER save. I have some saves from the original 1.2.8 version that loads just fine in the new one. I'm quite sure of this since I updated all my games on Steam with new Ren'Py+linux achievements, and people can load their old saves from previous version fine.
[255]ThePhiphi Apr 12, 2015 @ 5:20am 
My saves are from the old beta. That's probably why it won't work.
Well I managed to tame my antivirus and all seems better.
Except I now have a "Failed to start game" with beta version only. Not my antivirus' fault.
I also tried to delete Steam's cache, the leftovers in "downloading", and I checked the files' integrity, but no luck.
I'm sure you're doing it on purpose and it works! All day, I've wanted to buy your new game to replace this one =D
Edit: Yeah it worked. I just bought Tales of Aravorn... Thanks!
Last edited by [255]ThePhiphi; Apr 12, 2015 @ 5:58am
Winter Wolves  [developer] Apr 12, 2015 @ 6:47am 
Sorry for all the trouble, but glad you managed to make it work :)
[255]ThePhiphi Apr 12, 2015 @ 6:49am 
Oh no it didn't work. I'll have to wait for next update...
And I meant "yeah it worked" in your favor because I bought the new game. And I'm loving it so far. Thank you a lot!
nice! :) – Let's try!
ThreeSon Apr 13, 2015 @ 5:40pm 
Thank you for this. Just to verify, will Steam achievements still activate when using the uncensored workaround? This was an issue with a previous method I tried.
Winter Wolves  [developer] Apr 13, 2015 @ 11:52pm 
Yes they should work fine!
< >
Showing 1-15 of 132 comments
Per page: 15 30 50