PixelJunk™ Shooter

PixelJunk™ Shooter

View Stats:
Richie123 Nov 13, 2013 @ 3:19pm
Linux version has broken colision detection??
I can't play in linux because everytime I start a game, the ship jumps aroud eratically, and water and lava( as well as the ship) goes right through walls. the survivors usually die right at the beginning of the levels becasue lava or something kills them instantly. strang bug, would apreciate some help. thanks
< >
Showing 1-8 of 8 comments
Liquid_Vegeta Nov 14, 2013 @ 2:40am 
Weird, i'm not getting that...

What set up are you using? I've mentioned in other threads the devs are pretty good at getting back to people but it's not very helpful if you don't let them know your system spec. For example i'm running;

Ubuntu 13.04 32-bit
Intel i5 CPU @ 2.80GHz x 4
GeForce GTX 470 using the binary Xorg driver from nvidia 313-updates

And i'm definitely not seeing this issue, is it in all levels or just one?
m.bryant Nov 14, 2013 @ 6:42am 
Hi Richie,

We are sorry that you have been having difficulties with playing the game.

We have investigated this issue and have found the following on Ubuntu 13.04 32-bit with an NVidia graphics card:

Using the nvidia-310 drivers the issue you described occurs.
Using the nvidia-313-updates drivers the issue you described doesn't occur.

If you are using an NVidia graphics card, can you please try the game with the nvidia-313 drivers or later to see if the issue goes away?
Richie123 Nov 15, 2013 @ 4:09pm 
I am using amd 7950 amdcccle tool says "Driver Package Version 13.101-130523a-157671E-ATI" apt-get says fglrx-updates_13.101-0ubuntu3_i386.deb. I will try the amd driver from their website after I uninstall this one.
Amicus Nov 18, 2013 @ 1:21am 
Can second that I am having the same problems on Linux with AMD GPU, and cannot play the game as a result.

Linux Mint 15 64 bit
8GB Ram
AMD Athlon II x2 250 3.0 GHz x2
AMD Radeon HD 7770
fglrx version 2:12.104-0ubuntu1
Last edited by Amicus; Nov 18, 2013 @ 1:44am
lucifertdark Nov 18, 2013 @ 3:23am 
I'm using the same drivers as Richie but with a Radeon HD 5450 & i'm not seeing this bug.

Ubuntu 13.10 64bit
8Gb Ram
AMD Athlon 64 X2 2.2Ghz
Richie123 Nov 19, 2013 @ 5:24pm 
ok, the game only works with the open source drivers provided with ubuntu. I tried installing 13.25.18 beta driver from amd site, but still no go. I removed all traces of amd fglrx from apt-get before installing too. after reverting to ubuntu drivers, the game works, a bit slow but playable. must be an amd driver bug that needs fixing, or some game+driver combo bug. I amd using ubuntu 13.10 x64 with fx 8520 cpu and hd 7950 gpu.
Last edited by Richie123; Nov 19, 2013 @ 5:26pm
Class Jan 8, 2014 @ 12:24am 
The only collision detection error I get every now and then is when shooting the sand/rock between me and a scientist, which is very little, sometimes they get killed and the rock doesn't reduce.
k.cummins  [developer] Jan 9, 2014 @ 2:48am 

If this is still an issue for anybody, please can you shoot an email across to support@double11.co.uk so that the team can look into it for you?

It would be great if you could state whether you have tried the game with nvidia-313 drivers and what effect this had on your ability to play the game.

If you could include details of your setup, that would also be a massive help!


< >
Showing 1-8 of 8 comments
Per page: 15 30 50