GRID Autosport

GRID Autosport

View Stats:
[LnX]leillo1975 Dec 10, 2015 @ 10:08am
Problem with Linux port: Stops in the first screen
Hello, When I execute the game, It shows a window to configure resolution and other issues. When I push the button to start, the game stops in the Grid Autosport logo.

I try in fullscreen, in a window, at 1080 and 720. I use Ubuntu 14.04.3 64bits, with Nvidia 750ti (358.16) and 16GB RAM. My steam library are located in a NTFS shared partition
< >
Showing 1-15 of 73 comments
Arkdor Dec 10, 2015 @ 10:17am 
Same here on Ubuntu 15.10
[FERAL] Edwin Dec 10, 2015 @ 10:17am 
Please select the option to hide the pre game options panel and launch the game again. It is a compatibility issue with your language code that we will fix in a patch.
0x4C Dec 10, 2015 @ 11:42am 
Same with Debian 64bit, German, Nvidia Drivers installed.
I know it's not supported but everything is set up properly ;)
Looking forward to the fix :)
[LnX]leillo1975 Dec 10, 2015 @ 12:10pm 
Originally posted by FERAL Edwin:
Please select the option to hide the pre game options panel and launch the game again. It is a compatibility issue with your language code that we will fix in a patch.

My system's language is Galician (GL_ES).

If I check the box, the issue is not corrected. But If I lauch the game with

LANG=C %command% the game works great.

Thanks to everybody
Last edited by [LnX]leillo1975; Dec 10, 2015 @ 2:03pm
OG SWAT RV [Linux] Dec 10, 2015 @ 12:19pm 
Originally posted by FERAL Edwin:
Please select the option to hide the pre game options panel and launch the game again. It is a compatibility issue with your language code that we will fix in a patch.

Thank you !
It work for me.
Ubuntu Gnome 15.10x64 , German, Nvidia 358.16
0x4C Dec 10, 2015 @ 1:03pm 
Ok it seems that i actually have versions of libs that are too new O_o
The game demands librtmp0 while in my repo there is only librtmp1 because 0 was the old one in the stable release. Same seems to be with libgnutls where 26 is demanded but i'm at 28.
This packages are in ubuntu 14.04 LTS but if they get updated with 16.04 the newer version should be supported. I'll try to add the older repo and see if i can pin the older versions.

Edit: Nevermind the libs are eventually packaged by steam and are for the launcher. The game crashes even with them. Haha :D
Last edited by 0x4C; Dec 10, 2015 @ 1:18pm
[LnX]leillo1975 Dec 10, 2015 @ 3:03pm 
Originally posted by FERAL Edwin:
Please select the option to hide the pre game options panel and launch the game again. It is a compatibility issue with your language code that we will fix in a patch.


After checking this box I can't change the resolution. Can I re-enable this window?
[FERAL] Edwin Dec 10, 2015 @ 3:09pm 
Originally posted by LnXleillo1975:
Originally posted by FERAL Edwin:
Please select the option to hide the pre game options panel and launch the game again. It is a compatibility issue with your language code that we will fix in a patch.


After checking this box I can't change the resolution. Can I re-enable this window?

There should also be a resolution option in game. I'll look to get instructions on re-enablng the pre game panel and update the thread.
Last edited by [FERAL] Edwin; Dec 10, 2015 @ 3:10pm
Airweaver Dec 10, 2015 @ 3:27pm 
Used the option LANG=C %command% in startup parameter and it fixed the problem. Please fix the locale issue. My language is NB_NO (Norwegian Bokmål).
[FERAL] Edwin Dec 10, 2015 @ 3:44pm 
Originally posted by Airweaver:
Used the option LANG=C %command% in startup parameter and it fixed the problem. Please fix the locale issue. My language is NB_NO (Norwegian Bokmål).


http://steamcommunity.com/app/255220/discussions/0/494631967653501112/?tscn=1449790067#c494631967653526138

We're working on it :)
Last edited by [FERAL] Edwin; Dec 10, 2015 @ 3:44pm
Jose[Linux] Dec 11, 2015 @ 8:21am 
Originally posted by Airweaver:
Used the option LANG=C %command% in startup parameter and it fixed the problem. Please fix the locale issue. My language is NB_NO (Norwegian Bokmål).

In my case (es_ES UTF-8) I needed LC_ALL=C, not only LANG=C.
Chiqui1234 Dec 11, 2015 @ 8:30am 
I downloaded the game and when opens, the game looks like this (my own capture): http://i.imgur.com/s3iL1o2.png
The game sounds and reproduce the trailer movie, but I can't view anything due this problem...
My system is:
i7 3770K, 24GB of RAM and HD 4000 @ 1300MHz.
Last edited by Chiqui1234; Dec 11, 2015 @ 8:31am
[FERAL] Edwin Dec 11, 2015 @ 8:32am 
Originally posted by IceGames:
I downloaded the game and when opens, the game looks like this (my own capture): http://i.imgur.com/s3iL1o2.png
The game sounds and reproduce the trailer movie, but I can't view anything due this problem...
My system is:
i7 3770K, 24GB of RAM and HD 4000 @ 1300MHz.

Intel HD 4000 cards are not supported on this title.

http://steamcommunity.com/app/255220/discussions/0/494631967653421296/
Chiqui1234 Dec 11, 2015 @ 8:34am 
Originally posted by FERAL Edwin:
Originally posted by IceGames:
I downloaded the game and when opens, the game looks like this (my own capture): http://i.imgur.com/s3iL1o2.png
The game sounds and reproduce the trailer movie, but I can't view anything due this problem...
My system is:
i7 3770K, 24GB of RAM and HD 4000 @ 1300MHz.

Intel HD 4000 cards are not supported on this title.

http://steamcommunity.com/app/255220/discussions/0/494631967653421296/
Oh, my bad.
The Intel users can have a support for this game? I have a notebook with a little Haswell i3 and integrated HD 4400 @ 1400MHz... I really like this game, I need it in the notebook! haha :)
Last edited by Chiqui1234; Dec 11, 2015 @ 8:35am
Elring Dec 11, 2015 @ 8:52am 
Disabled "launcher" didn't help me. The game silently crashes (crash.dmp was created in ./local/...../GRID Autosport/crashes) [NV GT630, 4GB RAM, Linux Mint 17.2 (based on Ubuntu 14.04), x64, locale cs_CZ.UTF-8).

Syslog message: OpenGL dispatch[3759]: segfault at 0 ip (null) sp 00007f07bb3663c8 error 14 in GridAutosport[400000+2677000].
Last edited by Elring; Dec 11, 2015 @ 9:20am
< >
Showing 1-15 of 73 comments
Per page: 15 30 50