resident evil 4 / biohazard 4

resident evil 4 / biohazard 4

View Stats:
HaydenK Feb 27, 2014 @ 7:23pm
Slow Motion Fix
--
Note: Those looking for a fix for anything other than slow motion gameplay should look elsewhere. Although, if your issue is something such as crashing on startup or a black screen, try verifying the game cache. In your library, right click Resident Evil 4, then click properties, then go to the "Local Files" tab and click "Verify integrity of game cache..."

If this does not solve your black screen/crashing issues, then I'm sorry to say, I'm afraid I cannot help you. The rest of this post is dedicated to slow motion issues.
--

Update: A much neater, more official guide that you should look at first can be found here, unless you came here FROM that guide, in which case, scroll down to the "Switchable Graphics" section to find the information you came for.

The first thing you should try is settings the frame rate to 30FPS. This has fixed the issue for a lot of people. If this does fix the problem for you, skip to the "Why does the game go in slow motion?" part of this post for a bit more of an understanding. If you would like to have the 60FPS experience, you may have to turn off HD textures and turn down the resolution. Turning off AA will also help. Otherwise, read the following:

** It seems that most of the following applies to laptops. I'm unsure what the issue with desktop computers is as of now, but a lot of people seem to fix it by changing the settings as mentioned above. If you do manage to fix it on a desktop computer without having to downgrade the quality, please post what you did as a comment and I will add it to the main post in the "Updates" section, so Desktop users, be sure to check there if none of the following applies to you!**

IMPORTANT:

1. Laptop users, make sure you have the power supply plugged in, it's a common issue that many people seem to overlook, as most laptops come with an automatic power saving mode that reduces game playability when unplugged.

2. If you wish to change the texture and FPS settings, you must DO IT AT THE MAIN MENU. If you pause the game, there is a way to get back to the main menu through the "Retry or Load" submenu. Just select "Reset" and you'll find yourself back at the main menu, but don't forget to save if you have progressed.

I can't guarantee that this will work for everyone, and it may in fact only work for laptops (unsure on that, but don't just leave if you don't have a laptop, there's lots of information here that could still help you). Many people seem to be launching the game only to find that it runs in slow motion. I first ran the game to find that I had the exact same problem that many people are complaining about, although as an Australian who already had it pre-loaded, I believe I was one of the very first to experience it. Luckily, I found the issue facing me quite easily. Remember, it may not work for you, but kind users have gladly chipped in with some of their tips, so remember to continue reading.

Switchable Graphics

This has been one of the more common problems that people on laptops have been facing.
An issue with switchable graphics that causes the auto-select feature to use the Integrated Graphics GPU to power the game, which in most cases, cannot handle the demand of it.

I have an NVIDIA graphics card, so these instructions to fix the issue only work for NVIDIA, although Fafaffy has applied the same concept in the AMD control center with success, I will quote the post below. **

  • Open the NVIDIA Control Panel (Can be accessed by right clicking the desktop)
  • Click on "Manage 3D settings"
  • Click on the "Program Settings" tab
  • Click "Add"
  • If you have recently launched the game, see if "Resident Evil 4 / Biohazard 4" is in the list. If it is not, navigate to the Resident Evil 4 "Bin32" directory and add "Bio4.exe", which should be located here by default: C:\Program Files (x86)\Steam\SteamApps\common\Resident Evil 4\Bin32
  • After adding the game to the list, make sure that the "preferred graphics processor" is set to "High-performance NVIDIA processor"

Here is a screenshot of what I see after performing the fix: http://i.imgur.com/yxmiI59.png

**
Originally posted by Fafaffy:
I can confirm this fix worked on my AMD laptop.
I had to add Resident Evil as an application, then make it high performance.
Note, it adds the application as 'bio4.exe'

Screenshot for those who may find it useful:
http://i.imgur.com/ZULPrdU.png
Originally posted by Fafaffy:
I'll add more details on how to do my application thing for those with AMD:

1. Right click on the Desktop
2.* Click 'Configure Switchable Graphics'
3. Find, and click the button that says "Add Application ..."
4. Navigate to your Resident Evil 4 binary folder. If your steam games are on the C drive, then it should be here:
C:\Program Files (x86)\Steam\SteamApps\common\Resident Evil 4\Bin32
5. Double click the file called 'bio4.exe'
6. Back on the AMD Catalyst Control Center, under All Applications, you should see a new file called 'bio4.exe'
7. On the column labeled "Graphics Setting", make sure you set 'bio4.exe' to "High Performance"
8. Now, click Apply and you're done.

Thanks, Fafaffy!

*Take note of the fact that slow motion can also occur if your graphics card can't handle the game in the first place. If this is the case, you may have to settle with lowering the game quality, or just put up with the slow motion. Remember, graphics aren't everything. The game it self is what you should look forward to and I heavily recommend the game to anyone interested in buying it.

Why does the game go in slow motion?

Explanation of the game mechanics that lead to slow motion, instead of frame dropping:
http://steamcommunity.com/app/254700/discussions/0/558749190721364172/

If this is the case for you, it means that your computer can't run the game at 60fps as it's too laggy (either because your computer isn't good enough, or for reasons unknown, as of now at least). Try turning your settings down, or continue reading.

As more fixes become apparent, I will update this post to include them.

Updates

Originally posted by wbacon capcom:
SLI / Crossfire users
The game itself isn’t optimized for multi-GPU setups. Some may work, some may not as it hasn’t been tested with those configurations. If you’re seeing significant performance issues with the game despite having equal or better specs than recommended, you may want to experiment disabling SLI/Crossfire as it may be causing compatibility issues.

SLI / Crossfire users, that was an official statement from the developers. It is certainly recommended that you follow this advice, as it may drastically help. I remember seeing one or two comments earlier about the game running fine after Crossfire was disabled and I'm sure that the same would apply to SLI.

Originally posted by Soul:
I don't know if somebody pointed this out, but I was getting the slow motion effect until I went to my NVIDIA settings and set this:

Under Manage 3D settings (you can do game specific or global):
Multi-display/mixed-gpu acceleration: Single Display performance
Power Management Mode: Prefer Maximum Performance

After setting both of those, it worked like a charm. Granted, Idk if the first option actually needs to be done, since I only game using one monitor, but it can't hurt even if you have a second monitor.

The above is good advice for laptops, you should give this a try before attempting to rip your hair out, if you are still having issues at this point. Although if you don't ever change the Power Management setting back, you may find your battery life running shorter than usual.

Originally posted by Dj Sonic:
I'll add more details on how to do my application for those with ATI HD Graphics Cards for Desktop Computers. I did this with my graphics card ATI HD 6990 4G (Dual GPU)

1. Open Catalyst Control Center
2. Click "Gaming " > "3D Application Settings"
3. Find, and click the button that says "Add"
4. Navigate to your Resident Evil 4 binary folder. If your steam games are on the C drive, then it should be here:
C:\Program Files (x86)\Steam\SteamApps\common\Resident Evil 4\Bin32
5. Double click the file called 'bio4.exe'
6. Back on the "3D Application Settings", you should see a new profile "bio4.exe"
7. On the column labeled "Setting", the Anti-Aliasing Mode change it to "Override application settings" and the Anti-Aliasing Samples change it to "X8"
8. Now, click save and you're done.

Screenshot for those who may find it useful:
http://i58.servimg.com/u/f58/14/48/57/11/sin_ta10.png

I cannot speak for the effectiveness of the above potential fix, I can only hope that it works for you, as I am strictly a laptop user. Also note that the same may be applied to NVIDIA graphics cards, the menus and options may just have different names.

Originally posted by Shmaks:
Ok. Here's another slow mo fix for AMD cards users. There is fine utility called RadeonPro. Do the same that post here: http://forums.overclockers.co.uk/showpost.php?p=24000923&postcount=1 (Battlefield 3 example but works perfectly with RE4), and you will be happy :)

Again, I cannot speak for the effectiveness of this personally, though it seems to have helped two people so far, at the time of typing this. If this utility noticably helps you, please say so in a comment so that I can confirm it's effectiveness. Thank you. :)

////

Those with NVIDIA graphics cards, try this:

Open your NVIDIA Control Panel and click on "Set PhysX configuration"

Try setting it to Auto-Select like this: IMAGE[i.imgur.com]
See if that helps you out!

If it was already on Auto-Select, try setting it to your NVIDIA GPU like this: IMAGE[i.imgur.com]
Hopefully that will help!

Also, for those having trouble finding the "Preferred graphics processor" option in the instructions I gave, see if it shows up on this tab, here: IMAGE[i.imgur.com]
If it does, set it to the NVIDIA GPU like I have, and see if it works for you! Ignore the settings below that in the picture, I have actually personalized them to do things that may REDUCE your performance if you copy them.
---

2/03/2014:

It has been announced that a patch for the game is in the works! It should hopefully fix a bunch of issues that people have been posting on the community boards. Hopefully it will also help with slow motion issues! Fingers crossed. A release date has NOT been announced, though patience is appreciated. It has also been noted that AMD and NVIDIA will be contacted to help solve the issue of Integrated Graphics being selected as the default GPU, you can expect an updated driver some time in the future to fix that issue.
Last edited by HaydenK; Mar 4, 2014 @ 5:49pm
< >
Showing 1-15 of 290 comments
Fishsnot Feb 27, 2014 @ 7:33pm 
Love the port and want to play it, just hating on the issues. Thanks for trying though and I hope this helps someone. Didn't work for me unfortunatly!
Coflash Feb 27, 2014 @ 7:37pm 
Originally posted by HaydenK:
I hope this works for you, so that you can all stop hating the port, just because your computer is using the wrong graphics card.

LOL

Considering I can also reproduce slow motion movement on an integrated Intel 5000HD, I'm doubt nVidia or 'the wrong graphics card' is the cause.

On my GTX780 it is fine.
Last edited by Coflash; Feb 27, 2014 @ 7:38pm
World #1 害人 Feb 27, 2014 @ 7:38pm 
I managed to fix my slowdown by going into the options and changed the option that says "fixed 60 fps" to "fixed 30 fps"
WBacon [capcom]  [developer] Feb 27, 2014 @ 7:40pm 
Pinning this thread for visibility.

Yes, if you have switchable graphics, make sure the game is actually running on the correct graphics chip.

Laptop users with nVidia Optimus tech in particular may have this issue since the "Auto Detect" may default to your Intel integrated graphics.

If you're still having severe problems after the above workaround, please report your issues on the bug-tracking thread.

Edit: also please make sure your system meets the recommended specs outlined on the store page.
Last edited by WBacon [capcom]; Feb 27, 2014 @ 7:43pm
HaydenK Feb 27, 2014 @ 7:43pm 
Originally posted by Fishsnot:
Love the port and want to play it, just hating on the issues. Thanks for trying though and I hope this helps someone. Didn't work for me unfortunatly!

Sorry to hear! If you do find a fix, if you post it here I'll add it to my main post, hopefully it can help other people too.

Originally posted by Philll:
LOL

Considering I can also reproduce slow motion movement on an integrated Intel 5000HD, I'm doubt nVidia or 'the wrong graphics card' is the cause.

On my GTX780 it is fine.

'The wrong graphics card' WAS the cause for me. Not in the sense that I need a different one, but that NVIDIA's auto-select feature sometimes chooses a graphics card that isn't ideal for the program. It did so with RE4 for me. As soon as I changed it to use NVIDIA's graphics card, the game ran perfectly.
Coflash Feb 27, 2014 @ 7:43pm 
What if you don't have switchable graphics and only integrated chips? Integrated chips of which have no problem playing the likes of Crysis.

Also, it's in slow motion, but it's also at a very fluid 60FPS. Performance isn't an issue, there are no frames being dropped.
Last edited by Coflash; Feb 27, 2014 @ 7:47pm
HaydenK Feb 27, 2014 @ 7:50pm 
Originally posted by Philll:
What if you don't have switchable graphics and only integrated chips? Integrated chips of which have no problem playing the likes of Crysis.

I'm afraid that I don't have the answer to that, but I'd gladly include it in the main post if you find one, or if anyone else does. Sorry! I hope you find a solution soon, aside from these inital issues with graphics cards and such, the game runs great.



Originally posted by wbacon capcom:
Pinning this thread for visibility.

Yes, if you have switchable graphics, make sure the game is actually running on the correct graphics chip.

Laptop users with nVidia Optimus tech in particular may have this issue since the "Auto Detect" may default to your Intel integrated graphics.

If you're still having severe problems after the above workaround, please report your issues on the bug-tracking thread.

Edit: also please make sure your system meets the recommended specs outlined on the store page.

Thank you, if you ever want to (and are able to), you can edit the title or contents of my post to add more information. Basically, feel free to take over and use this as an official 'slow motion fix' compilation thread.
Aeon Feb 27, 2014 @ 8:18pm 
I can confirm this fix worked on my AMD laptop.
I had to add Resident Evil as an application, then make it high performance.
Note, it adds the application as 'bio4.exe'

Screenshot for those who may find it useful:
http://i.imgur.com/ZULPrdU.png
HaydenK Feb 27, 2014 @ 8:27pm 
Originally posted by Fafaffy:
I can confirm this fix worked on my AMD laptop.
I had to add Resident Evil as an application, then make it high performance.
Note, it adds the application as 'bio4.exe'

Screenshot for those who may find it useful:
http://i.imgur.com/ZULPrdU.png

I'll add this quote to the main post, thank you for the screen shot, I'm sure it will help. :)
Total Cereal Feb 27, 2014 @ 8:28pm 
I don't see a switchable graphics option in my AMD CCC. Does this mean it shouldn't be a problem for me? I have integrated graphics, but my computer doesn't use it unless the GPU is unplugged.
Aeon Feb 27, 2014 @ 8:29pm 
Originally posted by Total:
I don't see a switchable graphics option in my AMD CCC. Does this mean it shouldn't be a problem for me? I have integrated graphics, but my computer doesn't use it unless the GPU is unplugged.
This is mainly for laptops, if you're on desktop, you don't have AMD Enduro which is the switchable graphics. If it lags for you, I'm not sure what the problem is. Do you even have the optimal requirements to run the game?
Total Cereal Feb 27, 2014 @ 8:31pm 
Originally posted by Fafaffy:
Originally posted by Total:
I don't see a switchable graphics option in my AMD CCC. Does this mean it shouldn't be a problem for me? I have integrated graphics, but my computer doesn't use it unless the GPU is unplugged.
This is mainly for laptops, if you're on desktop, you don't have AMD Enduro which is the switchable graphics. If it lags for you, I'm not sure what the problem is. Do you even have the optimal requirements to run the game?
I don't even have the game yet XD I'm just concerned about all the technical issues people are talking about. I'm super hype for it and I don't want to be let down.
Aeon Feb 27, 2014 @ 8:36pm 
I'll add more details on how to do my application thing for those with AMD:

1. Right click on the Desktop
2.* Click 'Configure Switchable Graphics'
3. Find, and click the button that says "Add Application ..."
4. Navigate to your Resident Evil 4 binary folder. If your steam games are on the C drive, then it should be here:
C:\Program Files (x86)\Steam\SteamApps\common\Resident Evil 4\Bin32
5. Double click the file called 'bio4.exe'
6. Back on the AMD Catalyst Control Center, under All Applications, you should see a new file called 'bio4.exe'
7. On the column labeled "Graphics Setting", make sure you set 'bio4.exe' to "High Performance"
8. Now, click Apply and you're done.
hutz.ytmnd.com Feb 27, 2014 @ 8:41pm 
If this is really the issue, wow. Can people not like, straight-up disable the integrated device in device manager and leave the discrete?

The way people are going on, sounded like they had full framerate but it was in actual slow-motion. By the definition of slow motion.
Last edited by hutz.ytmnd.com; Feb 27, 2014 @ 8:42pm
HaydenK Feb 27, 2014 @ 8:43pm 
Originally posted by Fafaffy:
I'll add more details on how to do my application thing for those with AMD:

1. Right click on the Desktop
2.* Click 'Configure Switchable Graphics'
3. Find, and click the button that says "Add Application ..."
4. Navigate to your Resident Evil 4 binary folder. If your steam games are on the C drive, then it should be here:
C:\Program Files (x86)\Steam\SteamApps\common\Resident Evil 4\Bin32
5. Double click the file called 'bio4.exe'
6. Back on the AMD Catalyst Control Center, under All Applications, you should see a new file called 'bio4.exe'
7. On the column labeled "Graphics Setting", make sure you set 'bio4.exe' to "High Performance"
8. Now, click Apply and you're done.

Thank you! Already added to the main post! :)

Originally posted by {W`C} hutz:
If this is really the issue, wow. Can people not like, straight-up disable the integrated device in device manager and leave the discrete?

The way people are going on, sounded like they had full framerate but it was in actual slow-motion. By the definition of slow motion.

I believe disabling integrated graphics may cause a lot of issues with the computer. I can't confirm that, but I definitely wouldn't recommend it. Also considering the fact that some applications really don't need to take use of a high powered graphics card. Using the high power grpahics card for everything would most likely reduce it's lifespan.

The slow motion thing is true, that is exactly what I had. The frame rate was incredibly smooth, but everything was literally in slow motion.
Last edited by HaydenK; Feb 27, 2014 @ 8:44pm
< >
Showing 1-15 of 290 comments
Per page: 15 30 50

Date Posted: Feb 27, 2014 @ 7:23pm
Posts: 290