Stonehearth

Stonehearth

AllWorkNoPlay Jan 10, 2017 @ 12:54pm
Fullscreen to black screen on close!!
I am sorry but this is going to sound pretty harsh. As a developer you have one job and that is to make sure that your game can run. I do not mean play but RUN and stable. The issue that I have been having that still is not resolved is the fullscreen mode closing to a black screen issue. Also before you even ask yes I have installed the latest display drivers and yes I have made sure that I have no mods running and also for good measure I had no extra apps running in the back ground just windows, steam, and anti-virus. Oh yeah and just incase YES I have reinstalled the game and yes it is in the default steam directory!!!

Your job before game play is to make sure that everything launcher wise works 99.9% before moving to game play. Now yes I know this is an early access but even in early access your game better launch and close properly. This is coding 101 people!! It is not like PC game developement is something new there should be no excuse for your game to not open and close properly.

Now the fix that I have read from some of the devs from the forums is that I should not launch the game from the steam app. WELL THEN WHY IS IT THERE!!!! I really think you guys need to reevaluate your priority to-do check list.

I guess in short get your priorities straight and fix your launcher!! Also one more jab running it in compatibility mode does not work either!!

I love the idea of the game and when it runs it is fun as all hell but COME ONE having to reboot my freaking computer EVERYTIME I close your game is INSANE!!! and I know I am not the only one!!! :steamsad:
< >
Showing 1-13 of 13 comments
Crushyg Jan 12, 2017 @ 7:52pm 
I have the same issue. It also happens if I alt tab to something else.
AllWorkNoPlay Jan 12, 2017 @ 9:11pm 
Yup it sure does do it when you ALT-TAB sad really that such a simple function is so difficult for them to execute! :steamsad:
Same issue i love this game to death but like for real i dont want to reboot everytime i close the game
Last edited by CWO. Hunk [10th MD]; Jan 24, 2017 @ 6:05pm
Relyss Jan 25, 2017 @ 6:41am 
Is there any other hint on how to reproduce this? We can't get it to happen, tried many times and on different computers.
Are you perhaps using multi-monitor setup?
We tried alt-tabbing and closing the game in multiple ways and in fullscreen, but we didn't see any black screen, the game closes correctly.

Which are your computer specs? (CPU, RAM, OS, Graphic card...)
Are you using a laptop or a desktop?
Ol' Dracor (deaf) Jan 28, 2017 @ 5:52pm 
Black Screen of death upon exit
after playing nearly 1 hr and i exit and black screen stayed not even alt+crtl+del did anything. had to force pc restart :(
Relyss Jan 30, 2017 @ 10:54am 
We haven't been able to reproduce this yet, we need more info:

1 - Which Antivirus do you use?
2 - What are your system specs (CPU, RAM, OS, Graphic card...)?
3 - On your display settings - > Advanced display settings -> Display Adapter Properties, which is the screen refresh rate of your monitor?

Sorry for so many questions, we're really concerned about this issue happening to some users, but it's proving difficult to reproduce on our end.
Ol' Dracor (deaf) Jan 30, 2017 @ 12:23pm 
no anti-virus, windows 10 home, 12 gb ram, evga nvidia 730 gt 2gb card, 3.22ghz old intel quad core, 60 hz refresh
Ol' Dracor (deaf) Jan 30, 2017 @ 12:24pm 
well there is anti-virus its part of win 10 uhh windows defender
Relyss Jan 30, 2017 @ 1:11pm 
As a workaround, try unplugging / plugging your monitor to your PC (or just turning it off/on) and see if that refreshes the screen and brings back the image. If this works, you won't have to reboot your computer while you test possible fixes.

I've found a thread from other games where users also had this black screen issue: https://steamcommunity.com/app/207350/discussions/0/828925849481059703/

The problem seems to be with the refresh rate of the monitor, but some people already had it at 60Hz (like you). I don't know if this would work for Stonehearth too but it's worth mentioning.

In that thread there are the following suggestions:

- Changing your windows display adapter settings to have a 60hz refresh rate (this worked for most users, but you already have it at 60Hz, and sometimes it reverted back to the old value after restarting the computer, and you have to do it for all your monitors)

- In the Nvidia control panel-> Manage 3D settings->Program Settings tab, select the game that is causing issues (or add it to the list if it isn't there), scroll through the list of settings and find the setting for preferred refresh rate, choose Application controlled and apply the changes.

- Turn off anti-aliasing

- Fiddling with the antivirus (not your case)

- Playing in borderless mode (which Stonehearth doesn't have)

- Turn off Nvidia Gsync (set monitor to fixed refresh rate)

- Enabling VSR (Virtual Super Resolution) and GPU scaling

------------
Try the ones that apply for your system, and let us know how it goes.
I've merged your report with this one, so that the other affected users can check these possible fixes.

I remember in the past issues of crashes or failing to save due to shadows and other graphic settings, but shouldn't be the case.
Last edited by Relyss; Apr 17, 2017 @ 2:03pm
AllWorkNoPlay Jan 30, 2017 @ 1:34pm 
Relyss,

Thank you for finally taking the time out of your busy schedule to reply. Much appreciated!!!

I will try all of these and see what fixes it. I will post everything that I try so that your team can better understand the issue and what actually causes it. Which in turn I hope helps find a solution to the problem.

Again thank you for the help.
Crushyg Jan 31, 2017 @ 8:32pm 
about to try some of these things...

I do have a dual monitor setup, I also run the games on my 120hz monitor. I use bitdefender as my antivirus.

my processor is an AAMD FX 8320, it is over clocked though (yay liquid cooling :D)
I have 16gb of ram
using dx12 on my pc
and using a geforce gtx 970

now to try some fixes

oh... one thing that did make it so the game wouldnt cause the black screen was running it in a windowed mode... didnt look great but it did work.
Last edited by Crushyg; Jan 31, 2017 @ 8:35pm
Crushyg Jan 31, 2017 @ 8:38pm 
ok, well im kinda happy... full screen and it didnt do it...

Through the nvidia control pannel:
- my monitor was set to 60hz, switched that to 120.
- I turned off all the antialiasing
- put virtually pre-rendered frames to 3
Relyss Feb 1, 2017 @ 3:47am 
What about you, iDextrose, Ol' Dracor, [FROST] HUNK ?
Did any of these steps help?
< >
Showing 1-13 of 13 comments
Per page: 1530 50

Date Posted: Jan 10, 2017 @ 12:54pm
Posts: 13