Rocket League

Rocket League

View Stats:
mfoxdogg Sep 9, 2016 @ 12:54pm
Linux - Can not connect to servers
Hi, I am having difficulties connecting to rocket league servers. Whenever i want to do somthing online, like find a match or start a party. I get a notice saying i am not logged in and asks do i want to log in, i select yes, then i get a notice that says "There has been an error connecting to the rocket leauge servers please try again later" , yes i have gone through the faq and none of these helps. and no i cannot start from terminal because it segfaults when i do

Linux-Opensuse 42.1 with the plasma desktop

I am an australian if that helps
Last edited by mfoxdogg; Sep 9, 2016 @ 12:54pm
< >
Showing 16-28 of 28 comments
bladerunner Sep 10, 2016 @ 5:49am 
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!

For openSUSE 13.2 (and I suspect also 42.1) it's in a different place, so run this instead:

sudo ln -s /etc/ssl/ca-bundle.pem /etc/ssl/certs/ca-certificates.crt

Thanks Dutchy :).
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!

Thanks!

For those interested in where their certificates are, run:

locate ca-bundle.crt

(Might be slightly different between distros. This is for Fedora)
mfoxdogg Sep 10, 2016 @ 2:54pm 
Thank you bladerunner that was it, i can now play properly now :)
Cheeseness Sep 10, 2016 @ 6:26pm 
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!
Well spotted! This was the issue I was having as well :)
Thank you so much !! Your tip turned into a video. Sorry to be in Portuguese, but will arrange a legend. I mentioned you. Thanks for sharing
https://www.youtube.com/watch?v=dH3W7saXJUE
DutchyDuD Sep 11, 2016 @ 1:50pm 
Great that it also works for you guys! Was very glad myself that a quick temporary fix was possible since the game is great fun online.
I guess the devs will simply add these files to a list of locations to check for in a future update. I tried to look for a way to disable the SSL check but unfortunately could not find much information about the launch options and there appears to be no configuration setting for it, so until an update fixes it the symlink will have to do.
AshY Sep 15, 2016 @ 11:00am 
Originally posted by bladerunner:
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!

For openSUSE 13.2 (and I suspect also 42.1) it's in a different place, so run this instead:

sudo ln -s /etc/ssl/ca-bundle.pem /etc/ssl/certs/ca-certificates.crt

Thanks Dutchy :).

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

ln: failed to create symbolic link ‘/etc/ssl/certs/ca-certificates.crt’: File exists

That isn't working for me unfortunately,
Last edited by AshY; Sep 15, 2016 @ 11:00am
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!

Hi!
Using openSUSE Leap 42.1 same problem and your solution works great!
Thanks!
YaZoR Oct 24, 2016 @ 1:32am 
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!
Works!
Thank you!
Artox Jan 10 @ 5:43am 
This is still a thing in 2017 ...... will Psyonix ever implement a workaround?
wyqydsyq Apr 29 @ 4:11pm 
They only officially support SteamOS on which this isn't an issue.
Originally posted by DutchyDuD:
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!

Thank you! That worked for Fedora 25!
Cryvan May 14 @ 4:42pm 
After a recent patch for OpenSuse 42.2 this solution does not work. The certificate was moved in the patch and the link was invalid. I was able to resolve the problem using this command instead:

sudo ln -sf /var/lib/ca-certificates/ca-bundle.pem /etc/ssl/certs/ca-certificates.crt
< >
Showing 16-28 of 28 comments
Per page: 15 30 50

Date Posted: Sep 9, 2016 @ 12:54pm
Posts: 28