Rocket League

Rocket League

View Stats:
mfoxdogg Sep 9, 2016 @ 12:54pm
Linux - Can not connect to servers
Hi, I am having difficulties connecting to rocket league servers. Whenever i want to do somthing online, like find a match or start a party. I get a notice saying i am not logged in and asks do i want to log in, i select yes, then i get a notice that says "There has been an error connecting to the rocket leauge servers please try again later" , yes i have gone through the faq and none of these helps. and no i cannot start from terminal because it segfaults when i do

Linux-Opensuse 42.1 with the plasma desktop

I am an australian if that helps
Last edited by mfoxdogg; Sep 9, 2016 @ 12:54pm
< >
Showing 1-15 of 34 comments
khazaz Sep 9, 2016 @ 12:56pm 
I have the same problem and the same OS.
Aldo Raine Sep 9, 2016 @ 1:00pm 
I have this issue on Fedora 23.
Aldo Raine Sep 9, 2016 @ 1:02pm 
Ubuntu users don't have this problem. I don't know why. I already disabled firewalld, selinux but not solved
Last edited by Aldo Raine; Sep 9, 2016 @ 1:05pm
Bitlaus Sep 9, 2016 @ 1:54pm 
Same here on Fedora 24
moskae Sep 9, 2016 @ 4:01pm 
i have this problem on xubuntu 16.04. Not logged in to RL servers
Cheeseness Sep 9, 2016 @ 5:03pm 
I see this on Fedora as well. I'm wondering if there's some networking or crypto lib that the game should be bundling instead of relying on system libs.
same problem here on my fedora 24 machine, seems to not generate any output or errors tho (terminal, SELinux or some sort of log).
Cheeseness Sep 9, 2016 @ 6:03pm 
The game's log is here:
~/.local/share/Rocket League/TAGame/Logs/Launch.log

Unfortunately it's not regularly flushed, so it's tricky to spot the point at which stuff goes wrong by just doing a tail -f.

Here's a look at what the relevant parts of mine look like (full log is here[gist.github.com]). I don't expect any of this to be useful to users, but if a dev stops by, perhaps they'll see something that can shed some light.

[0004.43] Log: Initializing Engine Completed [0004.43] Log: >>>>>>>>>>>>>> Initial startup: 4.43s <<<<<<<<<<<<<<< [0004.67] DevOnline: Obtained steam user stats, user: 76561197993680740 [0004.70] Log: FSaveDataExportTask(0) wrote 71288 bytes to memory [0004.70] Auth: SendLoginRequest [0004.70] Log: SaveDataExport(0): Mount [0004.70] WebTask: DefaultLoginTask sending request [0004.76] Log: Deleting old save file ..\..\TAGame\SaveData\DBE_Production\76561197993680740_1.save [0004.76] Log: SaveDataExport(0): Finished - File:[..\..\TAGame\SaveData\DBE_Production\76561197993680740.save] Result:[1] [0004.76] DevAudio: UAudioDevice::ApplySoundMode(): Default [0004.76] SaveGame: Successfully Saved ..\..\TAGame\SaveData\DBE_Production\76561197993680740.save [0004.85] ScriptLog: HandleOnlineConfig WebRequest_X_0 Error_X_0 [0004.90] WebTask: DefaultLoginTask failed, count=1 delay=1.6392 [0004.90] Log: UJSONSerializer_X::DecodeObject() Failed: Object=LoginResponse_X Transient.LoginResponse_X_0 Json: [0007.22] StartMenu: ControllerIndex:'0' [0007.22] DevOnline: Set rich presence to: Main Menu data: Menu [0012.95] Log: SqlQuery Error: Procedure='GetPlayerSkillSteam', ErrorCode: -1, Message: WebRequestAuthorization Offline, QueueSendTime > PreLoginTimeoutTime [0015.13] Online: TryToPlayOnline ControllerID:'-1' [0015.13] Online: CheckPrivilege ControllerID:'-1' Privilege:'FP_OnlinePlay' [0015.13] Online: CheckPsyNetConnection not logged in to PsyNet [0015.14] Online: CheckPrivilege ControllerID:'-1' Privilege:'FP_OnlinePlay' no connection to PsyNet [0015.14] Online: HandlePrivilegeCheck PrivilegeCheck:'PrivilegeCheck_X_0' [0016.39] Auth: RequestAuthorizationCode [0016.39] Auth: AuthInterface.RequestAuthorizationCode [0016.39] DevOnline: Issuing request for auth session ticket [0016.39] DevOnline: Issuing request for encrypted app ticket [0016.39] Auth: AuthStatus=AUS_Pending [0016.84] Auth: SendLoginRequest [0016.84] WebTask: DefaultLoginTask sending request [0016.90] WebTask: DefaultLoginTask failed, count=2 delay=7.0507 [0016.91] Log: UJSONSerializer_X::DecodeObject() Failed: Object=LoginResponse_X Transient.LoginResponse_X_1 Json: [0020.26] Log: SqlQuery Error: Procedure='GetPopulationAllPlaylists', ErrorCode: -1, Message: WebRequestAuthorization Offline, QueueSendTime > PreLoginTimeoutTime [0021.83] Log: Closing by request [0021.83] Log: appRequestExit(0) [0021.98] Auth: (OnlinePlayerAuthentication_TA_0) OnlinePlayerAuthentication_X::OnlinePlayerAuthentication_TA:HandleLocalPlayerLoginStatusChanged Name=Cheeseness LoggedIn=False SendingLogin=False RequiresAuth=True AuthStatus=AUS_NotStarted [0021.98] Party: HandleLocalPlayerLoginStatusChanged PlayerName= PlayerID=Steam|76561197993680740|0 LoginStatus=LS_NotLoggedIn IsPrimary=True IsInParty=False
m2mg2 Sep 9, 2016 @ 6:19pm 
Same problem. I wonder if an OS check is done and everything other that Debian/Gnome3 (what steamos uses) is denied multiplayer, as Rocket League currently only supporting SteamOS
Cheeseness Sep 9, 2016 @ 6:36pm 
Originally posted by m2mg2:
Same problem. I wonder if an OS check is done and everything other that Debian/Gnome3 (what steamos uses) is denied multiplayer, as Rocket League currently only supporting SteamOS
This is very unlikely and isn't in line with the kind of stuff that the people behind the port would normally do, not to mention that the game is running fine for users on Arch, Manjaro and all sorts of other distros (for now, I'm going to suspect that kot-barbos happened to have trouble during actual server downtime).

Although generally speaking, there's not a huge amount of difference between distros, sometimes there are differences in the packages they come with, whether that be a preference for shipping older library versions over newer ones (for example, Fedora doesn't ship libcrypto 1.0.0), or favouring one fork over another (for example, Ubuntu ships libav by default instead of ffmpeg). It's far more likely to be an issue that stems from that sort of thing than an explicit crippling of the game on certain distros.
m2mg2 Sep 9, 2016 @ 7:08pm 
I wasn't aware that people were playing fine on Arch variations and others. Everything I had seen were just SteamOS or Ubuntu, I did miss the part where Ubuntu doesn't actually use Gnome 3 though.
NoXPhasma Sep 9, 2016 @ 9:02pm 
Originally posted by Cheeseness:
(for example, Ubuntu ships libav by default instead of ffmpeg).
Since Ubuntu 15.10 they ship ffmpeg again.
Last edited by NoXPhasma; Sep 9, 2016 @ 9:03pm
Hexen` Sep 10, 2016 @ 3:08am 
Has anyone figured this out yet? I'm also on Fedora 24 with the same exact issue, my logs look exactly the same as Cheeseness.
Last edited by Hexen`; Sep 10, 2016 @ 3:10am
DutchyDuD Sep 10, 2016 @ 4:19am 
The problem is that on Fedora et al. /etc/ssl/certs/ca-certificates.crt is called /etc/ssl/certs/ca-bundle.crt. The work around is simply creating a symlink:

sudo ln -s /etc/ssl/certs/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

After that I am able to connect to the servers and join a match. Cheers!
elFarto Sep 10, 2016 @ 5:38am 
Thanks Dutchy, that solved the problem for me!
< >
Showing 1-15 of 34 comments
Per page: 15 30 50

Date Posted: Sep 9, 2016 @ 12:54pm
Posts: 34