Legend of Grimrock 2

Legend of Grimrock 2

View Stats:
MrPhilGood Oct 15, 2014 @ 2:39pm
Start up error. (XAudio2 error in CreateMasteringVoice)
So I've played the game for a little bit. Decided to change some settings around and then it started giving me "XAudio2 error in CreateMasteringVoice". I know i have the minimum requirements and all my drivers are up to date, i just checked. I've tried reinstalling but that didn't work. It still gives me the error.

The game started giving me this error after i turned off Vsync. But now i can't start the game up to turn it back on. Anyone else have this issue?

Besides that, i was enjoying the game.
< >
Showing 1-10 of 10 comments
phittte Oct 15, 2014 @ 2:42pm 
I don't know how to solve the problem, but you can turn vsync on without starting the game by altering the ini file. It's in mydocuments/username/almost human/grimrock2 (or something similar, don't have it installed atm since my computer went to hell). Open the Grimrock.ini with an editor (the standard windows notepad) and look for vsync. I think 3 is Triple Buffering, 2 is Vsync and 1 is off IIRC.
Last edited by phittte; Oct 15, 2014 @ 2:43pm
MrPhilGood Oct 15, 2014 @ 2:49pm 
Well i've tried that just now, and sadly it still came up with the same error. Not sure what's up. It was running fine before.
Death of Rats Oct 15, 2014 @ 2:51pm 
I am having error too. I started up the game earlier today, played for a bit and came back a few hours to this error. It was running perfectly earlier.
phittte Oct 15, 2014 @ 2:56pm 
Googled a bit and landed on the Grimrock 1 forums. :) Apparently it's a directX problem. You need to download and install this (it's the official Microsoft site, so no worries):

http://www.microsoft.com/en-us/download/confirmation.aspx?id=8109

Here is a link to the thread:

http://www.grimrock.net/forum/viewtopic.php?f=12&t=513&start=10
MrPhilGood Oct 15, 2014 @ 3:06pm 
Well for some reason, it didn't work for me. It's still giving me that same error.
phittte Oct 15, 2014 @ 3:18pm 
Originally posted by MrPhilGood:
Well for some reason, it didn't work for me. It's still giving me that same error.

I'm not sure the directx package download I linked to is the fix for the Grimrock 2 problem, but apparently it is a directx problem of some sort. Make sure you have the latest directx version installed, maybe uninstall directx and install it again. Other than that I have no idea, sorry. Maybe head over to the official Grimrock forum if nothing helps, the devs are much more active there than here.
MrPhilGood Oct 15, 2014 @ 3:20pm 
Got it. I'll see what I can do. Thanks for the help.
MrPhilGood Oct 15, 2014 @ 3:54pm 
Not exactly sure what fixed it. But the last thing I did was restart my computer and it works now.
Warp Rider Nov 5, 2014 @ 1:08pm 
uhm...where do we place the extracted files? I just got that download and don't know what to do with it.
one86 Nov 5, 2014 @ 5:15pm 
Originally posted by Peachy Keen:
uhm...where do we place the extracted files? I just got that download and don't know what to do with it.
The exe you download (directx_Jun2010_redist.exe) is just a self extracting archive. You unpack in into a temporary location (folder), run another exe file from this location. This 2nd exe is the main install procedure. After all is done you can and should remove the temporary folder.
Ask if anything is unclear :) gl
Last edited by one86; Nov 5, 2014 @ 5:16pm
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Date Posted: Oct 15, 2014 @ 2:39pm
Posts: 10