7 Days to Die

7 Days to Die

View Stats:
NukeWaste_UwU May 10, 2020 @ 11:11am
Unplayable on New PC?
I got this game 2 days ago and would love to play, but I am having some issues I cannot seem to work past.


PC Specs: Intel core i7
16 GB ram
Nvidia Geforce GTX 1070


From what I understand, my PC should have no problems running this game. I have seen worse builds run this game just fine. I have tried playing around with graphical settings and have looked through discussions and forums for a solution, but have had not luck still. Am I just SOL until a new patch comes out or something? I really wanna play, but my game is running with single digit fps right now, it's unplayable for me. I have dropped my graphics setting and even then the best I've gotten has been a split sec of 20 fps. This PC is not even 2 weeks old yet so it's not dirty, and I have made sure to update graphics drivers...


On an unrelated note: I am also having a problem with profile creation. Any new file I try to make will load in an empty character model (Attributes all set to 0.0, all colors nonexistent, just floating eyeballs on a female character model.), I can edit the model, but after clicking apply and back it just resets back to nothing...


Did I just get a broken copy of the game somehow? Cause I'm starting to think my game is just broken :(
Originally posted by MyProfile:
Make sure you're actually using the 1070 and not onboard graphics. You should be cooking with that rig. In comparison, I'm playing on an 8 year old gaming laptop and I really can't complain about performance unless I try to run a browser while in the game.
< >
Showing 1-15 of 19 comments
The_Insane_Canadian May 10, 2020 @ 11:14am 
i am mildly concerned, does your PC run fine on other games? cause i am not too far off of your specs, i got a
1660 SUPER
16 GB of ram
and a Ryzen 7 2700x
with not one issue, id check to make sure every thing runs as it should, but other then that you'll have to wait for someone else smarter to respond
NukeWaste_UwU May 10, 2020 @ 11:17am 
Every other game I have runs without any issues. It's 7D with problem, which is why I am as confused as I am.
DForDogedetta May 10, 2020 @ 11:57am 
I'm Intel Core i7, Nvidia Geforece 1050, and 12 gb of ram and my pc runs it just fine. As to a solution, I have no idea. I'm assuming you've tried uninstalling and reinstalling?
Baziez May 10, 2020 @ 12:53pm 
try use this qualitty settings: https://steamcommunity.com/sharedfiles/filedetails/?id=1998625360

if you want to try using higher setting, put -force-vulkan in game optional launch. Start game, set up new quality and set vSync to Half. My machine could not do 60 fps with all fx that's why I use Half. With this if you're getting any other errors you'll have to stop using the launch options as vulkan is still in a lot development
JavaGawd May 10, 2020 @ 1:23pm 
something else to research, Project Lasso. I've a mid range "gaming" pc and have no issues running any other game but for whatever reason (no, I'm not a guru but I've built a few PCs) 7D2D spiked my CPU temp to uncomfortable levels. I did a search in these forums and somebody mentioned the Project Lasso software worked for them, its free and after learning what its actually supposed to do, I gave it a shot.

15 degrees cooler on my CPU (which is water cooled) was the result. I understand that there was crap running in the background that didnt need to be but this software made 7D2D playable for me.

Default to the opinions of others that know tons more than myself, I'm just stating that the free version with default options corrected the issues I was having with my machine with this particular game :)

Good Luck, its an interesting game even if you run solo :)
BodyBagger May 10, 2020 @ 1:29pm 
Here are the problems I had in Alpha 18, and the solution that seemed to work for me. With the settings listed below, the game seems to work fine!


Having problems with frame rate drops in A18

I have to say, Alpha 18 has me a bit perplexed: When previous Alphas have dropped, I haven't had any problems adjusting my video settings for smooth game play. Unfortunately, in A18 I'm having frame rate drops as low as "20." They happen suddenly, and usually when I'm in my base. Then the frame rate goes right back up again. Sometimes it's short lived, other times it fluctuates for a while. My normal frame rate is usually between 60 - 80 FPS. I have, however, experienced it as high as 150 FPS in A18. This new range (20 - 150 FPS) seems a bit odd to me.

I have three bases on my map, one in each of the following regions: South, East, and North (all in-game POIs). I am using Pregen Map 2. When I experienced a frame rate drop in my South base, I reduced the size of my tree farm (in the desert) and it seemed to fix the problem. Now I'm having the same problem in my North base (in the forest biome). So, I reduced the size of my tree farm once again. Unfortunately, it did not work this time. Perhaps there are already too many trees in the area, and my tree farm is the straw that broke the camel's back. I have about 50 trees in my farm (I've had larger farms in the past). I haven't eliminated my tree farm yet, but that's my next test.

Has anybody found a solution to the frame rate drops in A18? I would appreciate any insight since I am at a loss! I have spoken to others who are experiencing the same issue.

Here are the specs for my computer, and my game settings:

A) I have 16GB RAM, SSD, i7 @ 4 GHz, GTX 970 video card (4 GB video RAM), 2k monitor, Window 8.1.

1) I put my resolution @ 1920x1080 (even if you have a 2k monitor, 2k setting will make it lag). I also use Full Screen.

2) Vsync: Off

3) Anti-Aliasing @ yes / Texture @ half / UMA @ middle / reflection @ low & reflected shadows @ no / shadows distance @ near / water quality @ low / water particles @ 50% / view distance @ medium / LOD distance @ 50% / grass distance @ near / motion blur off / SSAD @ yes / depth of field @ no / sun shafts @ no.

4) Texture Streaming: I've tried this both on and off; I see no difference. (Use on)

5) Terrain Quality: I've tried this on both medium and high; I see no difference. (Use high)

6: Object Quality: I've tried this on both medium and high; I see no difference. (Use medium)

Thank you, in advance, for any assistance you can provide!

UPDATE: Well, I removed my tree farm in the forest biome and I haven't gotten any more FPS drops. So I guess the solution is to not have any tree farms, or keep them very small (maybe 20 or 30 trees)… And place the farm a fair distance from your base. I'm getting good FPS now.
Last edited by BodyBagger; May 10, 2020 @ 1:30pm
NukeWaste_UwU May 10, 2020 @ 1:49pm 
I switched to alpha 18 and it runs fine, but it crashes after about 5 min. So I'm back to square one
BodyBagger May 10, 2020 @ 1:55pm 
Originally posted by NukeWaste_UwU:
I switched to alpha 18 and it runs fine, but it crashes after about 5 min. So I'm back to square one

Could it be your virus software? Have you tried the settings I listed above?
Progje [NL] May 10, 2020 @ 2:20pm 
@BodyBagger

Treefarms can eat a lot yea....

Ur videocard, the GTX 970 is kinda low.
It can't handle so much trees as with every update the game is getting more GPU and CPU intensive. Sometimes a step forward and sometimes a step back.

I'll bet if you try another card, your pc can render more trees and whatnot.
Last edited by Progje [NL]; May 10, 2020 @ 3:03pm
SylenThunder May 10, 2020 @ 3:01pm 
Intel i7 is extremely vague. What drive it runs on is important too. OP needs to list actual specs instead of a vague 12-year window of processors.

Also note, every other game is not a complex voxel game that requires strong CPU and RAM power with fast HDD access rates. There is no other game that will push the core components as much as this one does.
Progje [NL] May 10, 2020 @ 3:13pm 
I think it's more that people uses components and they even don't know how many Mhz everything is running at.

I had the same thing, i thought i bought 2400 Mhz RAM modules. Stickers on it say's 2400 as well, as well on the module itself. But it was lower then that.
Lucky me i got my money back after a year of use.

A 16 GB @ 3200 Mhz runs better then 32 GB @ 1600 Mhz for example.
Also most people forget that if a motherboard can run 2400 Mhz, and they have memory modules running at 1600 Mhz, the whole pc is running at 1600 Mhz because it runs at the lowest Mhz that is in the pc.

Intel i7 say's not much indeed. There are many variants of that type.

I would say that IF people don't list their specs, they are running a laptop with integrated peripherals
SylenThunder May 10, 2020 @ 3:37pm 
I'll also note that it might not be the hardware that's the issue either, but part of the core system.

I've been troubleshooting this laptop with an i7-7700hq, 16GB RAM, and a GTX 1070 8GB. It's got two NVMe drives in RAID-0, and an SSD for storage.
There is absolutely no reason this PC should have any issues with the game, and in the past it's run the game client perfectly stable with an average of 80FPS.

However now, it's running 7 days like trash. That's not the only game having an issue though. Conan, Division, and Ghost Recon all have some freezing, stuttering, or audio issues as well. They aren't as bad as 7 Days with the issues though. So for the un-educated, it may look like 7 days is the problem game because the others are only having the issues once in a while, when 7 Days has the issue almost all the time.

Also, running off what Progjeツ said, I'll give example.

Old Hardware
i7-3930k at 3.2GHz (Circa 2011 3rg Gen Intel I7)
32B DDR3 RAM at 1600Mhz
GTX1060 6GB SSC
OS and game on separate SSD's, save data on HDD

I get a mostly stable 60FPS with this. It will head up into the 70-80 range if I'm not doing much, and can dip into the 40's briefly when I'm entering a heavily populated area, or an area with many/large buildings. During horde nights this will dip into the 30-45FPS range.

Old Hardware Overclocked
i7-3930k overclocked at 4.2GHz (Benchmarks a tad higher than an i7-7700k with this OC.)
32B DDR3 RAM at 1866Mhz
GTX1060 6GB SSC
OS and game on separate SSD's, save data on HDD

I get a mostly stable 80FPS with this. It will dip down into the 60's periodically when in big towns, or during bloodmoon.

Old Hardware Extreme Overclock
i7-3930k overclocked at 4.6GHz (Benchmarks damn close to an i7-8700k with this OC. Turbo puts it to 5.1GHz, and it's still stable due to undervolting.)
32B DDR3 RAM at 2000Mhz
GTX1060 6GB SSC OC'ed a pinch over the factory OC.
OS and game on separate SSD's, save data on ultra-fast SSHD's in RAID 0

I get a mostly stable 110FPS with this. It will head down into the 70-80 range for cities and bloodmoons

NEW Hardware
R9 3900X overclocked at 4.25GHz (I could push it a lot farther, but I'm on the stock cooler.)
32B DDR4 RAM at 3200Mhz
GTX1060 6GB SSC
OS is on SSD, Game is on NVMe, and save data is on the SSHD's in RAID-0

I still have that good ol GTX 1060, but now my FPS range is closer to 110-170FPS with the same graphics options.

That shows how much of a difference your core components make in a game like this. My RAM is twice as fast, and I have double the CPU cores. And on top of the higher FPS, the in-game movement is smooth as butter. It's almost like playing a completely different game in comparison.

Also, just for reference, these are the graphics settings I used for each of these runs.
https://i.gyazo.com/d1e00fcc68c9f65dff8461d5bcecb184.png
Last edited by SylenThunder; Jun 9, 2020 @ 12:05pm
NukeWaste_UwU May 10, 2020 @ 3:50pm 
I'm not on a laptop, it's just my first PC and Idk what I need to add when I spec it out I guess.. The link to the PC I got says

"Intel Core i7 - 8700 - 16GB Memory - NVIDIA GeForce GTX 1070 - 1TB HDD + 240GB SSD"

I went into control panel to try to find the RAM speed, but I'm not sure what Mhz it is. The consensus from everyone I've talked to has been that it should run fine on this rig. To BodyBagger, I have tried playing with your settings, and can get a few more frames, but nothing above 25.


**EDIT: I found a little extra info: 16 gigabytes RAM, DDR4 SDRAM, 2666 megahertz
Last edited by NukeWaste_UwU; May 10, 2020 @ 3:53pm
SuperMeatBag May 10, 2020 @ 3:57pm 
If you want to check what speed your memory is running at, I'd recommend downloading CPU-Z (free and widely used) and have a look in the "Memory" section. Changing the memory speed is totally possible to do, but will need to be done in the BIOS so research first if you intend to try. Most pre-built systems will not have enabled the XMP so you might be losing some horse power right there.
A moderator of this forum has indicated that this post answers the original topic.
MyProfile May 10, 2020 @ 6:55pm 
Make sure you're actually using the 1070 and not onboard graphics. You should be cooking with that rig. In comparison, I'm playing on an 8 year old gaming laptop and I really can't complain about performance unless I try to run a browser while in the game.
< >
Showing 1-15 of 19 comments
Per page: 1530 50

Date Posted: May 10, 2020 @ 11:11am
Posts: 19