7 Days to Die

7 Days to Die

View Stats:
7 Days to Die > Servers > Topic Details
Okko Jul 13, 2017 @ 8:25am
Just rented a dedicated server [HELP]
Hello, just rented a dedicated server for me and my friends to play on, but it seems to just keep restarting over and over again, this is what the console reads out to me.

https://pastebin.com/zGmt9xzT
< >
Showing 1-12 of 12 comments
Okko Jul 13, 2017 @ 8:26am 
2017-07-13T16:22:38 0.119 INF Parsing server configfile: C:/TCAFiles/Users/OliJ/61290/7DaysToDieServer_Data/../vserverconfig.xml
2017-07-13T16:22:38 0.166 ERR Error parsing configfile property 'EnemySenseMemory': Unknown config option
2017-07-13T16:22:38 0.166 INF Make sure your configfile is updated the current server version!
2017-07-13T16:22:38 0.167 INF Startup aborted due to the given error in server configfile
Aragon Jul 13, 2017 @ 9:17am 
EnemySenseMemory - this entry is from pre-alpha16 and outdated (removed), if u start an alpha 16 server u need a config-file up to date without this entry.
Okko Jul 13, 2017 @ 9:21am 
Originally posted by Aragon:
EnemySenseMemory - this entry is from pre-alpha16 and outdated (removed), if u start an alpha 16 server u need a config-file up to date without this entry.
Tyvm this is what i was looking for, not sure how to get a proper config file as i've reinstalled the server from my provider and it says that it is running alpha 16, which makes you assume it would also use the proper config.

Where could i get a proper config file?
Last edited by Okko; Jul 13, 2017 @ 9:23am
TFO_Nightstalker Jul 13, 2017 @ 9:24am 
same here it seems the servers ie like games server are not useing the right one i tryed that on mine and still got the error
Okko Jul 13, 2017 @ 9:25am 
Originally posted by TFO_Nightstalker:
same here it seems the servers ie like games server are not useing the right one i tryed that on mine and still got the error
I deleted the line just now and im getting another error about enemy spawn so i guess we just wait?
TFO_Nightstalker Jul 13, 2017 @ 9:25am 
took out the old entery anf put in the new still dont work get same error
Okko Jul 13, 2017 @ 11:06am 
Originally posted by Mad Zombie:
try looking at A16 local files and then change them with WinScp i use it to change all my xml file's
hope this help's
I am able to modify the files but that doesn't help me as i don't know what the settings should be in the new patch :)
Okko Jul 13, 2017 @ 11:58am 
The vserverconfig file
Thirst.Blood Jul 13, 2017 @ 11:58am 
ok 1 min
Okko Jul 13, 2017 @ 12:02pm 
I'll try and let you know thank you! :)
Aragon Jul 13, 2017 @ 2:28pm 
<property name="EnemySenseMemory" value="50" />
is also removed in a16. Below is an a16 config file, u need to change some entries to fit ur server:

<?xml version="1.0"?>
<ServerSettings>
<property name="ServerPort" value="26900"/>
<property name="ServerIsPublic" value="true"/>
<property name="ServerName" value="insert_ur_servername_here"/>
<property name="ServerPassword" value="add_a_pw_here_if_u_want"/>
<property name="ServerMaxPlayerCount" value="8"/>
<property name="ServerReservedSlots" value="0"/>
<property name="ServerReservedSlotsPermission" value="100"/>
<property name="ServerAdminSlots" value="0"/>
<property name="ServerAdminSlotsPermission" value="0"/>

<property name="ServerDescription" value="Whatever_you_want_the_description_to_be"/>
<property name="ServerWebsiteURL" value=""/>
<property name="ServerDisabledNetworkProtocols" value="UNET"/>

<property name="GameWorld" value="Navezgane or Random Gen"/>
<property name="GameName" value="Random_Generation_ID"/>
<property name="GameDifficulty" value="3"/>
<property name="GameMode" value="GameModeSurvivalMP"/>

<property name="ZombiesRun" value="0" />
<property name="BuildCreate" value="false" />
<property name="DayNightLength" value="50" />
<property name="DayLightLength" value="18" />
<property name="PlayerKillingMode" value="3" />
<property name="PersistentPlayerProfiles" value="false" />

<property name="PlayerSafeZoneLevel" value="5" />
<property name="PlayerSafeZoneHours" value="5" />

<property name="ControlPanelEnabled" value="true"/>
<property name="ControlPanelPort" value="8080"/>
<property name="ControlPanelPassword" value="insert_a_pw_here"/>

<property name="TelnetEnabled" value="false"/>
<property name="TelnetPort" value="8081"/>
<property name="TelnetPassword" value=""/>

<property name="AdminFileName" value="serveradmin.xml"/>

<property name="DropOnDeath" value="0" />
<property name="DropOnQuit" value="0" />

<property name="BloodMoonEnemyCount" value="insert_how_much_zombies_spawn_for_each_player" />
<property name="EnemySpawnMode" value="true" />
<property name="EnemyDifficulty" value="0" />

<property name="BlockDurabilityModifier" value="100" />
<property name="LootAbundance" value="100" />
<property name="LootRespawnDays" value="14" />

<property name="LandClaimSize" value="41"/>
<property name="LandClaimDeadZone" value="30"/>
<property name="LandClaimExpiryTime" value="3"/>
<property name="LandClaimDecayMode" value="0"/>
<property name="LandClaimOnlineDurabilityModifier" value="4"/>
<property name="LandClaimOfflineDurabilityModifier" value="4"/>
<property name="AirDropFrequency" value="0"/>
<property name="AirDropMarker" value="false"/>
<property name="MaxSpawnedZombies" value="60"/>

<property name="MaxSpawnedAnimals" value="50"/>
<property name="EACEnabled" value="true"/>
<property name="HideCommandExecutionLog" value="0"/>
<property name="MaxUncoveredMapChunksPerPlayer" value="131072"/>
<property name="BedrollDeadZoneSize" value="15"/>

<!--property name="SaveGameFolder" value="absolute path" /-->
</ServerSettings>

Okko Jul 13, 2017 @ 2:40pm 
Solved it, thanks for all the help guys.
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

7 Days to Die > Servers > Topic Details
Date Posted: Jul 13, 2017 @ 8:25am
Posts: 12