TowerFall Ascension

TowerFall Ascension

View Stats:
Matt  [developer] Apr 17, 2015 @ 12:16am
Dark World Update Beta
The Dark World Update changes are now live on the game's beta branch! To be clear, none of the new Dark World Expansion content is available yet, but all the updates to Ascension are. There's a ton of changes to Ascension that come along with the Dark World update that make it much better in its own right, even for people who never buy the new expansion.

Any testing is super appreciated! If you run into any bugs, post them here. Enjoy :)

The beta is now available on Windows, Mac, and Linux!

To enter the beta branch, right-click TowerFall Ascension in your Steam Library. Select properties, and then go to the Betas tab. Select 'beta' from the drop-down list.

Here's the full changelist as it stands right now![docs.google.com]

Fixes and changes made since posting this (the beta branch should have all these changes):
  • Added an alternate match end music track (it randomizes between the new and old ones)
  • Added the ReplayExport_Config.xml to configure how replays GIFs are exported, and improved the default export time of replays
  • Fixed Return As Ghosts not working if Exploding Corpses is also enabled
  • Fixed dropped items (icicles, crystal balls) opening chests they hit even if they're already open (resulting in duplicate item spawns)
  • Fixed white archer's hair not appearing when her hair tie is shot off
  • Fixed crash in TowerForge II trial
  • Fixed incorrect behavior in Team Deathmatch mode when a team one point from winning kills their last opponent after their own deaths
  • Fixed some rare arrow physics bugs when stuck in corpses
  • Fixed rare physics bug with corpses pushing out from each other
  • Fixed breaking platforms reappearing on top of player corpses or ghosts
  • Fixed cases where lives display in Quest mode could get out of sync with how many lives you actually have
  • Added the king to the background of a King's Court Team Deathmatch level too
Last edited by Matt; May 3, 2015 @ 7:57pm
< >
Showing 1-15 of 57 comments
kha Apr 17, 2015 @ 7:30am 
Not seeing any update on Linux. Should this be live for all platforms?
RyuSage Apr 17, 2015 @ 12:27pm 
Here's one bug that just happened to us.

What Happened:

Speed boots that were already grabbed reappeared over the chest they came from, and would not disappear again.


Steps to reproduce:

1) Play Headhunters with Purple and White archers. Standard Length, No variants enabled.
2) Select Twilight Spire for tower.
3) Play the map with a chest on a platform in the center. I think the chest had a disappearing platform right above it?
4) White opens the chest in the center, gets speed boots. They should disappear.
5) After a short time, the boots reappear above the chest. They no longer disappear when you touch them. I'm not sure if touching them gives the buff or not.
Matt  [developer] Apr 17, 2015 @ 1:29pm 
Apologies, I should have mentioned that the beta is only available for Windows. We'll be porting to Mac and Linux closer to release.

Thanks RyuSage, I'll look into that bug :)
RyuSage Apr 17, 2015 @ 2:03pm 
No problem. Thanks for the update! The game plays so much smoother, it's amazing. :D
Matt  [developer] Apr 17, 2015 @ 5:31pm 
Awesome, we've already found two bugs I probably would've missed :) Keep your eyes peeled for more! I put a changelog in the first post of the bugs we've found and fixed so far.
none Apr 17, 2015 @ 7:43pm 
Purple (RyuSage from this thread actually) caught the arrow white shot right as the block was transitioning back to solid. The block turned solid and caught him in it where he then died to miasma.

http://i.imgur.com/sK4tUU3.gifv
Knightsoldier Apr 17, 2015 @ 10:58pm 
I start Towerfall using Steam (or Big Picture) and using the Beta branch and I have this annoying message box saying: "Couldn't find Steam!" with a Ok button

In fact, the message box appears and stays 10 seconds, then disappears for 5 seconds. and then reappears again.

I've tried
- to verify integrity of game cache
- to reinstall Towerfall on different hard drive
- to restart Steam
- to reboot computer
And I still have the same error.

Though, I managed to start it once (with v1.2.1.5)... but I don't know really how exactly I've done it...

I can have the same error if I switch to normal branch (v1.1.19.5) without restarting steam.
But if I restart steam, the game loads....
If I switch to beta, and restart steam, I still have the error.

I've added -loadlog to launch options
And I've got only this :

==============================================
TowerFall Loading Log
Support: mattmakesgames.help@gmail.com
1.2.1.6
----------------------------------------------
Initializing Steam...
==============================================

FYI, my Steam directory is not in default one (C:\Program Files(x86)\Steam)
I guess it should not be a problem... but just in case. :)

FYI 2, I've got that problem with mostly every new version (between 1.1.17 and 1.1.19.5 I would say). But each time, I've been lucky enough to find a way to get it loads. But now, I really don't know what to do...
Kabu Apr 20, 2015 @ 12:34am 
Two bugs I noticed:


What Happened:

Ghost spawned in just as a crumbling platform returned, causing the ghost to be stuck within the platform.


Steps to reproduce:

1) Play Headhunters with Return as Ghosts.
2) Play Twilight Spire.
3) Get killed directly under a crumbling platform as the platform is destroyed.
4) Spawn in as a ghost at the same time the platform returns.

Bug Number 2:

What Happened:

Ancient Exile's hair bun disappears when removed by an arrow or when a crown is picked up, and her hair does not let down. Her hair only lets down if she has a crown at the start of a round.

Steps to reproduce:

1) Play Versus with Ancient Exile and any other archer.
2) Select any map.
3) Purposefully shoot off Ancient Exile's hair bun.
4) Attempt to pick up a crown as Ancient Exile.
5) Play a round where Ancient Exile is in the lead.

Hope that helps! I was really bummed how Ancient Exile lost her flowing locks, unless she was in the lead.
Matt  [developer] Apr 20, 2015 @ 1:00am 
Super helpful, thank you! Uploading fixes for those now :)
Kabu Apr 20, 2015 @ 1:28am 
No problem! I just remembered two more, but they're a bit strange..
I've noticed some weird discrepencies with the end of the round lights-off, but they were two different cases and I don't know how credible they were as bugs. However, they confused my friends and I, and it may warrant investigation.

Bug 1:

What Happened:

A player won, only to be shot immediately afterwards on Team Deathmatch last man standing, steak-in-mouth style. However the lights remained dark and did not return the normal game music or turn the level's lighting back on. It then proceeded to the next round as if it were a regular Steak-in-mouth scenario.


Steps to reproduce:

1) Play Team Deathmatch 1 versus 2.
2) Select Sunken City.
3)Have the opposing team get to 4 rounds out of 5.
4) Kill one enemy as the solo-player, and shoot the other player exactly after they stomp you.
5) The darkness end-of-round indicator should show from the first kill, but should not be removed where it normally is before. This happened only once, after we had the normal steak-in-mouth scenario play out a few games previously.

Bug 2:

What Happened:

A self-kill that ended a Team Deathmatch Last Man Standing game did not result in the end-of-round darkness indicator.


Steps to reproduce:

1) Play Team Deathmatch 1 versus 2.
2) Select Flight.
3)Have the opposing team get to 4 rounds out of 5.
4) Kill yourself with a bomb arrow.
5) The Darkness end-of-round indicator should not show.


Really loving the ghost changes so far and the team deathmatch maps, if anything else comes up, I'll post it here.
Storm Rayne Apr 20, 2015 @ 12:57pm 
I found a bug who crashs Towerfall and this bug prevents to me to unlock the Yellow Archer , i uninstall/reinstall the game if it was a problem about my download but the bug was still here

What Happened : I can't go at Towerforge 2 in "Trials Mode" if you have the 7 Yellow Gems

Steps to Reproduce :
1) Play Trials Mode
2) Get all the 7 Yellow Gems
3) Go to Towerforge 2
4) The Game will Crash

I don't know if the Game Crashes also when you have not any gems or some of them....
Knightsoldier Apr 20, 2015 @ 6:11pm 
Strange enough...
When I click "Play" in Steam, I can see in the task manager, two process of Towerfall.exe are starting at the same time. o_O

That's probably why I can see two "Couldn't find steam" message boxes.
Matt  [developer] Apr 20, 2015 @ 8:02pm 
@Kabu: Fixed! If possible, please play more Team Deathmatch games and see if you spot anymore issues, but I think I fixed them all :)

@storm4mt: Fixed! Thanks :)

@Knightsoldier: I'm really sorry, but this sounds like a problem with your Steam installation and not TowerFall. I'll let you know if I learn otherwise.
Matt  [developer] Apr 21, 2015 @ 5:14pm 
I just updated again with a few more small bugfixes. I think it's almost finished :)
Knightsoldier Apr 21, 2015 @ 7:22pm 
And... you are right ! :P

Though, the reinstalation or repair of steam wasn't the solution.

Deleting the "%APPDATA%\..\Local\Steam" folder was mine.

And my towerfall beta works now like charm!

BTW, great game and can't wait the DLC! ^_^ !

Thank you!
< >
Showing 1-15 of 57 comments
Per page: 15 30 50

Date Posted: Apr 17, 2015 @ 12:16am
Posts: 57