The Inner World

The Inner World

View Stats:
minego Mar 17, 2015 @ 11:27pm
No cutscenes
I grabbed this from the humble bundle, and start playing on Linux... but found it very confusing. Eventually I realized that there are supposed to be cut scenes. They do not play at all for me, and there is no indication that they should be there.
< >
Showing 1-15 of 39 comments
flesk Mar 18, 2015 @ 1:53pm 
I have the same issue with the DRM free version. The movies are there and play just fine with Dragon Player, but they are not triggered at all in-game.
minego Mar 18, 2015 @ 5:38pm 
Well at least I'm not the only one seeing that. I was VERY confused.
Herochao [Linux] Mar 20, 2015 @ 4:55am 
I have this problem as well, tried installing gstreamer, flash etc. Hope there will be a fix soon, but thanks for the port :D

EDIT: solution in my next post
Last edited by Herochao [Linux]; Mar 21, 2015 @ 4:04am
fallsilentio  [developer] Mar 20, 2015 @ 6:11am 
Hey, this should fix the cut-scene problem:

You must install GLIB 2.28 in order to run JavaFX Media.

You must install the following in order to support AAC audio, MP3 audio, H.264 video, and HTTP Live Streaming:

* libavcodec53 and libavformat53 on Ubuntu Linux 12.04 or equivalent.
(quelle: http://www.oracle.com/technetwork/java/javase/certconfig-2095354.html)


Unfortunately it seems that the cutscene-implementation currently crashes the game when launched directly from STEAM. But it runs perfectly if you run the TIW_start.sh directly without using STEAM from the local folder.
Gnurfos Mar 20, 2015 @ 2:05pm 
Hi, I got GLIB 2.32.4 + libav*53 (linux Mint Maya), but still no cutscenes. Thanks for the Linux port anyway, and for the support. Hope to hear more news soon !
Herochao [Linux] Mar 20, 2015 @ 4:38pm 
I succeeded, for archlinux x64, I installed ffmpeg-compat (may not be neccessary?), and I installed the oracle version of jre8, using the oracle jre, it worked.

The video spawns in a new window, seperate from the main window. THis casts the problem that the music is stopped every time the main window looses focus, resulting in the background music being lost after every time a video plays :/

but still, the game is now close to playable, and maybe my report helps :D

EDIT:

Overall solution on x64 archlinux:

1. Install the oracle jre ("jre" from the AUR)

2. Set it as your default (using "archlinux-java set java-8-jre/jre")

3. install ffmpeg compatiblity librarys ("ffmpeg-compat" from AUR, do not install ffmpeg-compat55 or similar)

(4.?) run LD_LIBRARY_PATH=/usr/lib/ffmpeg-compat/
export LD_LIBRARY_PATH to load the compat librarys when starting TIW (not neccessary for me)

note that the game will crash with a cutscene when started from steam, probably because it's opening a second window (Steam overlay etc.)?
Last edited by Herochao [Linux]; Mar 21, 2015 @ 1:19am
minego Mar 20, 2015 @ 4:58pm 
What is the package name for the oracle version of jre8? I have jre8-openjdk installed at the moment along with ffmpeg-compat.
minego Mar 20, 2015 @ 5:09pm 
Ah, the "jre" AUR appears to be the right one. I'm launching the game now with that installed.

yaouart -S jre
sudo archlinux-java set java-8-jre/jre
Last edited by minego; Mar 20, 2015 @ 5:10pm
Herochao [Linux] Mar 20, 2015 @ 5:11pm 
yes, the package is jre from the AUR.

After installing it, you need to use "archlinux-java set java-8-jre/jre" (as root) to make it the default. Then just start the game. Test wether it is set using "archlinux-java status", you can find a more detailed guide in the arch-wiki.

Edit: oh, you where faster than me :) have fun with the game!
Last edited by Herochao [Linux]; Mar 20, 2015 @ 5:12pm
minego Mar 20, 2015 @ 5:12pm 
Damn, that didn't help.
Herochao [Linux] Mar 20, 2015 @ 5:14pm 
hm.. I'm running it from the AUR. The quickest way to test it is to start a new game, which itself should start with a cutscene. I started the game without steam, from terminal in .../SteamApps/.../TheInnerWorld/ "./TIW_start.sh", check your archlinux-java status
Last edited by Herochao [Linux]; Mar 20, 2015 @ 5:15pm
minego Mar 20, 2015 @ 5:18pm 
Yeah, as far as I can tell I'm doing the same thing you are. I've tried starting the game from steam and from the terminal. Running 'archlinux-java status' shows the right thing.

I'll keep experimenting.

EDIT: btw, thank you for the help! Despite not having it working yet, I really appreciate it.
Last edited by minego; Mar 20, 2015 @ 5:21pm
Herochao [Linux] Mar 20, 2015 @ 5:22pm 
Oh, one thing i did before installing the jre, after getting the ffmpeg-compat package, in terminal:

LD_LIBRARY_PATH=/usr/lib/ffmpeg-compat/
export LD_LIBRARY_PATH

try that, that should be everything i changed
minego Mar 20, 2015 @ 5:37pm 
Still no dice :/
Herochao [Linux] Mar 20, 2015 @ 5:41pm 
could you post the output of your pacman -Q somwhere and link it for me? maybe that helps us
< >
Showing 1-15 of 39 comments
Per page: 15 30 50