SteamVR

SteamVR

AlmaSinNombre Jul 21, 2019 @ 8:08pm
definitive method to reset or restore SteamVR to default / factory options (clean Reinstall)
many thanks to Julian from vive support team to help me out!
the following steps will restore steam vr and all the settings to default, in my case this help me to fix some perfomance issues caused by programs like Openvr Advanced settings (Uninstall said program or any 3rd Party VR software before following these steps...)

Manually clear SteamVR settings:
In certain scenarios, like changes the SteamVR settings or has used 3rd Party VR software, Steam/SteamVR will start to behave unexpectedly. Despite it is recommended to reinstall both Steam/SteamVR on these scenarios, it is possible to clear the current settings and enforce a clean setup of all the system again. This process will clear the SteamVR settings and the lighthouse settings stored on the system.
1. Completely close Steam and SteamVR.
2. Navigate to each path and delete the following files:
a. C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings
b. C:\Program Files (x86)\Steam\config\steamvr.vrsettings
c. C:\Program Files (x86)\Steam\config\lighthouse\lighthousedb.json

Then Uninstall steam VR! You can do so with the following instructions:
1. Right click the SteamVR tool from the Steam Library and select Unistall
2. Follow the on screen prompts to complete the uninstallation of the SteamVR tool.

(important) Make sure to delete any leftover files in the installation directory by deleting the contents in the folder “SteamVR”
The default path for that folder would be:
"%ProgramFiles(x86)%\Steam\steamapps\common\SteamVR"

then Re-install SteamVR: You can so do by downloading and installing the latest release directly from the steam library by clicking the Install button, keep in mind that you may need to reselect the SteamVR tool from the Steam Library to display the Install button.

*This also can be done by typing “steam://run/250820” on your favorite browser

note: 3rd Party programs may create files outside the steam directories
Last edited by AlmaSinNombre; Jun 7, 2020 @ 6:46am
Originally posted by cris2003:
Alma, put this extra thing at the end of the post: I think would help some people.

Short version for people who's still with the issue:
Make a clean reinstall of your nvidia graphic drivers.
If you're on AMD side, prolly this error would be solved with Alma's tutorial.

Longer version:
Using as me a Valve Index, which have 120 Hz and 144 Hz modes, what happens is one of the frecuencies (Hz) gets corrupt on the drivers side, so you need to reset the drivers.

That means if you, for example, use regular 144 Hz, and get 435 error, going to C:\Program Files (x86)\Steam\config\steamvr.vrsettings and removing that file, would put your Index on 90 Hz, the default Hz amount, then work; but the plot twist is that driver stills corrupt, so if you change to 120 Hz or 80 Hz, you would be ok, but when putting on 144Hz, you would get the same.

And yes, if yoy was using 90 Hz when corrupted, you would suffered a complete soft brick of your HDM if you're not solving this issue, or, using another PC/laptop or reinstalling Windows.

After a week, when 144 Hz got bugged and staying at 120 Hz, yesterday I got 120hz corrupted too.

That meant to use the ♥♥♥♥ horrible 90 Hz or 80 Hz (I'm so used to 120+, go to 90 now makes me feel all blurry when move), so I didn't stand it more, and I checked, removed all valve's software, cleaned manualy all Valve and Steam regs on regedit, and then after all that don't working, I noticed the graphic card drivers would be the logic conclusion I completely ignored.
I heard clean Windows re-install makes that error dissapear and work, and after emulate a first time steam clean launch, my driver theory got more force, due a Windows reinstall means install drivers from 0.

After go to Geforce Experience, go to find updates, and if nothing new, find the "reinstall driver" option.
Select manual, and check ALL the option boxes.

After that, congrats, you would be able to use again your corruped frequency, and if you suffered the same as me, congrats, you would scape this time from use the hell-ous 90 to 80 Hz.

-----
I hope this would help anyone with the same issue, now Google would postion this post on first places when searching "error 435" or "Steamvr error 435" if we want to help more people... :p2cube: :p4g_love:

P.D.:
Just in case, I tried a lot of extra stuff, like ports changing and all, so I localiced the error after steam unistalling, but before that I tried a lot more things. My message only talks about the last resort I had (erase and delate all Valve signal of life from my disks) and how it failed, only to notice the error where the drivers.
In my case, I'm using 446 driver with a 1070 EX 8GB.[/u]
< >
Showing 1-15 of 26 comments
Snoopa Jul 25, 2019 @ 8:04am 
Testing this now. Hopefully, it helps with the problem I'm having. Will Update.
Snoopa Jul 25, 2019 @ 8:40am 
So I was hoping this would help but sadly it didn't. But my issue might not have been the scenario for this.

I've been having trouble with my headset not connecting to the the stations. Everything is lit green showing me they see each other but that's the extent. Now my HMD will turn green but no visuals coming through. Then it just wouldn't work.
AlmaSinNombre Jul 25, 2019 @ 12:36pm 
Originally posted by Snoopa:
So I was hoping this would help but sadly it didn't. But my issue might not have been the scenario for this.

I've been having trouble with my headset not connecting to the the stations. Everything is lit green showing me they see each other but that's the extent. Now my HMD will turn green but no visuals coming through. Then it just wouldn't work.

strange problem, inside steam vr options on the developer tab, theres an option to reset all steam vr usb devices, activate that option and wait ti finish, once completed disconect all htc vive related cables, then do an complete clean reinstall of you graphics drivers, restart the computer, ensure your drivers are working, then reconnect all htc vive related cables, you pc should start installing all drivers again, give it some time (maybe 10mins to be sure), the when finish, start steamVR, and tell me the results
Snoopa Jul 25, 2019 @ 1:22pm 
Originally posted by AlmaSinNombre:
Originally posted by Snoopa:
So I was hoping this would help but sadly it didn't. But my issue might not have been the scenario for this.

I've been having trouble with my headset not connecting to the the stations. Everything is lit green showing me they see each other but that's the extent. Now my HMD will turn green but no visuals coming through. Then it just wouldn't work.

strange problem, inside steam vr options on the developer tab, theres an option to reset all steam vr usb devices, activate that option and wait ti finish, once completed disconect all htc vive related cables, then do an complete clean reinstall of you graphics drivers, restart the computer, ensure your drivers are working, then reconnect all htc vive related cables, you pc should start installing all drivers again, give it some time (maybe 10mins to be sure), the when finish, start steamVR, and tell me the results
Bro, I'm considering you're post as a last ditch effort. Meaning, I've tried that everything I could at least 10 times. Your suggestion alone, I've reinstalled drives more than I can keep count. Believe me, I've tried every angle including bypass.

Every new reinstall, it does the same thing. Everything comes on and SteamVR shows everything running. Then 10 secs into it, the headset goes from green to black and I'm told to make sure to show the headset to the base. Which I do. Eventually, it all goes grey and I'm back at square one.

Point out as well, I've had this vive for 3yrs now and it just recently started doing this.
AlmaSinNombre Jul 25, 2019 @ 1:52pm 
Originally posted by Snoopa:
Originally posted by AlmaSinNombre:

strange problem, inside steam vr options on the developer tab, theres an option to reset all steam vr usb devices, activate that option and wait ti finish, once completed disconect all htc vive related cables, then do an complete clean reinstall of you graphics drivers, restart the computer, ensure your drivers are working, then reconnect all htc vive related cables, you pc should start installing all drivers again, give it some time (maybe 10mins to be sure), the when finish, start steamVR, and tell me the results
Bro, I'm considering you're post as a last ditch effort. Meaning, I've tried that everything I could at least 10 times. Your suggestion alone, I've reinstalled drives more than I can keep count. Believe me, I've tried every angle including bypass.

Every new reinstall, it does the same thing. Everything comes on and SteamVR shows everything running. Then 10 secs into it, the headset goes from green to black and I'm told to make sure to show the headset to the base. Which I do. Eventually, it all goes grey and I'm back at square one.

Point out as well, I've had this vive for 3yrs now and it just recently started doing this.

ho... knowing that now
the problem could be on hardware levels, send you headset to vive support for repairs
Snoopa Jul 25, 2019 @ 6:04pm 
Originally posted by AlmaSinNombre:
Originally posted by Snoopa:
Bro, I'm considering you're post as a last ditch effort. Meaning, I've tried that everything I could at least 10 times. Your suggestion alone, I've reinstalled drives more than I can keep count. Believe me, I've tried every angle including bypass.

Every new reinstall, it does the same thing. Everything comes on and SteamVR shows everything running. Then 10 secs into it, the headset goes from green to black and I'm told to make sure to show the headset to the base. Which I do. Eventually, it all goes grey and I'm back at square one.

Point out as well, I've had this vive for 3yrs now and it just recently started doing this.

ho... knowing that now
the problem could be on hardware levels, send you headset to vive support for repairs
Nah, I'm the type to fix my own broken things. I don't trust manufacturers and companies on so many things.

But I have isolated the problem to being the 3-in-1 cord that is goes directly to the HMD. It's the HDMI cable. Problem now is that the slot is thinner than all the cables I have lying around the house. That's some slight evilness in the design. :hskull::steamhappy: So now I'm going to splice the cable. :cozyprodman:;) To battle that evil. :TimberKnightHelmet:
AlmaSinNombre Jul 25, 2019 @ 6:06pm 
Originally posted by Snoopa:
Originally posted by AlmaSinNombre:

ho... knowing that now
the problem could be on hardware levels, send you headset to vive support for repairs
Nah, I'm the type to fix my own broken things. I don't trust manufacturers and companies on so many things.

But I have isolated the problem to being the 3-in-1 cord that is goes directly to the HMD. It's the HDMI cable. Problem now is that the slot is thinner than all the cables I have lying around the house. That's some slight evilness in the design. :hskull::steamhappy: So now I'm going to splice the cable. :cozyprodman:;) To battle that evil. :TimberKnightHelmet:

great!!
have luck whit that :D
OtA 30fps Sep 5, 2019 @ 5:25pm 
THANKS for sharing this guide with us, was very useful for me! :heart: (i hate you fpsvr)
AlmaSinNombre Sep 5, 2019 @ 5:35pm 
Originally posted by OtaQueen:
THANKS for sharing this guide with us, was very useful for me! :heart: (i hate you fpsvr)

:D
yaaaaaayyyy im really happy to know that my post is being helpfull
i was on your position before, looking everywhere! trying to find a way to free my steamvr from awfully made third party sofwares!

until i finally contacted julian from vive support yasss
he gave the solution and i knew exaclty what to do whit it, share it so anyone whit my same problem can fix it quickly and easily yay
RazorModz Dec 31, 2019 @ 4:36pm 
You my friend are a legend. Thankyou very much indeed! :)
AlmaSinNombre Dec 31, 2019 @ 5:09pm 
Originally posted by RazorModz:
You my friend are a legend. Thankyou very much indeed! :)

my pleasure to help you!
LivLou Jan 16, 2020 @ 12:21pm 
Whenever I open steamvr with my headset etc connected I loose all connection
AlmaSinNombre Jan 16, 2020 @ 3:37pm 
Originally posted by LivLou:
Whenever I open steamvr with my headset etc connected I loose all connection

there is a setting that allows restarting all devices on steam vr, that will reinstall all drivers
Fragarach Mar 15, 2020 @ 11:37pm 
I had an issue "SteamVR addons blocked/Headset not detected", despite working perfectly prior to this with no changes to the PC.

(see also https://steamcommunity.com/app/250820/discussions/0/3148519094651762120/)

This method of uninstall fixed my issue. Thank you so much for posting this!!
AlmaSinNombre Mar 16, 2020 @ 12:30am 
Originally posted by Fragarach:
I had an issue "SteamVR addons blocked/Headset not detected", despite working perfectly prior to this with no changes to the PC.

(see also https://steamcommunity.com/app/250820/discussions/0/3148519094651762120/)

This method of uninstall fixed my issue. Thank you so much for posting this!!


yayyy im happy to ear my post was helpful :D
< >
Showing 1-15 of 26 comments
Per page: 1530 50

Date Posted: Jul 21, 2019 @ 8:08pm
Posts: 26