View Stats:
FORCED > General Discussions > Topic Details
ean5533 Nov 3, 2013 @ 12:36pm
[Linux][Gamepad/Keyboard][Everywhere] Controller AND keyboard input both broken (in different ways)
I'm having two separate but related problems, both related to in-game input.

The first problem is that my Xbox 360 controller does not work in-game. If I go to the controller config section I can get 90% of the way through the configuration walkthrough. I can press all 20 buttons/axes on my controller and the config receives them all, and I can map each key to a command as the config asks me to. However, after pressing the last config key (which is a d-pad press), nothing happens. The config just sits there, and pressing the Next button does nothing. I can press the Back key and remap the last key, or I can press Restart and remap all the keys again, but each time after pressing the final key nothing happens. At this point I'm forced to press Cancel to get out of the config. After this if I try to play a game with the controller I get no response in-game.

The second problem is that in-game keyboard input is almost completely broken. I can move around with WASD, I can press enter and type whatever I want and send it, and I can move the mouse and watch my character face the direction of the cursor. However, clicking does nothing and no other keyboard keys do anything. I cannot even open the menu with escape. Once a game starts I'm forced to alt-tab out and kill the game.

Workarounds I've tried:

1) Making sure my controllers are plugged in and ready to go before booting computer and starting game
2) Entering a game, pressing enter, typing "/forgetsaves" into the prompt, pressing enter, and restarting the game
3) Remapping keyboard keys (for example, I tried mapping the menu command to the "z" key, but it still didn't open a menu in-game)

My system:

Linux Mint 15 32-bit
GTX 260 using proprietary driver version 310.44

My most recent player.log file:

Note all of the null reference exceptions that look like this:

(Filename: Line: -1) NullReferenceException: Object reference not set to an instance of an object at InputManager1.HandleRuntimeInput () [0x00000] in <filename unknown>:0 at InputManager1.Update () [0x00000] in <filename unknown>:0

The actions I took to generate this log:

1) Start game
2) Go to controller config
3) Using my Xbox 360 wireless controller, press all 20 buttons/axes
4) Wait during the "reading dead values" timeout
5) Go through the steps of assigning each key
6) After assigning the final key (which is pressing the d-pad), the controller config scene just does nothing, so I'm forced to press cancel to get out of the config.
7) I go play a single player game with keyboard selected as input
8) After game starts, I move around with the WASD and use the mouse (which both work fine). I try clicking, pressing escape, and several other keyboard keys, but nothing happens.
9) With no access to the menu, I'm forced to alt-tab out and kill the game

Note that I could only save the first couple thousand lines of the log because it was too long for pastebin (about 65 thousand lines total), but the log just repeats itself after the null ref exceptions start so there's nothing useful there.
< >
Showing 1-2 of 2 comments
ean5533 Nov 11, 2013 @ 5:54pm 
No response for a week. Bump.
ean5533 Nov 16, 2013 @ 9:14am 
Issue still occurring in Linux Mint 16.

It's been three weeks since I posted in the bug thread and sent an email to support, with zero acknowledgement of any kind. The complete lack of followup is outrageous. Do you guys care about your customers at all?
Last edited by ean5533; Nov 16, 2013 @ 9:22am
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

FORCED > General Discussions > Topic Details
Date Posted: Nov 3, 2013 @ 12:36pm
Posts: 2