Command and Conquer 3: Kane's Wrath

Command and Conquer 3: Kane's Wrath

StWrath Jul 28, 2013 @ 12:34pm
Kane's Wrath crashes after popup screen.(Solved)
Kanes Wrath crashes right after it has shown me KW popup screen. It messes up my resolution and just stops responding - screen stays blank and no sounds. I have both CnC3 and KW bought from Steam. My usual resolution is 1920*1080 - the game forces 800*600 after launch and crashes. When I press Alt-Crtl-Del - i still see crap res and have quite limited control over mouse movements and can only move in Task manager window. Tried reinstalling and checked file integrity. My machine is more than enough for this game and CnC3 works on it without any problems at max reso and detail. Just trouble to get KW running. Using win7 64 bit. Steam stuff is in separate Steam folder not in program files. What I noticed in task manager it has the dat file of the game eating up cpu and memory - ca 25+ % cpu activity + up to 600mb ram just for the dat file. Got i5 3570K with 8 gb ram so the load shouldn't be issue :)
Hope someone can offer a solution that doesn't involve getting a cracked exe and dat files :)

UPDATE: after tinkering around I am able to run it "normally" at 1920*1080 + max setting with command line option "-Win" (that applies window mode that leaves taskbar hanging in front of view)
"-xres 1920 -yres 1080" gives direct3d error - any res with forced res gives error.
Videocard is: Asus GTX560Ti
Drivers: latest 320.49 WHQL
Direct X latest runtime installed
Win 7 x64 Sp1

Repeat: Command and Conquer: Tiberium Wars works at max with no issues or tinkering needed. Everything is installed in same Steam root folder :)

Next I will check that maybe its Virtu MVP thats ******** with game's understanding what hw it got :)

Ok I disabled Lucid Virtu MVP tech that my motherboard has been "blessed" with. This got the game running without any command line options needed.
After GPU Virtualization was put on Off - everything seemed to work fine. HyperFormance and VirtualVsync I disabled earlier with some other games that had issues with it.

How to find it? - It should be running at your taskbar system tray area(option maybe hidden or you can access it from your start menu. (you can disable it only if you have it - it is found on some Intel chipset based motherboards)
Last edited by StWrath; Jul 28, 2013 @ 3:01pm
< >
Showing 1-3 of 3 comments
Loaderini Jul 28, 2013 @ 2:32pm 
Are Tiberium Wars and Kane's Wrath installed both under the Steam folder?
StWrath Jul 28, 2013 @ 2:34pm 
Originally posted by Loaderini:
Are Tiberium Wars and Kane's Wrath installed both under the Steam folder?
Yes, they are. Something else is wrong :)
patrik.hs77 Jan 28, 2017 @ 9:03am 
I had similar issue, it seems in my case that problem was in anti-aliasing was turn on in high detail settings.
I went into steam library game properties and in set launch options I set -win
to start game in windowed mod then turn of anti-aliasing and game went fine since.
I hope it will help for others.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50