Command and Conquer 3: Tiberium Wars

Command and Conquer 3: Tiberium Wars

GarbageSauce Aug 8, 2015 @ 8:24pm
Game starts throwing out of memory errors
Okay. So I bought this game a while ago onto my Windows 7 Home Premium 64 bit machine and it ran fine. As the Windows 10 upgrade was approaching, I went ahead and bought my own copy of Windows 7 Professional 64 bit and then proceeded to upgrade to Windows 10 the same day. After upgrading, the game ran just fine like it did before. But all of a sudden, like, today sudden, the game starts throwing a Direct3D out of memory error and then would crash. I have tried messing with CPU affinity with the game, I uninstalled Visual Studio Community 2015, disabled my RAMDisk, installed the latest Windows 10 updates, uninstalled the most recent Windows 10 updates, stopped a Windows service that was installed earlier this day, and even did a steam game file check which supposedly checks the files of my game with the correct version and replaces all bad files. All of which did absolutely nothing. My GPU driver is up to date otherwise GeForce Experience would notify me and it hasn't bugged me in a few days. I am completely clueless as to why this is happening.

Now, the mod I like playing with is the R e t a r t e d mod. I tried playing without the mod and the error still appears. I have seen the error on two maps so far and that is it however, those two maps as well as a lot more were both downloaded and newly installed on wednesday. After downloading those maps, I played games on four of them and none of which gave me any problems. So I will attempt a few games on different maps and give you guys updates. Thanks!

PS: Steam kept censoring out the name of the mod so ignore the spaces inbetween the letters.

UPDATE: The game did the same thing when I tried a game on the map Roctagon. And yes that was with R e t a r t e d enabled.
Last edited by GarbageSauce; Aug 8, 2015 @ 8:53pm
< >
Showing 1-5 of 5 comments
Tacos Aug 11, 2015 @ 11:59am 
I have the same problem on Origin, someone know how to fix that pls?
BeLlSiBuB Aug 11, 2015 @ 6:38pm 
Same error on windows 7 64 bit just recently started after about 3 mins of play. (Nvidia 750 ti)
BeLlSiBuB Aug 14, 2015 @ 12:40am 
I set it to run as Windows XP Service Pack 3 and now seems ok on max settings.

Update: Forget that. I must have just got lucky. Problem is still occurring. Have also tried increasing virtual memory on drives. BTW I have 32GB Ram, i7.
Last edited by BeLlSiBuB; Aug 14, 2015 @ 7:59pm
I have finally found a solution to this...after much forth and back.

First, You just can't play the game on a 64 bit OS.... sooner or later the game will crash and you get the 'out of memory' error...

After testing several versions of windows (Ihave a 2 year old PC with good specs. Nvidia 980 GTX card and 16 mb ram on an ASUS Maximus ranger VII motherboard) I have found that Windows 7 32 ultimate works fine. I have played several hours and even saved complex games and reloaded them wo errors (I could not do this in the 64 bit version).

When you run several programs while you play, the game may lag but you don't get the 'out of memory error'. I do not use any antivirus and installed it on a clean Win 7 32 install. It don't lag when u only play CC, it runs smooth and fine. I have tested for 2 mods wo error. The mods I use is Tiberium wars advanced and Tiberium essence.

Hope this can help as this is a fun game to play...

cheers, Jan
Vertria Mar 6 @ 1:15pm 
I would like to redirect people to the following Steam forum:

https://steamcommunity.com/app/24790/discussions/0/358415206091823236/
< >
Showing 1-5 of 5 comments
Per page: 15 30 50