Nether > Troubleshooting > Topic Details
BIT Bear Dec 31, 2013 @ 10:34am
Cannot login. Sign in button not working
Edit: Added my system specs and other info.. hopefully it gets me a response.

Intel Core 2 Duo CPU E8500 (3.16 / 3.17ghz)
8 GB DDR3 1333mhz RAM
AMD Radeon 7790 HD
Harddrive has 700+ gb free space
Windows Vista 64-bit Home Premium

I have (re)installed:

Directx (updated to latest)
Microsoft Framework 4.0
Microsoft Framework 4.5
Nether (countless times)

The problem i´m having is that when i click the sign in button nothing happens.
The launcher doesn´t want to download, install or update the game and there is nothing i can do. Are there any specific requirements needed to get the launcher to work?.

Before the simple copy paste answers are coming:
Yes, i did fill in my PlayNether username and password.
Yes my Nether account is linked to steam.
Yes, I did try reinstalling Nether and/or (re)verifying files.
Yes, I have tried (temporarily) disabling my Anti-virus.
And Yes, I am running the launcher as Administrator.

Can someone please help me further?

Last edited by BIT Bear; Jan 7, 2014 @ 12:45pm
< >
Showing 1-10 of 10 comments
BIT Bear Dec 31, 2013 @ 3:34pm 
I went over and looked into the debugging and console logs and what i found is scaring the ♥♥♥♥ out of me.

Message: Uncaught TypeError: Object #<HTMLObjectElement> has no method 'GetLauncherVersion'
Source: file:///boot.html
Line: 42
Message: Uncaught TypeError: Object #<HTMLObjectElement> has no method 'SignIn'
Source: file:///boot.html
Line: 81

This is from the console log.. So basically the launcher I keep downloading through steam has no method for signing in? Did I buy into some kind of joke what is this?

*If I can't sign in. What am I supposed to do? Why isn't there a full client available for download?

Can I please get some support. I am more then willing to upload my logs or anything.
Last edited by BIT Bear; Dec 31, 2013 @ 3:36pm
Nectaria Jan 7, 2014 @ 10:40am 
I cannot press the button either. It says "version 0", and i get three missing-dll errors in a row when i start the launcher, but all dll-files are there.
Kross Jan 7, 2014 @ 11:56am 
I recommend trying to uninstall the game by downloading the launcher and choosing uninstall, then remove all remnants of the game.
Use any programm like Ccleaner and clean your stuff up, aswell as fix registry problems and such.

After that, download the game again via steam, you should try to start it from the folder in steam/steamapps/nether/Launcher -> Launcher.

I really don't know if it'd help, but I've seen it somewhere, all we can do is atleast try ^_^

BIT Bear Jan 7, 2014 @ 12:24pm 
Thank you for your reply, Kross. However i've tried (un)installing the game many times.
I have been trying that for almost a week on a daily basis.
This includes; regular reinstalls (through steam), manual reinstalls (including registry cleans) and even formatted my pc three days earlier. None of this had any effect and the problem still persists.

Seriously though it's just the frikkin' "sign in" button that doesn't work.
Why is this particular issue so difficult to get a reply to?
Kross Jan 8, 2014 @ 6:34am 
The thing is, I'm telling you to dig up the folder of the game.

I've found two launchers, one is just like you say, Log In button isn't more than cosmetic.

But the other one is the launcher which is succesfully noting me of my failure to log in.

Please do dig and ♥♥♥♥ around with the game files ^_^
BIT Bear Jan 8, 2014 @ 12:04pm 
Okay I have just reinstalled Nether again and out of nowhere it let´s me login and i´m downloading now. Just to clarify; I didn't change anything except reinstalling the game for the 50th time. Perhaps that's the trick behind it?

Anyway whilst i'm mildly happy that atleast it works now i really would like an official response on what is/was causing issues because not replying to Nether forum posts, Steam forum posts AND support mail is a horrible way to treat customers. I probably won't change my negative recommendation for this game until it comes out of alpha/beta.
rom3ox Jan 8, 2014 @ 1:22pm 
Hello, i would like to resume all steps i have done to get Nether working:

I have seen a lot of people having this problem and its seems to be happening on some 64 bits systems. I Downloaded the Nether Launcher from steam (68mb) and run it. The launcher seems not responding, cannot click on exit or sign-in button. I launch the launcher manually from the steam install dir and it throws curllib.dll error (dll errors)[] and start again locked.

Those are the steps i followed to solve the problem:

1) Go to Steam and delete the local content for Nether.
2) Redownload the launcher from steam or try this launcher: Manual Launcher[]
- Instructions: Game Download Instructions[]
3) Be sure to execute Steam and the launcher as administrator.
4) If its still locked, follow the steps from this post with the launcher closed: DLL errors thread[] and download these 2 files:
- Win32OpenSSL[]
- Win64OpenSLL[]
5) in some cases its says to install 2008 redist... so instal this files:
- Win2008 Redist 32b[]
- Win2008 Redist 64b[]
6) now the launcher its working and you have to login and link your steam account to download the game: Link Steam Account[]
7) If the download stops, you cand manually download from: Manual Game Download[]

Note: As always try Basic Troubleshooting[] or go to Official Nether Support[]
[SB]Shl_Holmes Jun 27, 2014 @ 1:33am 
Found a simple solution!
Just start Launcher.exe in ...steam/steamapps/common/nether/launcher in compatibility mode (right click properties and compatibility blabla...) windows xp service pack 3. voila! everything is working!!!
BIT Bear Jun 27, 2014 @ 1:38am 
Thanks for necro'ing my thread from last december. This thread is almost half a year old and i remember fixing this issue by installing Microsoft Frameworks 3.5 64-bit edition.
So if anyone still has the issue of not being able to sign in due to the launcher not working, try that.

But to be totally honest with you you shouldn't play this game. It's crap.
The community is total crap, the players are crap, gameplay is crap, there's 0 customer support (not even on their own forums) and the game is riddled with bugs/issues.
There's a strong reason there are so many negative reviews on this game.
Better not to ignore the players.

For those coming in through the recent nether sales.. im sorry you bought this game.
Last edited by BIT Bear; Jun 27, 2014 @ 1:43am
Kross Jun 27, 2014 @ 6:25am 
I dunno, I like it, the community is crap EVERYWHERE, You gotta find a bunch of awesome people.

The gameplay is unique and fun (In my personal opinion)
And customer support - I dunno, They really helped me actively for a long time and then dissapeared, but screw that. Support made for those who are too lazy to search on their own.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Nether > Troubleshooting > Topic Details
Date Posted: Dec 31, 2013 @ 10:34am
Posts: 10