Crypt of the NecroDancer

Crypt of the NecroDancer

 This topic has been pinned, so it's probably important
Computer freezing when you ALT-TAB or Exit the game? Please read!
Hi all! We are aware of an issue where players' computers freeze when trying to Alt-Tab or Exit the game and are trying to figure out the cause of it. We're sorry for all of the frustration this issue has caused in the meantime.

A work-around for the issue is to play in Windowed mode.

After doing some searching, some common fixes for similar issues in other games are:
If running Windows 10:
- Navigate to NecroDancer.exe, right click on the exe → Properties → Compatibility tab → Check the box next to "Disable fullscreen optimizations" → click Apply → click OK.

[How to get to NecroDancer.exe: Program Files (x86) → Steam → steamapps → common → Crypt of the NecroDancer → NecroDancer (application)] After doing this, then try running the game to see if that helps.

If you have a nVidia graphics card, please try these:
- Navigate to the nVidia Control Panel and disable fast sync
- Navigate to the nVidia Control Panel and disable vertical sync (v-sync)
- If nothing else seems to work, some users have reported that rolling back to an older version of your nVidia graphics driver may help. You may need to roll back several versions, not just one previous version. Users have recommended version 378 or earlier.

To find your nVidia Control panel, click in your system tray next to the date/time then right click on the nVidia icon. Choose "Open NVIDIA Control Panel" and scroll down the list of items. Click on the item you wish to change (ex: "Vertical sync") and use the drop-down menu on the right-side column to change settings.

Please let me know if any of these have helped you (and which one), or if you find another solution that has helped you. Hopefully by doing this, we can find a solution for this issue! Thanks in advance for your help.

If nothing listed above helps or applies to you and you're still experiencing this specific issue (computer freezes when trying to Alt-Tab or Exit the game), please reply with the following information:

1: Your operating system (OS):
2: The last 2 updates on your OS/last service pack:
(On Windows 10, You can check this by going to Settings → Update & Security → Update history)
3: Your video card brand:
4: Your video card driver version number:

If you are experiencing *other* freezing, crashing, or technical issues, please feel free to check our FAQ for the most common causes of issues and how to fix them. If nothing in our FAQ helps, please create a new thread and I'd be happy to help you.

Our FAQ can be found here:
http://necrodancer.com/faq.php
Last edited by BraceYourselfGames_Jackie; Jul 21, 2017 @ 2:51pm
< >
Showing 1-15 of 24 comments
Stay Optimistic Jul 23, 2017 @ 9:52am 
I tried suggested solution (turning off fast sync and v-sync, then properly reinstall the game and restart the pc and steam) but problem did not solved. Here's my information about my computer.
1. Windows 10 Home, 64-bit. DirectX 12.0
2. KB4025376 and KB4025342
3. Nvidia GeForce GTX 1050
4. 384.76
Sappari Jul 25, 2017 @ 10:56pm 
It's great to know that you've noticed this issue! Thanks for your hard work! Hopefully, I provided the correct information.

1: Your operating system (OS): Windows 10 Home, 64-bit Build 15063, DirectX 12

2: The last 2 updates on your OS/last service pack: KB4025376 and KB4025342

3: Your video card brand: Intel(R) HD Graphics 4600; Dedicated - Nvidia Geforce 860M

4: Your video card driver version number: 20.19.15.4531; Dedicated - 22.21.13.8494
chipkali Jul 26, 2017 @ 11:31am 
Hi, thanks for looking into this issue. I attempted your workaround. Windowed mode works fine, but I don't like it. :)
As for the vertical sync, it didn't do much.

Here's my specs:
1. Windoze 10, Ver. 1703, 64bit, Build 15063.483
2. KB4025342 & KB4025376
3. GeForce GTX 960M
4. 382.33
Sergio Aug 3, 2017 @ 8:32am 
Tried the proposed fixes, nothing worked. If I switch to windowed mode before closing, it doesn't freeze my computer and force me to manually power it off, which means it can be fixed within the game's programming. Please... do this.

1. Windows 10 64-bit
2. KB4025342 & KB4022725 (KB4025376 is just a Flash player update)
3. GeForce GTX 960M
4. 385.12 (upgraded from an earlier version that still had this issue)
TemmieNeko Aug 4, 2017 @ 4:12pm 
My pc just experienced this, rather jarring having to turn my pc off to get out of it.
windowed mode may be fine. but this isnt cool at all ><
TrianguloY Aug 23, 2017 @ 9:18am 
Just another answer confirming that none of the fixes work, only windowed mode (which is not the same as playing full screen)
1) Windows 10 64-bits
2) The crashes happened only AFTER installing the Windows 10, versión 1703 update (Creators Update) which I did just a few days ago due to an error with windows update (it stopped working and I didn't noticed until recently). After the 'big' update some minor ones were installed too (KB890830, KB4022405, KB4025376, KB4034662 and KB4034674)
3) NVIDIA GeForce GTX 950M
4) 385.28 (but happened with previous one too)
Cuz Sep 1, 2017 @ 9:27pm 
Alright so a friend helped me solve this issue

Go to windows settings > Gaming > Game Mode Tab and then turn off game mode
TrianguloY Sep 3, 2017 @ 11:00am 
I'm afraid disabling Game Mode didn't work for me (check my computer specs on post #6)
More specifically: With Windows Game Mode disabled, pressing ALT+TAB on the Lobby freezes the computer.
I would like to test more things, but I'm afraid of damaging the hard drive.
A Dummy Sep 11, 2017 @ 3:43pm 
Game still freezes my computer when I quit, even after disabling fullscreen optimizations.
Though it doesn't freeze like this when playing it in windowed mode, it's not as enjoyable to me since windowed mode has those borders around it. (Maybe add a borderless windowed mode?)

requested addititional info
1: Windows 10 Home
2: KB4034674 & KB4034662
3: NVIDIA GeForce GTX 965M
4: 385.41
lastea Sep 16, 2017 @ 8:37am 
Hi I'm korean, I can't English well so I'm not sure that I answered your Q
1. Windows 10 home
2.KB4038788 (I don't know. Is it right)
3.nvidia geforce GTX 950M
4.22.21.13.8205
Space Entropy Oct 14, 2017 @ 11:14am 
Hi, I recently purchased the game and it does exactly that, I hope you'll be able to fix this issue :)

1. Windows 10 Family build 15063.502
2. KB4041676 & KB4038788
3. NVIDIA GeForce GTX 1050 Ti
4. 387.92
NeviahofFlame Oct 14, 2017 @ 1:14pm 
1. Windows 10 Home 64-bit OS, x64-based processer
2. KB4041676, KB403788
3. NVIDIA GeForce GTX 850M
4. 22.21.13.8205
SamTheJester Oct 20, 2017 @ 4:11pm 
Did the things you suggested. NecroDancer still crashes my laptop :(
1. Windows 10 home 64bit
2. (KB4049179) (KB4041676)
3. Nvidia GeForce GTX 970m
4. driver version: 382.53
rubix Nov 3, 2017 @ 8:54am 
I have a laptop with w10 and a GTX 950M, and have disabled fullscreen optimization and v-sync in the nvidia panel, but couldn't find fast sync (either it wasn't there or i searched badly). And it worked! Thanks a lot for this fix.
pancakefulness Nov 3, 2017 @ 8:22pm 
Thanks! It worked when I went into the game settings and turned fullscreen off.
< >
Showing 1-15 of 24 comments
Per page: 15 30 50