Trials Fusion

Trials Fusion

View Stats:
DCCentR Oct 2, 2015 @ 12:22pm
Crash on startup [Fixed]
I get a crash on startup. Can't play After this screen:
http://steamcommunity.com/sharedfiles/filedetails/?id=528480865
Windows 10 x64 (with latest updates) / HD7970 (Catalyst 15.8 Beta) / I5-2500K / G35 (LGS 8.70.315)

Dumps & config:
{LINK REMOVED}
DxDiag:
{LINK REMOVED}

Fix (for AMD videocards only):
Devs & AMD team, please fix this issue!

UPDATE:
Fixed in AMD Radeon Software Crimson Edition (Display Driver version 15.30.1025) from 11/24/2015
http://support.amd.com/en-us/download/desktop?os=Windows+10+-+64
Last edited by DCCentR; Nov 24, 2015 @ 7:27am
< >
Showing 1-15 of 44 comments
FredFlint Oct 2, 2015 @ 12:44pm 
I have the same problem win10 x64 FuryX 15.8 beta
Last edited by FredFlint; Oct 2, 2015 @ 12:54pm
same problem. win10 x64, R9 270X Catalyst15.9.1
FredFlint Oct 2, 2015 @ 1:44pm 
Looks like its not going to work for me so will try and get a refund
Jowwdown Oct 2, 2015 @ 2:06pm 
I get constant crashing!

Windows 10
i5-3570k @ 3.4Ghz
XFX R9 280X
8GB Ram
djdreadful Oct 2, 2015 @ 2:08pm 
I have the same problem r9290 win 10 x64 15.8 beta
Stevanobalabala Oct 2, 2015 @ 2:42pm 
Same here, this is a joke!

seems like this is a common issue so have requested a refund. Your loss Ubisoft for not making a game properly!

390X 4770K win 10 x64 15.8 beta
Last edited by Stevanobalabala; Oct 2, 2015 @ 2:51pm
Moonlight Oct 2, 2015 @ 3:19pm 
Ребята, такая же проблема. Сегодня купил игру, думал поиграть..
Вин 10 х64, тоже вылетает после экрана загрузки...
PooTiRooSki Oct 2, 2015 @ 3:32pm 
Same dam @*$# here!!! This happend to me 1st with rogue right after I updated to win 10. I got all the DLC today with the sale and go to play some Trials and BAM! NOPE.. I thought I checked all other Ubisoft games after rogue took a dump but guess I missed this one.

2 R9 295x, i7 4790k, win 10 x64, 15.8 beta, 16GB Ram

I put in a ticket for rogue and they said it was not made for windows 10 as per system requirements. Well the other 100s of games on my pc weren't either but they work.

We pined the problem to a Windows Service. What one, IDK. When I disable all services Rogue works but thats all that does work. I dont have the time to go though the service list one by one and I am not that savy on PC. I'm just a gamer.


Fix fixed it
Thank you
Last edited by PooTiRooSki; Oct 5, 2015 @ 5:46pm
FredFlint Oct 2, 2015 @ 3:59pm 
I got this for 2 pc:

pc 1:
Win10 x64 home, 4790,ASUS Z97 Pro, Saphire Vapor X R9 290X 8GB, 16GB RAM = Game works.

driver = 15.20.1062.1004-150803a1-187674C
think this is the one windows installs after the win 10 upgrade.

pc 2:
Win10 x64 Pro, 5930K, ASUS X99 D, MSI FuryX, 32GB RAM = crash on startup.

driver = 15.8 beta
Last edited by FredFlint; Oct 3, 2015 @ 3:27am
Awesome. Everyone has AMD with 15.8 or newer beta drivers. Has anyone tried to roll back their drivers and install Catalyst 15.7.1?
Also we should try to ask AMD too.
Last edited by that's what she said; Oct 3, 2015 @ 3:00am
DCCentR Oct 3, 2015 @ 3:18am 
I will try with dll's from old drivers (when i come home). You can find these dll's here: http://forums.guru3d.com/showthread.php?t=399547
Originally posted by DCCentR:
I will try with dll's from old drivers (when i come home). You can find these dll's here: http://forums.guru3d.com/showthread.php?t=399547

DX11 - 15.7.1 works for both Fusion and Evo. Thanks. This is very convenient.
DCCentR Oct 3, 2015 @ 8:19am 
First post updated with fix
EnTwinedEnVision Oct 3, 2015 @ 9:47pm 
Thx! ^_^ When I tried the demo & it crashed I thought "oh well, can't have that then" but I added the dll's files to the directory of the demo & it worked so I then bought it knowing it were a simple fix.
In a meantime don't forget to report this issue to AMD so they could fix it in next driver version. Or maybe Trials devs will see this and report it by themselves which would be much more effective.
Last edited by that's what she said; Oct 3, 2015 @ 11:43pm
< >
Showing 1-15 of 44 comments
Per page: 15 30 50