The Chaos Engine

The Chaos Engine

View Stats:
Bugs ruined this game (Still not fixed -- Jun 2016)
This thread will contain all the known bugs for The Chaos Engine that are yet to be fixed.

Primarily there are audio and timing issues that affect both minor and important things in the game.

These are 100% repeatable issues, and not just based on a certain configuration.

Edit: None of these bugs have been fixed and it looks like they never will be :(
Last edited by ThunderPeel2001; Jan 14 @ 3:16pm
< >
Showing 1-15 of 78 comments
ThunderPeel2001 Nov 9, 2013 @ 2:33am 

PLEASE FIX ASAP: Due to a timing issue, this version is much more difficult/much less fun than the original. The carefully balanced gameplay is now different, as a direct result, it's just nowhere near as much fun to play :( In fact, it's no fun at all.

What's amazing is that it's only a small change. The character animation timings are slightly off, but it has disastrous results for the game. The player now walks into monsters more frequently than they should, making the game actually ANNOYING to play. (This is why nearly all the reviews of this port complained that it was no fun to play any more.)

This is probably the most important problem needing to be fixed, and probably relies on a core change to how the main code is being executed to ensure it's fixed properly.

It's astonishing that a games company that was given complete access to the original source code, still messed this up.
Last edited by ThunderPeel2001; Aug 10, 2014 @ 7:37am
ThunderPeel2001 Nov 9, 2013 @ 2:33am 
Missing music

Less important than the above fix, but if you're going to do a complete "restoration" of the original game, you should at least make sure the music plays properly. Here is the video showing the missing music at the end of each level that people have been complaining about (apparently the programmers didn't know what was being referred to):
Last edited by ThunderPeel2001; Sep 5, 2014 @ 6:48am
ThunderPeel2001 Nov 9, 2013 @ 2:33am 
The ending sequence is incomplete

In the original version, the rescued Baron says to you:

"I have guided you here so that you might set me free. The chaos has ended. You will be remembered..."


In the 2013 version he simply states:

"I have guided you here so that you might set me free."

Last edited by ThunderPeel2001; Sep 5, 2014 @ 6:49am
ThunderPeel2001 Nov 9, 2013 @ 2:34am 
Sound Issues

Frequently sound effects are not played properly or drop out.

Video pending.
Last edited by ThunderPeel2001; Sep 5, 2014 @ 6:49am
ThunderPeel2001 Nov 9, 2013 @ 2:38am 
More sound issues: Audio Glitches

Here's a video demonstrating the differences in SFX that people have been complaining about:
Last edited by ThunderPeel2001; Sep 5, 2014 @ 6:50am
WiZZyWiGG Nov 11, 2013 @ 5:25am 
These are currently being looked at, it seems they are particularly annoying bugs to fix. :(
ThunderPeel2001 Nov 11, 2013 @ 8:34am 
Thanks. Most issues appear to be timing related. I still maintain that some characters (e.g. Gentleman) don't stay in the same place while they're firing as long as they should, either. That means you end up walking into Monsters more frequently than in the original -- which makes the game less fun, and more difficult to play (and probably explains some of the poor reviews this game has gotten :( ).

Fix the timing issues, thus making the game more fun = better reviews, more sales!
Last edited by ThunderPeel2001; Nov 11, 2013 @ 8:35am
WiZZyWiGG Nov 13, 2013 @ 2:37am 
Yeah we know there are a few annoying things to be fixed, and they are being looked at. It just seems like some of these are the hardest to get sorted.

This is a very helpful thread though to keep track of them, so thankyou!
Last edited by WiZZyWiGG; Nov 27, 2013 @ 7:14am
Teho Nov 16, 2013 @ 2:58am 
Aww, the Party Power exploit in level 1-4 doesn't work anymore. Was that fixed in the original AGA version too? I only played the ECS version.

To explain, in level 1-4 there's a party power pickup that grants full guns and speed to both players for five seconds. A little before you get to it there's an entrance in a forest wall that teleports you to a small treasure room. Walk past it, get the party power pickup and run back and enter the room before the five seconds is up. Not hard, should make it there in four. The party power is now active for the rest of the game. Totally worked in the original ECS version.
Last edited by Teho; Nov 16, 2013 @ 3:08am
ThunderPeel2001 Nov 16, 2013 @ 4:41am 
Teho: Yes, that was fixed in the AGA version.
Teho Nov 16, 2013 @ 8:00am 
The one bug I'd rather have kept. Oh well.
ThunderPeel2001 Nov 16, 2013 @ 8:50am 
I know! I loved that trick too :)
Aulbath Nov 23, 2013 @ 4:37am 
Regarding the ending, it looks like the entire speaking-animation plays during that one line of dialogue - which is a pity, considering there was some nice looking lip-syncing going on as the video demonstrates.

I am not sure wether it is a bug or not, but I am not getting the "maxed out"-achievements for characters or the "destroyed the Chaos Engine" achievement (finished the game in Singleplayer with CPU). Do passwords lock achievements? Or are these things only obtainable in proper Multiplayer with a human player?
ThunderPeel2001 Nov 24, 2013 @ 5:34am 
Aulbath -- Yes, I think passwords prevent you from getting those achievements. You have to finish the game in one play through (or use the "Continue" option).
ThunderPeel2001 Nov 24, 2013 @ 1:13pm 
It's getting pretty difficult to believe that any bug could take several months to fix.
< >
Showing 1-15 of 78 comments
Per page: 15 30 50