Train Simulator

Train Simulator

View Stats:
This topic has been locked
DTG_Jay Sep 22, 2015 @ 10:50am
Train Simulator 2016: We are working on fixes
Hello everyone,

Firstly, we would like to thank our community for the enthusiasm you have shown these past six weeks as we revealed and released Train Simulator 16. We are extremely grateful for all the support, help and feedback you have showered upon us across all our channels.

Secondly, we are very pleased to announce that - despite some initial technical problems – the launch of the latest iteration of Train Simulator has been a success and that thousands of you enjoyed the game over the weekend.

However, we are aware that a number of technical issues remain, and thanks to all the community feedback we have collected over the past few days we were able to prioritise the issues affecting the most people.

We are targeting a minor update to the UI shortly which will ensure that both TS2016 and upgraded user experiences match in terms of functionality, as well as to address the issue of being unable to publish content to Workshop.

In the mean time we are working to resolve localisation issues reported for the Köln to Koblenz route.

Once this first batch has been taken care of our QA and development teams will do some further testing as well as look into other issues reported by our community to insure that TS16 meets our community’s expectations. If you come across a bug not listed above, please use the template provided below to report your bug in this thread.

Thank you for your support and understanding,

The Dovetail Games Team

Bug Report Template:

• Location of bug: menu/core game/scenario etc.
• Short description of the issue
• Steps to reproduce
• Notes (optional)
• Screenshots/videos (optional)
Last edited by DTG_Jay; Sep 23, 2015 @ 2:06am
< >
Showing 1-15 of 515 comments
Naviss Sep 22, 2015 @ 11:02am 
• Sound Bug with the Gtel
• Location of bug: Any scenario / Game mode.
• Short description of the issue: Turbine sound cuts out after you reach the connected rolling stock.
• Load any quick drive / free roam gameplay with the Gtel Turbine - couple to any rolling stock, Make sure turbine is running and go to Camera "2 or 8", And zoom out to where the rolling stock couples to the tender, And you'll see the Turbine sound instantly cuts out.
Unhook from any rolling stock and you'll correctly hear the Turbine running as normal and fade in distance.

Thanks for the upcoming fixes!
Last edited by Naviss; Sep 22, 2015 @ 11:03am
bored222 Sep 22, 2015 @ 11:06am 
Bug Report Template:

• TS2016 - DLC Big Boy
• Big Boy has no sound
• Use Big Boy in a scenario
pavig Sep 22, 2015 @ 11:32am 
• Post scenario summary screen
• Invisible bar showing score/XP
• Do a scenario, score points. At the post scenario screen there is a "progress bar" style widget next to the points display. The bar will seem to fill, and the bronze, silver and gold stars will bounce, but no blue bar is visible.
• Points and stars seem to be awarded for scenarios so this seems to be a purely visual bug.
http://www.evernote.com/shard/s2/sh/58ed8e53-fabd-40f7-a1c6-8ede7763336c/bb4b5141e209b3a61d6db9e626dc4921
jamie.dunn08 Sep 22, 2015 @ 11:33am 
Location of bug: On the Granges' footplate.

• The reverser's locking handle is not attached to the reverser. When you turn around it appears to be floating above the tender.

• I believe its on every grange scenario I first found it on the fish to kingswear freight run.


Location of bug: Rivera in the 50s route. (exeter st davids engine shed and newton abbots shed)

• The floor under / behind the turntable (exeter shed) and the floor under/ around the ashpit under the coaling stage (Newton abbot's shed) the lofts seem to be missing.

• I've only been on scenrios and a self made freeroam scenario and so far they have not apeared, they may be other points on the route aswell but these are the only ones i have noticed.


other then them slight issues i'm in love the route and the included stock :) please keep up the good work, just awaiting the K1 from VW.
Ghost Sep 22, 2015 @ 12:13pm 
Location of bug : Core game

Short description of the issue : FPS remains at 5-10 in most of the routes.

Steps to reproduce : Please make sure that the game uses all the Cores/threads of the CPU. Since the game uses only one core of the CPU, game runs in unplayable condition in most of the routes. (Most of the lastest games including Mortal kombat X/ Grand theft auto V are work fine (minimum 30, average 45 FPS) in my machine.

Thanks
rwaday Sep 22, 2015 @ 1:08pm 
I see that you have over 100 hours have you followed previous posts regarding changing your in game settings? AA to FXAA+8XMSAA
Robbedem Sep 22, 2015 @ 1:25pm 
Location:
scenario: Freight to Andernach
500Hz (at least it should be a 500Hz) magnet at catenary pole 31 0 about 1,2km before Bonn Hbf platform 3, second track from the left when facing the bridge (with the station behind the bridge). The light it should correspond to is the second from the left (there are about 7 lights just before the bridge).

Short description:
When passing this magnet when the light is red, the train will apply emergency brakes, even when going below 50km/h speed (allowed speed for PZB setting M) It even applied emergency brakes when going below 35km/h.

Steps to reproduce:
Do the scenario and make sure you are fast, but you don't have to brake any speed limits or other limitations. If you are to slow, the red light will have turned to a 60km/h limited speed.

Notes:
Maybe it's a wrongly placed 2000Hz magnet instead of a 500Hz magnet?
Last edited by Robbedem; Sep 22, 2015 @ 1:28pm
Robbedem Sep 22, 2015 @ 1:37pm 
Location:
scenario: Freight to Andernach
100km/h stretch after passing Bonn Hbf station.

Short Description:
If you are well on time, you should have a train in front of you causing double yellow warning signs. On this stretch of track I encountered a double yellow so I slowed down to 70km/h (PZB setting M) and passed a green block light (because the red signal shifted forward as the train in front of me moved forward). This green block light should have disengaged the 1000Hz warning but it didn't.

Steps to reproduce:
Do the scenario and make sure you are fast, but you don't have to brake any speed limits or other limitations

Notes:
Maybe one of the lights is in a wrong place? (normally block signals should not be less than 1000m apart and 1000Hz should disengage after 700m) not really sure what exactly happened, but AFAIK the train should not have applied emergency brakes.
SamWolf Sep 22, 2015 @ 1:41pm 
• Drive Menu, Standard Scenarios
• When selecting the Fort Kent Route, scenario list does not appear.
• Select Standard Scenarios, Select Fort Kent from Route Menu

Last edited by SamWolf; Sep 22, 2015 @ 1:41pm
Robbedem Sep 22, 2015 @ 1:43pm 
Location:
Cologne - Koblenz route

Short Description:
After the change to the AFB cruise control (5km/h steps instead of 10km/h steps), the train doesn't seem to brake hard enough anymore to keep the speed limit on a downhill piece of track. I noticed that about 2km/h above the set speed limit the train practicly doesn't brake at all...

I encounterd this in a BR 146.2, but I suspect it's a general problem after the AFB updarte.
Raildroid Sep 22, 2015 @ 1:46pm 
I had train simulator 2015 and since I got the update to 2016 a few days ago, all that I got was the new intro and the new menu sounds, but nothing else came with the update.
-Not even the new routes and content (including the gas turbine and the riviera line)
Thats the only bug I have.
Last edited by Raildroid; Sep 22, 2015 @ 1:47pm
IceFire Sep 22, 2015 @ 1:49pm 
Originally posted by Trainfan96:
I had train simulator 2015 and since I got the update to 2016 a few days ago, all that I got was the new intro and the new menu sounds, but nothing else came with the update.
-Not even the new routes and content (including the gas turbine and the riviera line)
Thats the only bug I have.

Did you buy the 2016 version or the free upgrade ? You have to buy 2016 to get the content your asking about.
rwaday Sep 22, 2015 @ 1:49pm 
You will not get the new content until you purchase the TS2016 Steam Edition.
Raildroid Sep 22, 2015 @ 1:51pm 
How do you do that when steam tells you "you already own this"?
rwaday Sep 22, 2015 @ 1:53pm 
Go ahead and purchase. This is the normal response. If you have any of the content in the package you will get a warning that you will not get duplicates of this content, again this is a normal response. Let the content download and install when done reboot your computer. If you have any issues verify your files. If you have not backed up your files please do so before starting the purchase process. You will have some issues with the new content but DTG is aware and are working on patches. Watch the forums for updates. If asked please register your copy to qualify for freebies.
< >
Showing 1-15 of 515 comments
Per page: 15 30 50

Date Posted: Sep 22, 2015 @ 10:50am
Posts: 515