Train Simulator

Train Simulator

View Stats:
Error 0xc000007b - FIX

Microsoft XNA Framework Redistributable 4.0 was broken, you need to reinstall it.

https://www.microsoft.com/en-gb/download/confirmation.aspx?id=20914

During this registration of a .dll might fail (mine did) which is one of the reasons for the game crash.

HOW TO FIX - Go to: C:\Windows\SysWOW64
- Delete "msvcr100.dll
- Re-install xnaredist
- Have fun :)
Last edited by Secret_Godfather; May 6, 2018 @ 1:58am
< >
Showing 16-24 of 24 comments
Phase3 May 5, 2018 @ 5:36pm 
OP
This sounds like a windows issue possibly to do with .NET framework
Where is the OS installed?
Where is TS installed?
Have you set AV, FireWall, Anti malware to exclude Steam and TS?
Does this happen in safe mode?
Have you triedd to run TS/Steam after a clean boot? Google
Have you installed all .NET framworlk versions again if necessary
Tun Steam and TS as administrator
Did you perform a clean windows install or just the repair that does not change your files?
Have you run sfc /scannow?
Have you run chkdsk on the TS disk?
Is UAC set? (Google)
Answer these and we might have a chance at fixing the issue.
Last edited by Phase3; May 5, 2018 @ 5:38pm
trev123 May 5, 2018 @ 9:51pm 
Yes try this fix here, not just a Windows 10 issue but also Windows 7. https://www.drivereasy.com/knowledge/how-to-fix-the-application-is-unable-to-start-correctly-0xc00007b-error/
Secret_Godfather May 6, 2018 @ 1:18am 
Originally posted by JJTimothy:
I have TS installed on three Windows 10 machines with no problems... well not that I can blame on Windows anyway. I realize that's no actual help but it's more info'.

Has TS ever worked on your system?

If you tried reinstalling TS did you completely remove the Railworks folder?

I haven't had to do any fiddling to get it to work but have you tried the backwards compatibility settings? They don't seem to be available on my system but that may be because it's running Windows 7.

Sorry I can't be much help but I suggest you add your system's specifications to your OP or somewhere in this thread- you can get a complete list of spec's in Steam from the Help menu then copy and paste. It'll save time when someone who can help reads this.

Yeah, i had it installed on the same pc back with windows 7 with no problems

Computer Information:
Manufacturer: OEGStone
Model: DH55TC
Form Factor: Desktop
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
CPU Family: 0x6
CPU Model: 0x25
CPU Stepping: 0x5
CPU Type: 0x0
Speed: 3192 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 750 Ti
DirectX Driver Name: nvldumd.dll
Driver Version: 24.21.13.9731
DirectX Driver Version: 24.21.13.9731
Driver Date: 4 22 2018
OpenGL Version: 4.6
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: NVIDIA GeForce GTX 750 Ti
VendorID: 0x10de
DeviceID: 0x1380
Revision: 0xa2
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 45.28" x 25.59" (51.97" diag)
115.0cm x 65.0cm (132.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2047 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: HISENSE (NVIDIA High Definition

Memory:
RAM: 8053 Mb

Miscellaneous:
UI Language: English
Media Type: Undetermined
Total Hard Disk Space Available: 2384120 Mb
Largest Free Hard Disk Block: 952191 Mb
OS Install Date: Jan 01 1970
Game Controller: XInput Controller #1 detected
VR Headset: None detected

Secret_Godfather May 6, 2018 @ 1:54am 
Fixed
dgre1950 May 6, 2018 @ 1:56am 
and Thanks guys......nudge
Last edited by dgre1950; May 6, 2018 @ 2:29am
IC125 May 6, 2018 @ 1:57am 
Could you also tell us how you fixed it, so that others with this problem know a solution? Thanks.
Secret_Godfather May 6, 2018 @ 1:59am 
Originally posted by IC125:
Could you also tell us how you fixed it, so that others with this problem know a solution? Thanks.

updated :)
trev123 May 6, 2018 @ 2:02am 
Updated what ?
Secret_Godfather May 6, 2018 @ 2:03am 
Originally posted by trev123:
Updated what ?

Updated the forum title and description to the fix
< >
Showing 16-24 of 24 comments
Per page: 15 30 50

Date Posted: May 5, 2018 @ 2:26pm
Posts: 24