Amnesia: A Machine for Pigs

Amnesia: A Machine for Pigs

Näytä tilastot:
Can't create profile (game unplayable)
Every time I start the game I get to the screen where you create a profile to continue. I type in a name and click "create" and nothing happens.

So every time I try to play the game I have 3 options.

1. Select Profile (no profiles to select)
2. Create Profile (isn't working)
3. Delete Profile (no profiles to delete)

It's like I'm trapped in some ♥♥♥♥ed up catch 22. When I go to exit it freezes and tells me "aamfp.exe has stopped working". Also the setup utility doesn't recognize my graphics card which is an EVGA Nvidia GTX Titan Hydro Copper Signature Edition. I've also tried uninstalling, and re-downloading this game to no effect.

Any help would be appreciated as I can't play this game without some resolution to this issue.

Side question, would it be possible for someone to create their own new profile, find the file in their game directory, upload it to gdrive or something, and link to it here for me to place in my game directory (thus skipping the create profile function that isn't working for me)?
< >
Näytetään 1-12 / 12 kommentista
McQuiggle 23.12.2013 kello 14.03 
Haven't heard of this issue before. Gotta ask the obvious, have you tried going into the game's properties on steam and verifying its integrity? Maybe the download corrupted or didn't finish.
I don't think that it has anything to do with corrupted files, or unfinished downloads because I've deleted all the local content associated with this game and re-downloaded it several times.

Each time the game keeps doing the same crap.

I'm getting pretty frustrated here because this isn't the first unplayable steam game I've wasted money on. I switched from piracy to steam so I wouldn't have to deal with crap like this.

What's the point of even paying for a game you can't play and that comes with ZERO support? I could have pirated it for free and probably ended up with a better experience. At the very least it couldn't have been a worse experience.
Since I just redownloaded the game to replay, I'm getting this problem. It wasn't a problem I had before and I've already completed the game, but apparently Steam Cloud settings forgot about my saves. As it stands it's completely unplayable for exactly the same reasons.

I actually figured out how to fix this a few months ago. So what was happening is that my saved games folder was corrupt. I believe it was under

My Documents > Amnesia

However it was a while back so you may need to double check and find out where your saved game folder is. Anyways, once you find your corrupted saved game folder just delete it and recreate another folder of the same name in the same place that's empty. Restart your game and it should be able to now save in that folder and allow you to create a profile.

Also I was having major problems with many other games for the exact same reason, and while I was in there I noticed several other saved game folders that were corrupted. Which I fixed by doing the same thing.

Lastly, check under

C (or whatever drive your steam files are saved to) > Program Files > Steam > User Data > Your USER ID #

There you will see a large list of folders that are all numbered. Each numbered folder corresponds to a Steam Game ID#. If the folder for a game there is corrupted it will stop the game from working. To fix just do what you did before and delete the corrupted folder and create a new empty folder of the same name in it's place.

Hope this helps.

Thank you kindly! I'd deleted the save game folder when I uninstalled the game because I figured I wouldn't be using it. It's a wonder the game doesn't figure to create the folder itself, especially when we consider that after I manually created the folder it placed my cloud saves back into it.

But oh well. Thanks again, can actually play the game now. Cheers!
Viimeisin muokkaaja on Fairy Nuff.; 19.11.2014 kello 18.31
Hamakei 22.6.2014 kello 13.20 
I have this exact same problem on the Linux build, but this is my very first time loading so I don't have anything in the save folder :|
Dont know much about linux, but my only suggestion is that maybe the saved games folder isnt letting the game write to it for some reason.

So use your troubleshooting abilities to figure out if there is any reason the game might not be able to write to that folder and try to fix it.

Sorry I couldn't help more, but again linux isn't my thing.
Hamakei 22.6.2014 kello 13.44 
Huh. Turns out you were right. The Linux build saves profiles into ~/.frictionalgames/ which for some reason was read-only. Changing this to r/w let me create a profile and it seems to be working now...

Thank you!
Glad to hear. Enjoy your fully functional walking simulator. lol.

Just sayin compared to the first game which creeped me out too bad to finish, this game is mild and lame.
Hamakei 22.6.2014 kello 14.02 
Eh. I'll give it a go. I liked Dear Esther so I'd be interested to see what they do with a different genre...
< >
Näytetään 1-12 / 12 kommentista
Sivua kohden: 15 30 50

Lähetetty: 8.12.2013 kello 18.25
Viestejä: 12