Thief
Thief > Technical discussions & bug reports > Подробности темы
!!! Working Stutter Fix - now 60 fps and no stuttering !!!
well i posted about an hour ago and tried everything, but nothing really helped.

now i can play with 60 fps in the first room and on the line out of the window with all settings maxed (Textures High, SSAA High, Shadows High, FXAA, ...) on my DX 10 Card.

before this i had so much stutter and low fps i couldn't even play in very low settings.

here's what i did (thanks to other people who posted in this forum, i just had to combine some posts to get to my goal):

1) make backup copies of win64 and win32 folders in the game's binaries folder, then delete win64 folder, then rename win32 to win64 (thx to katzeapfel!)

2) before starting the game set all settings to max and Textures to very low

3) start the game and load up your recent game

4) then set textures to low, normal or high in game (don't load the game with textures on normal or high or you will get stuttering)

5) return to game and give it a few seconds to load the higher textures in vram, then you get constant 60 fps again.

enjoy.

if using vsync:

1) enable vsync in the nvidia control panel 3d settings, turn it ON

2) in-game, turn vsync OFF (not double, not triple, OFF)

you will still have vsync but smoother framerates.


worked for me with a STEADY 60 fps in-game (Fraps) with HIGH Textures and all Graphics Settings maxed out with 1280x720 FXAA on:

phenom x4 9950 @ 3.1
2 x gtx 260-216 BE @ 666 SLI (896 MB VRAM)
4 GB DDR-2 800
vista x64

and forget about the benchmark, it has nothing to do with the ingame fps once you follow my instructions.

and here's how i think this works:

- 32bit version uses less ram so the game reserves less ram and does not swap memory to your harddrive all the time and in and out of the vram.

- starting the game with very low textures also makes the game RESERVE less vram and keeps that value when you set higher textures in-game. of course the game will have to load the higher textures MORE OFTEN into your reserved vram than when you play with lower textures (micro stutters from time to time). but hey, you got high textures and constant 60 fps without stuttering every second.

if you start the game with normal or high textures, the game will reserve more vram (more than your card can handle) and swap it all the time to your harddisk.

this explains the stuttering and this is why the workaround works.

Fraps Result:
Frames, Time (ms), Min, Max, Avg
301, 5000, 59, 61, 60.200

on my rig i get fps decrease when i use very high textures, but a constant 60 fps with high textures.

texture quality compared (look on the carpet in the first room at the beginning of the game while you change the texture quality in the ingame settings):

very low: washed out textures
low: a lot more detailed and not washed out anymore, playable
normal: even finer (would have this compared to high textures in older games)
high: no difference to normal in 1280x720
very high: no difference to normal in 1280x720
Последний раз отредактировано x-ray; 1 мар. 2014 в 15:38
< >
Сообщения 18 из 8
This worked for me!! Thanks to all envolved. I think deleting and renaming the folders in binaries did the trick!
Not working for me at all.
I didn't understand this line: 4) then set textures to low, normal or high in game (don't load the game with textures on normal or high or you will get stuttering)

I must set to low once, medium once. high once more inside the game or from launcher and load for every once??
Set low, normal or high in game,, and you said don't load the game but how to set high and low in game without loading the save game ??
Последний раз отредактировано Ali-S; 9 мар. 2014 в 20:17
ok ;) what i meant is: start the game from steam, then you get the desktop setup menu, change the texture resolution to very low in there, then start the game from the menu.
next load your game from the game menu, and when you are in the game go to graphic settings and change the texture resolution to low or normal or high, corresponding to your hardware. for me i can play with low textures in the city and high textures in houses and smaller levels.
You just need extra ram, this game is unplayable with 4go thats all.
Автор сообщения: GrOCam
You just need extra ram, this game is unplayable with 4go thats all.

Автор сообщения: x-ray
I guess u are right

That's not true. 4GB was fine on my (Migz-DH... you can see how I've been offline for ages now...stupid ASUS breaking my motherboard...<sigh>) system before I took it apart three weeks ago.

VRAM is much more important... especially when discussing GTX 260s.
Последний раз отредактировано Charais; 17 мар. 2014 в 10:20
vram is not swapped to the hard-drive, and the 32-bit version shouldn't require any more vram
< >
Сообщения 18 из 8
Показывать на странице: 15 30 50

Thief > Technical discussions & bug reports > Подробности темы