Ver estatísticas:
Thief > Discussões Gerais > Detalhes do tópico
shankly1985 6 Abr, 2014 às 5:06
TrueAudio Missing?
Been playing with TrueAudio since it was added to the game. First time to day I have played since latest patch and now TrueAudio is missing? No option to select it.

Anyone else
< >
A mostrar 1-13 de 13 comentários
You must have a Kavari APU, or one of 4 GPUS, r8 260(x) or r9 290(x)
shankly1985 6 Abr, 2014 às 18:31 
Originalmente postado por -=Cloud Windfoot Omega=-:
You must have a Kavari APU, or one of 4 GPUS, r8 260(x) or r9 290(x)

Its ok I fixed it. Re-installed 14.3 driver again and it picked it up. My system is Crossfire 290's True Audio was working before patch.
I'm having this problem, too. I just recently got an R9 290x GPU and tried out TrueAudio a few days ago. I tried it again last night and checked the audio options (Convolution Reverb), and TrueAudio was missing from the options. Everything else is running perfectly. I'm using Catalyst 14.4 (latest drivers to date) and all other drivers are updated. Thief is up to date, as well. I already used Steam's "Verify Integrity of Game Cache" check to make sure all the game's files were working. I also reinstalled Catalyst 14.4 to see if shakly1985's fix would work, but TrueAudio is still absent from Convolution Reverb options.
I can see in Thief's log file that it's not detecting TrueAudio for some reason, as noted in this log: [audio] TrueAudio unavailable ... and then: [audio] Convolution Reverb Option = SOFTWARE
I'm wondering if there's some way I can force the game to use TrueAudio for convolution reverb, but I can't find any controls for it in the config files.
I've contacted Square Enix support, but I don't expect to get much help out of them aside from the canned response I've already received. This might be a difficult issue to resolve, since Thief is the only game at the moment with TrueAudio support, and the R9 GPUs (maybe only the 290/290x?) are the only GPUs with TrueAudio capability, so the number of people with this problem may be few.
It's just weird that TrueAudio was working, and then just a day or so later, it's not... I've restarted my computer a few times since I first tried it, so at first I thought maybe that part of the driver/GPU wasn't initializing. I still think maybe it's a driver issue. It's impossible to test it in other games, since Thief is the only game at this point with TrueAudio, aside from the Tuscany demo.
I'm going to try deleting my profile (hopefully just game settings and not progression; I'll make backups first) to see if it might re-detect it. I'll also see if it detects TrueAudio in DirectX mode, as opposed to Mantle, although I'd rather use Mantle, because I think I'm getting better framerate.
Última alteração por The Sensitive Naked Man; 9 Mai, 2014 às 12:15
Ok, I just completely uninstalled (Catalyst uninstall manager, driver sweeper, DDU) my GPU driver, then reinstalled. Just tested Thief and TrueAudio is available now. I didn't install the AMD HDMI Audio Driver this time (don't use it anyway), so now I know that it isn't necessary for TrueAudio to work. I guess the card loops TrueAudio info back through the mobo to any other sound devices being used. Anyway, if anyone else gets caught with this problem, the fix is a *complete* uninstall/reinstall of your Catalyst drivers (although I completely uninstalled everything AMD-related; you might be able to get away with uninstalling just your graphics driver instead of the Control Center and everything else along with it, but I just did everything). I don't know why it disappeared in the first place, or if it will disappear again. And I don't even know if it was worth it, because I'm not so sure I like TrueAudio. The convolution reverb sounds like a good idea in theory, but it just sounds weird to me in game. I even have the headphone preset turned on, since I use headphones with Thief, and have ever since the original Thief games, but that reverb just my ears.
Well, TrueAudio had been working, even after a few reboots, but Windows had a few updates today, and after restarting I just sat down to play, decided to check audio settings, TrueAudio option again... I don't feel like the whole uninstall/reinstall driver dance again, but I was starting to enjoy TrueAudio... I've given up trying to understand why it disappears from the audio settings.
KrashLog 31 Mai, 2014 às 8:34 
I'm having the same problem... TrueAudio was working all right when I first installed the game, but inbetween the latest AMD drivers and the latest Thief patch, it's no longer in the audio options.

Did you manage to find a fix?
Última alteração por KrashLog; 31 Mai, 2014 às 8:34
Unfortunately, no fix yet, although I went ahead and finished Thief last week anyway. I haven't played it since then, but I have installed the latest Catalyst 14.6 beta drivers, to help with Watch_Dogs performance (that's a whole other can of worms...).

I'm sure if I tried Thief right now, TrueAudio would be available, but the question is: for how long? I uninstalled/reinstalled the 14.4 drivers and got it to work, like I said, and then it stopped working, so..I don't know. The 14.6 beta drivers have improved Mantle support, but I don't think that has anything to do with TrueAudio.

I've only heard about the missing TrueAudio problem from a small handful of other people, so I don't know if it's a driver issue (which must have something to do with it, since uninstallation/reinstallation helps temorarily), or a weird hardware issue with a number of people's R9 cards that somehow causes the TrueAudio DSP chip to sort of stop functioning or 'disappear.'
KrashLog 31 Mai, 2014 às 12:33 
I see... oh well, I guess we'll have better support when more games use TrueAudio (if that ever happens) and they fix all the hardware / software bugs.

I tried the 14.6 Beta but had to revert to 14.4 WHQL because 14.6 was giving me black screens all the time during gaming (but thats another bug, unrelated to TrueAudio).

Sad to say this might be the last time I buy AMD.
I think Mantle is still kind of beta at this point, even though 14.4 was the official release. So far, only two games use it, and only one game (Thief) uses TrueAudio. Dragon Age 3, last time I checked, will use Mantle, and I think TrueAudio is also a possibility with that game. And I think the PS4 has a TrueAudio chip, as well, so there may be more games that support it in the future, even on PC. I'm not counting AMD out yet. I'm really happy with my current R9 290x, and I've had great results with the past 2 GPUs I've had from them. I know nVidia has deals with some studios involving their GameWorks program, plus they have PhysX dedicated on their boards, so that might be a reason to switch, but sometimes PhysX seems kind of gimmicky. The only thing I want out of GameWorks/any nVidia GPU is TXAA.

Which game was causing black screens for you on 14.6? Or was it just general usage? 14.6 is still beta, and I usually don't use beta drivers, because I've had problems with with them in the past, but I'm using it for Watch_Dogs. And yeah, I know the only real reason they're 'beta' is because they don't have WHQL certification yet. But, I did have some crashes with a beta driver and Dishonored a while back, so that's why I haven't used betas in a while.

I haven't had any problems with 14.6 thus far, but I haven't tried it with Thief. Actually I haven't tried 14.6 on any other game or benchmark. Even if 14.6 has problems with other games I have, I probably won't switch back for now, though, since 14.6 gives me a little more performance over 14.4 in WD.
KrashLog 31 Mai, 2014 às 16:31 
I understand the edgy/experimental nature of AMD's tech, but what I find disturbing is the lack of support to end users. Just google AMD "black screen" and you'll see thousands of people having issues with their R7/R9s. Yet, AMD isn't even acknowledging the problem! As for TrueAudio, it's almost scary : nobody ever mentions it anymore, and yours is the only thread I found reporting the problem. Dead tech already?

That being said, the 14.4 drivers were okay... but with 14.6 Beta, I can reproduce the problem systematically in Sleeping Dogs on Extreme settings -- just start a new game and get to the prison scene (about 9-10 minutes in) and... *boom*

It also happens in BF4 every time, but more randomly (sometimes after 15 minutes, sometimes an hour). Older games crash far less often, so it seems related to how much stress the GPU is under.

It's always the same: the display suddenly goes blank / black, the audio continues for a couple of seconds before stopping. The system is then locked up, and will only respond to a hard reset. Checking logs will reveal temps well under the limits. I've sent a detailed report to AMD, if I don't hear anything I might turn to XFX (my card's manufacturer) for help, but this issues happens on other brands, too.

Here are my specs:

GPU : XFX R9-290X-EDFD 4Gb (@ stock clocks)
Mobo : Gigabyte GA-Z77X-UD3H (F20e latest BIOS)
PSU : 660W Seasonic SS-660XP2 (80 Plus Platinum)
RAM : G.Skill Ripjaws Z Series 16GB (4 x 4GB) DDR3-1600
SSD : Samsung 830 SSD 240Gb
Audio : Creative X-Fi Titanium HD
Windows 8.1 64-bit

I'll update this thread if I find/hear something new.

Última alteração por KrashLog; 31 Mai, 2014 às 17:50
I had a problem with black screens and my PC locking up a while back, and it turned out to be a problem with my PSU (it was ~5 years old). Replacing the PSU with a Seasonic X 650w Gold Edition did the trick. But there was also a problem with my monitor, which died eventually, so I also replaced it, and haven't had any problems since. I did have intermittent graphical artifacting with my Gigabyte Radeon 7870 OC Edition for a while after that (I'd also experienced some occasional artifacting before changing my PSU) but I chalked that up to having my VRAM overclocked a little too much. I've not had any artifacting with this R9 290x yet, but I've kept it on stock clocks for core and VRAM (well, factory overclock).
diyuser 3 Set, 2014 às 14:04 
Hi wondering did you manage to find a solution I'm having the same problem as you there is no option for trueaudio.
shankly1985 13 Set, 2014 às 15:49 
Originalmente postado por diyuser:
Hi wondering did you manage to find a solution I'm having the same problem as you there is no option for trueaudio.

Yeah I just re-installed the drivers.
< >
A mostrar 1-13 de 13 comentários
Por página: 15 30 50

Thief > Discussões Gerais > Detalhes do tópico
Postado a: 6 Abr, 2014 às 5:06
Comentários: 13