View Stats:
Hammerwatch > General Discussions > Topic Details
***** Sep 1, 2013 @ 6:50am
[Solved?] No Steam achievements on 64-bit Linux
Hi, I play on Linux and launch it from Steam. I've slain the Queen and the Knight on medium level, no crutches. I've disovered both Gauntlet levels, now I'm in the library floor. I have lots of money etc.

And yet, I have absolutely no Steam awards.

Is this normal?

I bought it on the official page and then used the Steam key to get it here, can that be the reason?
Last edited by *****; Sep 2, 2013 @ 7:58am
< >
Showing 1-15 of 22 comments
Myran  [developer] Sep 2, 2013 @ 5:47am 
There is no 64-bit version of the steam sdk for linux, https://github.com/ValveSoftware/steam-for-linux/issues/2722
This means that we can only use steam features if you run it as 32 bit.
***** Sep 2, 2013 @ 7:12am 
Right, that's an x86-64 system.

So I need to install 32-bit mono and manually run with that?

Will it detect Steam running in the background, or should I edit RunHammerwatch script and start from Steam for it to work?
Myran  [developer] Sep 2, 2013 @ 7:37am 
You can either copy the steam_appid.txt from the editor folder and put in the game folder to make it detect steam running, or you can edit the script. A quick way of seeing that it works is that if you delete the config.xml it shouldn't ask for a username since it takes what you are using in Steam.
***** Sep 2, 2013 @ 7:59am 
Thanks, I'll be experimenting with this in the evening.

I've changed thread title so others notice it easier.
Der Erloeser Sep 7, 2013 @ 3:14am 
Are there any news here? I really want to play this game, but not with broken achievements. It is also not possible (at least with the standard repositories) to install mono x86 on Linux Mint 15 / Ubuntu 13. To make things worse I tried to copy the steam_appid.txt while using mono x64 and also tried to run it under wine and now I have a totally wrong progress in achievements like 'Rich'.
Der Erloeser Sep 9, 2013 @ 11:49pm 
Steam update news: "Linux: added support for 64-bit games to the Steam Linux Runtime"

Does this mean 64bit Linux users will get achievements as soon as you the steam_appid.txt is in the folder?
Last edited by Der Erloeser; Sep 10, 2013 @ 12:00am
Der Erloeser Sep 10, 2013 @ 11:30am 
game.log: Initialize achievments, Steam and master server
Failed to initialize Steam, using Null implementation
steev Nov 27, 2013 @ 10:08am 
The Steamworks SDK appears to support 64-Bit Linux now. Will there be an update?
The Steamworks SDK has been updated with new APIs for Family Sharing, 64-Bit Linux binaries and a new UGC interface to query Workshop items.
adolson Dec 2, 2013 @ 1:19am 
I picked this up a week or two ago and finally got it running on Arch a couple days ago. I put about 4 hours into it so far and love it - but just noticed now that there's no Achievements popping.

Just chiming in here in hopes for an update from Crackshell, now that it should be do-able.
spacepope Dec 2, 2013 @ 3:16am 
It would be much appreciated if you could either ship a 32-bit Mono runtime (the Ironclad Tactics dev does that) or 64-bit Steam libs with the game. The current situation is kind of dissatisfying for us 64-bit users...
Zuckerwatte o.O Dec 2, 2013 @ 3:41am 
Another game where the achievements have problems with Linux (x64)...
eigenroy Dec 8, 2013 @ 3:57pm 
Any updates?
David™ Dec 8, 2013 @ 5:26pm 
Does the Steam Overlay work for anyone else?
eigenroy Dec 8, 2013 @ 10:33pm 
Steam overlay works here (Ubuntu 12.04 + 13.10). Just no achievements.
David™ Dec 9, 2013 @ 2:30pm 
Originally posted by eigenroy:
Steam overlay works here (Ubuntu 12.04 + 13.10). Just no achievements.
What graphics card do you have and what drivers are you running?
< >
Showing 1-15 of 22 comments
Per page: 15 30 50

Hammerwatch > General Discussions > Topic Details
Date Posted: Sep 1, 2013 @ 6:50am
Posts: 22