Outlast

Outlast

View Stats:
Outlast > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
[Tutorial] Change FOV, Remove Blur, Uncap FPS, FIX Stuttering, Better Textures, Antialiasing, Grain Filter, Resolution, Battery Life
YOU CAN ALSO TAKE A LOOK AT THIS SIMILAR GUIDE:

http://steamcommunity.com/sharedfiles/filedetails/?id=176247453
Thanks for this Awesome Game :)
___________________________________________________________

First of All *Very Important*

1.Locate the folder which contains the files we are going to edit:
Documents > My Games > Outlast > OLGame > Config

2.Copy the contents of that folder into another one.

▶ PLEASE note that once you modify a file you have to tick the 'Read Only' box, to do this: Right click on the file, Properties, and tick the read only box.


How to Change the FOV

Open "OLGame.ini" with a text editor (such as Notepad++) and look for "DefaultFOV=" and "RunningFOV=", then change the values to whatever you want.

Please note that 110º in this game looks like 90º in others, like Call of duty.

Example:
DefaultFOV=110.0
RunningFOV=120.0


--------
↓↓IMPORTANT (CAMERA FOV)↓↓: When you look through your camera you have a different FOV. To change it you have to edit the following lines:

CamcorderNVMaxFOV=83.0
CamcorderMaxFOV=83.0

▶ ↓Just replace 83 with your normal fov, if your defaultfov is 110 then :↓

CamcorderNVMaxFOV=110.0
CamcorderMaxFOV=110.0




How to Change FPS limit (Uncap FPS)

IMPORTANT:
The following lines are repeated a few times in the file, so you MUST change it all to False and 0 in order to FULLY Unlock the Frames Per Second limit.

Open "OLEngine.ini" and look for these lines:
bSmoothFrameRate=TRUE
MinSmoothedFrameRate=22
MaxSmoothedFrameRate=62


▶ ↓If you want no FPS limit do this:↓
bSmoothFrameRate=FALSE
MinSmoothedFrameRate=0
MaxSmoothedFrameRate=0


(0 means UNLIMITED, you can change it to whatever you want)



Remove Motion Blur

PLEASE TICK THE 'READ ONLY' BOX IN THIS FILE!

I only recommend turning off Motion Blur if you run this game at 60fps or higher.

Open "OLSystemSettings.ini", change this:

MotionBlur=True
MotionBlurPause=True
MotionBlurSkinning=1
AllowRadialBlur=True
MaxFilterBlurSampleCount=16
MobilePostProcessBlurAmount=32.0

▶ ↓To this:↓

MotionBlur=FALSE
MotionBlurPause=FALSE
MotionBlurSkinning=0
AllowRadialBlur=FALSE
MaxFilterBlurSampleCount=8
MobilePostProcessBlurAmount=16.0


-------------------------

If the above method doesn't work for you, you can try this modded file made by LoneWolfDon (just replace the necessary files): https://www.dropbox.com/s/i0t6dhppi8mkio8/OLSystemSettings.zip

Thx to LONEWOLFDON



Better Textures Resolution


In "OLEngine.ini" look for these lines and change 1024 and 256 to the desired values:

MaxProcBuildingLODColorTextureSize=1024
MaxProcBuildingLODLightingTextureSize=256


▶ ↓Example:↓

MaxProcBuildingLODColorTextureSize=2048
MaxProcBuildingLODLightingTextureSize=1024




FIX Stuttering


2 Methods, (use both to have better results)

1. - Go to "OLEngine.ini", under "[TextureStreaming]" Edit "Poolsize=", and set it to 280 at least: (mine is at 1024 = 1 GB VRAM (I have 3GB)

Examples: (just test)
PoolSize=1024
PoolSize=280
PoolSize=560


Originally posted by Caiobrz:
(http://forums.steampowered.com/forums/showthread.php?t=1963500)
[TextureStreaming]
...
[...]As a matter of fact, increase it anyway. Suggested value: 560 on high-end GPU, 280 on others. Defragmenting your drive might also help with stuttering/small freezes.
..........................................................................................................


2. - In the same file (OLEngine.ini), look for "TimeBetweenPurgingPendingKillObjects=". Change the value to 3600.

▶ Like this: TimeBetweenPurgingPendingKillObjects=3600

Originally posted by MBgeek:
(http://forums.steampowered.com/forums/showpost.php?p=17496804&postcount=14)
[...]
TimeBetweenPurgingPendingKillObjects=10

I set it to 20 and now I got the stutter every 20 seconds...I then bumped it up to 3600 (1 hour) and haven't seen it since.

Who knows what will happen after an hour...lol

Hope that helps someone, it was making me nuts

MB Geek




Antialiasing (MSAA) [Working fine on my AMD GPU*]

------
*UPDATE*
Originally posted by SKINNIE:
The DLC broke the MSAA Antialiasing[/b] for me. Turns everything really dark to the point of being unplayable. Have to switch bAllowD3D9MSAA in the OLSystemSettings.ini back to False.
Su**s cause MSAA was working so well for me before I bought the DLC. :(

*UPDATE 2*
Originally posted by chillgreg:
[...]this setting causes strange (unplayable) lighting:
bAllowD3D9MSAA=True
Set back to FALSE, no problems
Originally posted by Eggahertz:
The culprit for this appears to be the setting
AllowSkin=TRUE
(located in OLSystemSettings.ini), which is enabled when effects are set to high/very high. Changing this setting to FALSE under the heading that corresponds to your effects setting ([SystemSettingsBucket4] for high and [SystemSettingsBucket5] for very high) eliminates the lighting problem, although the artifacts from before persist.

Please note that I don't know what the AllowSkin setting actually does (I couldn't tell the difference one way or the other), only that it doesn't play nice with MSAA.
--------
*Works good on AMD and NVIDIA (I think)

In "OLSystemSettings.ini", change this:

MaxMultiSamples=1
bAllowD3D9MSAA=False

▶ ↓To this:↓

MaxMultiSamples=2
bAllowD3D9MSAA=True



(In "MaxMultiSamples=" you can use 2, 4, or 8 I think)



[nVidia Users Only] Antialiasing (SGSSAA) (CalinTM)


Originally posted by CalinTM:

To use SGSSAA, you need a nvidia GPU and follow these steps from here:

This does require a powerful system!

- Download Nvidia Inspector
- Open up the program
- Open up the Profile settings ( Tool button on the right side of driver version )
- Open the Outlast profile ( if you havn't created it yet, look in the previous section )
- Paste 0x000010C1 in the "Antialiasing Combatibility" section
- Set "Antialiasing - Mode" to: Override any application setting
- Set "Antialiasing - Setting" to: 2x [2x Multisampling]
- Set "Antialiasing - Transparency Supersampling" to: 2x Sparse Grid Supersampling
- Set "Lod Bias" to: -0.500 for 2x
- -1.000 for 4x
- -1.500 for 8x

Note: you can set it to 4x or even 8x if your system is powerful enough, always be sure that the values in multisampling and supersampling match up.


Should look like this:
https://lh5.googleusercontent.com/-wXxQY5OF4Ic/UieZZ_OSnHI/AAAAAAAAAc4/305PasjIkFc/s919/AA.png


"Taken from my thread...

Also if you want to enable Physx on the GPU instead of CPU, modify this to False
bDisablePhysXHardwareSupport=False (found in OLEngine.ini)"


Also:

Originally posted by CalinTM:
You can downsample and disable AA, almost the same effect. My 120hz monitor can't downsample at 120hz...if you have a 60hz monitor you can downsample to 1440p.



Change Resolution


In "OLSystemSettings.ini", look for:
ResX=
ResY=

▶ ↓Change it to whatever you want (800x600, 1920x1080, etc)↓

For Example:

ResX=1920
ResY=1080


(If you see a black screen you can change "fullscreen=true" to "fullscreen=false" or change screen resolution to a lower one or check your drivers or and install/update directX...)



Change Battery Life


Note: Changing battery life is only recommended if you are stuck somewhere or you ran out of batteries :).

Go to "OlGame.ini" and change "BatteryDuration=150.0" to the desired value.
(The value is measured in seconds)

For example you can change the value to 300, so you have 300 seconds of battery life .



Modify Grain Filter

Note:*I think it does not remove the film grain at all*

Go to: C:\Program Files (x86)\Steam\SteamApps\common\Outlast\Engine\Config

Then open "ConsoleVariables.ini" and under "[Startups]" write:
"ImageGrain = 0.0" or the desired value.

▶ ↓So it looks like:↓

[Startup]
ImageGrain = 0.0


UPDATE:
It seems that is possible to remove the grain filter, but I think it removes the night vision effect (I haven't personally tried this):
http://steamcommunity.com/app/238320/discussions/0/540741131475598122/

___________________________________________________________

OTHER TWEAKS

Originally posted by mooner:
Set 'OneFrameThreadLag=False' in OLSystemSettings.ini for increased mouse responsiveness.

Originally posted by SoulesS:
Originally posted by ruk80:
Does anyone know how to disable messages like "press left click to open the door"? (I can't turn off in the subtitle menu) They distract and ruin the atmosphere!

Try this in OLGame.ini

[OLGame.OLHUD]
bAlwaysShowPrompts=false
____________________________________________

▶ Remember to backup all the files before edit them. Also tick the Read Only box in every modified file.

Note: If your game doesn't run then delete the .ini files and start the game again. As a result the game will create new and fresh files :)
____________________________________________


THANKS :)
Last edited by illescasDaniel; Nov 18, 2017 @ 11:02am
< >
Showing 1-15 of 426 comments
Lotsa Sep 5, 2013 @ 3:56am 
Any way to change the camera battery's charge time?
Last edited by Lotsa; Sep 5, 2013 @ 3:57am
illescasDaniel Sep 5, 2013 @ 3:57am 
Originally posted by LOTSAFINGAS:
Any way to change the torch battery's charge time?
I don't know :S
Lotsa Sep 5, 2013 @ 3:57am 
Damn batteries die too quickly lol
illescasDaniel Sep 5, 2013 @ 3:58am 
Originally posted by LOTSAFINGAS:
Damn batteries die too quickly lol
Yeah I know :(
Kilo Sep 5, 2013 @ 3:58am 
Cheers dude, I'll try this out and let you know how it goes.
Lotsa Sep 5, 2013 @ 4:01am 
Never mind, found it.
illescasDaniel Sep 5, 2013 @ 4:01am 
Originally posted by LOTSAFINGAS:
Never mind, found it.
Please explain how.
Lotsa Sep 5, 2013 @ 4:03am 
C:\Users\Caleb\Documents\My Games\Outlast\OLGame\Config

Select Olgame and open with notepad, press control F and type in Battery, click find, change values :D
illescasDaniel Sep 5, 2013 @ 4:05am 
Originally posted by LOTSAFINGAS:
C:\Users\Caleb\Documents\My Games\Outlast\OLGame\Config

Select Olgame and open with notepad, press control F and type in Battery, click find, change values :D

Good find, thanks.
Disrupt Sep 5, 2013 @ 4:40am 
awesome tweak guide.
Are all of these 100% confirmed (mainly AA settings im personally interested in)

Also another one of interest:
-VSYNC- (not tested)
OLSystemSettings.ini
UseVsync=True

Change to
UseVsync=False
Last edited by Disrupt; Sep 5, 2013 @ 4:43am
illescasDaniel Sep 5, 2013 @ 4:44am 
Originally posted by .Disruptr:
awesome tweak guide.
Are all of these 100% confirmed (mainly AA settings im personally interested in)

Yes, I tested all of them except the battery life (but it must work I think).
The AA Tweak Works 100%, I recommend "MaxMultiSamples=2" (MSAA x2) instead of "MaxMultiSamples=4" (MSAA x4) because it is better for performance.

Well, you can Turn Off Vsync in Options Menu.
Last edited by illescasDaniel; Sep 5, 2013 @ 4:45am
Companion Pube Sep 5, 2013 @ 5:16am 
Great guide, thanks for taking the time to write all of this down.
nick Sep 5, 2013 @ 5:20am 
This is better than what you've posted, also people have above 144hz monitors (unlikely to be playing this game) just an fyi

bSmoothFrameRate=FALSE
MinSmoothedFrameRate=0
MaxSmoothedFrameRate=0
illescasDaniel Sep 5, 2013 @ 5:21am 
Originally posted by playername:
This is better than what you've posted, also people have above 144hz monitors (unlikely to be playing this game) just an fyi

bSmoothFrameRate=FALSE
MinSmoothedFrameRate=0
MaxSmoothedFrameRate=0

Anyway is the same, because if you have disabled SmoothFrameRate the game won't use min and maxsmoothedframrate commands, but I will change that Thanks.
Last edited by illescasDaniel; Sep 5, 2013 @ 5:21am
My name is Cloud Sep 5, 2013 @ 5:56am 
It would be better if grainy screen can be removed/change. Like Silent Hill.
< >
Showing 1-15 of 426 comments
Per page: 15 30 50

Outlast > General Discussions > Topic Details