Deus Ex: Human Revolution - Director's Cut

Deus Ex: Human Revolution - Director's Cut

View Stats:
OdanUrr Oct 24, 2013 @ 3:36am
List of bugs, missing items, etc. (Updated 31/03/2014)
Per request of Jerion from the Eidos' forum I'm adding a link to a thread that will aim to provide official clarifications and responses to issues people have been experiencing with the DC:

Human Revolution Director's Cut: Answers from the team[forums.eidosgames.com]

-- Nomenclature --

*SAE - Problem Solved According to Eidos

*FiET - Fix can be found in the Eidos thread

-- Original post --

I thought it'd be a good idea if we kept a list of bugs, missing items, etc., that we've encountered while playing the DC so as not to be forced to search dozens of threads. I'll try and update this post as I'm able. I've yet to start playing but I've already found that the promised strategy guide is missing and, apparently, the Tactical-Pattern Recognition System augment is not in the game. If someone could confirm the latter, I'd appreciate it.

So, what other discrepancies have you found?

List of missing features/bugs:

1) No official strategy guide (Wii U exclusive)
2) No Tactical-Pattern Recognition System augment (Wii U only)
3) No touchscreen hacking
4) Frame rate drops
5) Broken carpet pattern in Detroit's apartment buildings (SAE)
6) Texture problem on the base of Detroit convenience shops (SAE)
7) Holding W+A or W+D results in movement speed increase
8) Cloaks and Daggers' quest: floating cup bug
9) Before the "security" tutorial: you can walk into the wall on the left
10) One of the male hobo NPCs in Detroit City Sewers (right at the bottom of the manhole behind DPD) can revert to the default "arms raised sideways" position and will stay as such. Screen | Screen | Screen
11) Problems opening/loading the game
12) Black posters on company lobby after intro (SAE)
13) Flashing dots on the characters if you turn on the Tesselation (may be Nvidia-related)
14) Text-Language option is missing (SAE)
15) Cursor jumping in main, hacking and picking items menus (FiET)
16) Superimposed audio tracks
17) Characters frozen in places
18) Problems with SSAO, bloom/HDR, and other lighting and shadowing effects
19) Achievements don't work in PAL version
20) Music looping causes fast-forwarding of conversations
21) Kitchens in Hengsha apartments have broken/missing textures (show up as bright green) (SAE)
22) Problems with dirt texture in outdoor planters and in Adam's apartment (SAE)
23) Incoming audio signal for commentary even when disabled in the main options menu (SAE)
24) Polish and Russian languages are missing (Not supported)
25) Inventory: using an automatic unlocking device for a quest consumes two
26) One of the NPCs in the garden pods is standing in mid air.
27) Sometimes after a quickload, those reflections in windows will be distorted so instead of seeing the reflection of the room behind me it's just a broken mosaic of colors.
28) When increasing the FOV, the quick-slot inventory at the bottom of the screen disappears completely. (Update)
29) Sometimes menu buttons stop working and become unresponsive.
30) In China after Belltower attacks the Alice Garden Pods, I escaped, then went to the LIMB clinic. Right after I exited the limb clinic, the background music / ambience started skipping. When the glitch is present, you are unable to talk to Malik's friend from the LIMB clinic after he heads outside.
31) Alice Gardens: floating man glitch
32) Civillian NPCs' voices are muffled when they reply if you interact with them with your weapon drawn.
33) Can't use ä or ö on Steam chat when the game is running and when leaving the game it'll crash and gamepad won't work afterwards.
34) Cutscene glitches on NPC faces when using localization (not a tesselation issue)
35) Low quality textures in places[minus.com]
36) Alt+TAB frequently crashes the game
37) Possible bug with Foxiest of the Hounds achievement
38) Texture problems in Jensen's apartment (SAE)
39) Stun gun glitch in DLC
40) Hostile police officers in Detroit
41) Crash during Missing Link
42) Strange window texture glitch
43) Missing textures in Tai Yong Medical (SAE)
44) Graphics glitch in laser room
45) Low res + oversaturation (?)
46) Missing pictures in Zhao's penthouse
47) Screen clipping in Tai Yong Medical
48) Flashing water texture in Hengsha sewers
49) Missing Link: see-through wall
50) Missing Link: broken email
51) Missing Link: missing quotation mark in dialogue with Keitner
52) NG+: Missing money and weapons at start (Gear doesn't carry over)
53) Issue with dual monitors when running DXHR:DC: second monitor goes black
54) Switching hacked turrets from disabled/enemies (friendly to you) to normal (hostile to you) results in the map going alert for a second.
55) You can hack a wall safe multiple times
56) Destroying walls will kill enemies leaning on them (is that a bug?)
57) Stuttering when accessing security hubs
58) Lighting problems on Malik's VTOL
59) Texture problems at the FEMA facility
60) Issue with the hacking menu
61) Misaligned iron sight on revolver
62) Wider cone of fire when zooming with certain weapons
63) Laser pointer results in iron sight innacuracy/misalignment
64) Badly mirrored textures on the immovable crates in the first elevator of the TYM building | Screen
65) Floating geometry w/texture in the room after the elevator in the previous screenshot | Screen | Screen | Screen
66) Odd white glow
67) Possible lighting issue: black toilets
68) Vanishing gang member on Derelict Row
69) Death by tranquilizer dart (Confirmed) (Isolated?)
70) Initial music in Megan's office continues playing over next track (SAE)
71) News broadcasts reset for no apparent reason
72) Insufficient energy warning overstays its welcome
73) Decal issue with Purity First graffitis in the Sarif Manufacturing Plant
74) Frozen character makes progression impossible (Solved)
75) Looping dialogue during the Typhoon presentation makes progression impossible (Solved)
76) Bullet decal flickering
77) Malik's VTOL has shading issues...
78) ... and oversaturation ones
79) After the Barrett boss fight if you go up the ladder to hack the terminal in the area the boss fight music triggers again.
80) Windmill texture issues
81) Unable to select DX11 options
82) Missing MCB NPC
83) Windows/Steam client error
84) 360º X-Ray cameras
85) Vanishing blood during intro
86) Missing blood in Hive torture room (?)
87) Broken textures in Alice Garden Pods
88) Invisible Belltower Guard
89) Slow motion issue on quick load
90) Sky/ground banding issues
91) Malik's VTOL: bad shading/shadowing pt. 2
92) Bugged conversation with Chet Wagner during the Motherly Ties quest
93) Jenny Alexander's missing from her spot; unable to complete quest
94) Yelena doesn't react to your presence during the fight
95) Leaves suspended in the air in sewers
96) Problem with Dr. Wing's eyes
97) Texture issue in Hengsha sewers
98) Mirrored number in Missing Link
99) Using a crate to hack Burke's office shortens the camera's surveillance arc
100) Lighting issues with mine during the "Smash the State" side quest
101) Loud sound drowns Federova death cutscene
102) Talion A.D. quest still bugged
103) Upon completion of the "Smash the State" side quest the door to the Police Station becomes accessible...
104) And the dialogues repeat themselves.
105) Greg Thorpe's Seurat dialogue repeats in Detroit 2
106) Bugged "Motherly Ties" quest during conversation with Cassandra Reed
107) Possible UI bug
108) Bug with NPCs at Jensen's apartment upon completion of "Motherly Ties" quest
109) Problems shutting down the game
110) CASIE dialogue options wrongly assigned (Confirmed) (SAE)
111) Unable to complete "Motherly Ties": Chet Wagner is missing (SAE)
112) Lighting creeps through breakable wall in Harvester Hideout...
113) ...and in Derelict Row
114) During the Namir boss fight: battle music stops in camera/security hub room
115) Clipping issues while using iron sight, crouched, at FOV 80 (apparently only happens when Jensen's wearing his trench coat)
116) Stuck Belltower guard outside LIMB clinic in Hengsha
117) Broken LOD/draw distance in the Old Noodle Factory
118) Glowing toilet in Old Noodle Factory (Tracer's cell)
119) Possible texture glitch: pinned paper pieces in Hong Hua bar
120) Steam ingame overlay doesn't work
121) Game crashes when Alt-TABing while using Steam overlay and when clicking on Windows on 2nd monitor
122) The game doesn't use the system settings for the keyboard, so in the case of German keyboards the Y and Z are swapped.
123) Bugged outlines in the first room of TML
124) Death by non-lethal takedown of another guard
125) Light bleeding through doors in TML
126) Odd end (not a bug): If you had 200 HP before ML, you keep the 200 HP even though it doesn't make sense within the context of what happened in the game.
127) Audio bug in TML when picking up weapons and gear
128) Guard in TML dies when dragged through a doorway (aka The Doorway of Doom)
129) Game won't start in Italian despite being fully supported
130) Missing weapon in TML
131) Missing yellow highlight from openable door
132) Draw distance/lod issue in TML
133) Game crash when trying to exit the LIMB clinic in Hengsha
134) Problem with hacking panel in TML
135) Problems interacting with Quinn in TML
136) Any transaction in Hengsha results in crashes
137) Draw distance issue in Kavanagh's lab
138) Dragging unconscious soldiers in Omega Ranch, then saving and reloading results in them dying
139) Floating geometry+textures in Hangar 18
140) Save/load killing bug also in Detroit (Also here and here)
141) Burke stuck in one spot
142) Burke's taunts are cut off when moving through tunnel (bug?)
143) Namir battle music stops when reloading
144) Floating box in Panchea tower
145) Hyron Project boss starts again after fight
146) Game hangs when loading after the ending
147) Issue with cover boundaries in LEO shuttle room
148) Inaccurate date/time stamp on saved games (verify: bug or date format?)
149) Guard goes into alarm mode when exiting a locker
150) Factory Zero achievement bugged
151) Sitting NPC hovering outside LIMB clinic in Hengsha
152) Stuck: unable to escape in TML
153) Tai Yong Medical: bottom laser fails to flicker
154) Missing pictures of achievements
155) Discovered password doesn't show up when hacking terminal
156) Civilians with arms extended permanently in the Convention Centre.
157) If you fail to talk Sandoval down, he has a pocket secretary with him. However, there is no pocket secretary if you do manage to talk him down and later proceed to stun/shoot him.
158) Can't pick up weapon upgrade in Belltower Docks even if you have enough inventory space.
159) In TML-CIC Ground Floor, an unconscious guard will suddenly die when dragged through a door.
160) In TML, the screens in the CIC room are simply empty frames that allow you to see the ceiling and walls.
161) Audio delay when shooting.
162) Some items leave their outline when removed from the quickbar.
Last edited by OdanUrr; Mar 31, 2014 @ 8:34am
< >
Showing 226-240 of 981 comments
blackguard Nov 1, 2013 @ 3:24pm 
I just shot a wall in Montreal, with two Belltower guards behind it, none of them leaning, and it stunned them for a few seconds. Taking what yupsi said into account, it might deal damage to the enemies based on their distance to the wall. or simply considering wall-breaking when leaning as insta-kill, since the guy in my Detroit scenario just *fell* over the debris of the wall, towards the side i was shooting from.
Last edited by blackguard; Nov 1, 2013 @ 3:25pm
docjeffy Nov 1, 2013 @ 5:44pm 
For some reason I cannot select DX11 in the options. My system has the latest nVidia drivers (v 331.58), and is more than capable of doing DX11 (I have run other DX11 games on the system).
Devilswarchild Nov 1, 2013 @ 6:13pm 
Originally posted by te47:
Looks like the Pacifist and Foxiest of the Hounds achievements really are messed up. The way I always play (and, of course, did during my first playthrough of the DC) means both never risking a single casualty under any circumstances and getting Ghost every single time it's possible to do so. I succeeded in doing that (as always), and never even used anything but nonlethal takedowns, and I still didn't get Pacifist or Foxiest of the Hounds. I definitely never had any trouble getting those in the original game...
you would have to get smooth operator as well as ghost every single time
I have had 2 missing NPC's. both in the same quest

one of the MCB's in Double-T's apartment vanished, he "teleported in" when I shot one of the Dead MCB's in the head again.

Also, in the same quest Xander has gone missing from her spot, and therefore, am unable to finish the quest.
Devilswarchild Nov 1, 2013 @ 6:51pm 
buildbot_winslave04_steam_steam_rel_client_win32@winslave04 keeps popping up with not responding might want to look into this. im running windows 7 ultimate 64bit with 16 GB of RAM, bigfoots killer wireless, nvidia 670M with current driver, i7 multicore processors.
Ischaria Nov 1, 2013 @ 7:40pm 
Originally posted by JackLaVaporiera:
Originally posted by Ischaria:
Hi, Im having real trouble with this game. Ive had a quick read through and I seem to have some problems unique to me, so Im posting this in the hope some people are having the same problem and hae managed to fix it. I emailed Square Enix but no reply so far (surprise surprise).

The game breaking problem is that the female Aug lady in the tutorial/start of game is frozen in place, in a T shape with her machine guns glitched into her hands. This makes it impossible to progress after the first 10-15 mins of play. This happens 100% of the time ive managed to get this far. However sometimes im rumbled by other errors on the way.

A problem that occurs 50% of the time is that during the initial sequence, when you follow the smartly dressed lady and see the "typhoon" in action, the guy just repeats the last thing he says over and over and again progression becomes impossible.

Numerous characters are frozen in place. Bad guys dont always seem to respond to being shot and are just frozen.

Also, the performance is absolutely terrible. I get framerates of 50-60 that drop to 10-20 every 20 seconds or so. This is regardless of graphics settings. I have a GT650M, its a laptop chip but should be powerful enough to play on at least medium settings right?

Generally pretty pissed off about this, being unable to get past the first 15 minutes is frustrating. The bad perfomance makes it more frustrating to play!!!

Laptops are common sources of issues, I feel you, to tell it all, sometimes they use a completely different coupling of system components than desktops, this makes for really weird situation like yours and widely diffused statements sounding "may not be compatible with all mobile chips".

All I can do to temporarily help is just made of a couple of hints, select the high performance power profile in windows energy saving options and try to see if Nvidia Inspector allows you to couple the game with the profile for the original game and tweak the power management option of the GPU to "prefer maximum performance" istead of "adaptive", toggle "threaded optimization" ON and set "max pre-rendered frames" to 1, also condsider to check the level of fragmentation in the drive in which the game is installed (if not an SSD). Finally, be sure to not have a very intrusive antivirus doing some scan in the background or even on access scanning on the game folder.

This is nearly everything I can do to help, there are scattered around even few registry tweaks and someone did benefit from leaving a browser like Chrome open in the backgound, shouldn't be an issue to find these "tricks" someone seemingly found useful, just browse a bit the other threads for "performance issues" and there you go...

The last resource would be toggling CPU core-parking off but I'll try everything else first.

However it would be nice (and maybe useful to solve even in other instances), if devs are lurking in this thread, to specify your specs other than the GPU you're using, the more, the better, thanks.

Thanks for your reply! So I managed it with a pretty easy fix. For some reason it was defaulting to the intel graphics. Forcing it to use the nvidia graphics in the control panel fixed the immediate problem. Seems to run fine now, and I managed to get past the aug lady hurrah!
ninjaholic Nov 1, 2013 @ 7:49pm 
What a joke of a release. DX:HRDC is more bugged than the first. omg.
JackLaVaporiera Nov 1, 2013 @ 8:31pm 
Originally posted by docjeffy:
For some reason I cannot select DX11 in the options. My system has the latest nVidia drivers (v 331.58), and is more than capable of doing DX11 (I have run other DX11 games on the system).

Actually drivers doesn't count, as there is no dedicated profile for the game every release is nearly the same, TBP the latest release, to which the above still applies, is 331.65.

Check to not have an iGPU as default render output device, you're risking to miss one of the cutest bugsets since a long time if they should come out soon with a patch.
te47 Nov 1, 2013 @ 9:19pm 
Originally posted by Devilswarchild:
Originally posted by te47:
Looks like the Pacifist and Foxiest of the Hounds achievements really are messed up. The way I always play (and, of course, did during my first playthrough of the DC) means both never risking a single casualty under any circumstances and getting Ghost every single time it's possible to do so. I succeeded in doing that (as always), and never even used anything but nonlethal takedowns, and I still didn't get Pacifist or Foxiest of the Hounds. I definitely never had any trouble getting those in the original game...
you would have to get smooth operator as well as ghost every single time

I did. It's impossible to get Ghost without getting Smooth Operator too (when an alarm system is present), seeing as Smooth Operator is the "I'm kind of stealthy" bonus and Ghost is the "I'm completely stealthy" bonus. How could anyone sound the alarm if no one was even able to confirm that there's an intruder at all?
Last edited by te47; Nov 1, 2013 @ 9:32pm
Rawr Nov 2, 2013 @ 2:06am 
I encountered a bug with the security cameras myself in the labs early on. They disappeared from the map and seemed to have some sort of weird 360 degree x-ray vision, they'd spot me if there wasn't an actual wall between me and the camera. Objects such as boxes and anything other than a wall it would see straight through.
CubicRubik Nov 2, 2013 @ 2:43am 
dont remember, was this in original game or not, but in intro mission blood splatters disappear after 3-6 seconds.
http://steamcommunity.com/sharedfiles/filedetails/?id=191307207
http://steamcommunity.com/sharedfiles/filedetails/?id=191307244
Last edited by CubicRubik; Nov 2, 2013 @ 2:46am
ai_killer Nov 2, 2013 @ 7:15am 
Originally posted by CubicRubik:
dont remember, was this in original game or not, but in intro mission blood splatters disappear after 3-6 seconds.
Speaking of blood: The commentary says the torture room below the Hive is supposed to have blood on the floor or walls, but I didn't see any.
ai_killer Nov 2, 2013 @ 8:09am 
- More broken textures in Alice Garden Pods:
http://steamcommunity.com/sharedfiles/filedetails/?id=191383338

- Belltower guard in middle floor (section 2) pops in and out of the wall (see his location on the radar). Both guards seem stuck in place:
http://steamcommunity.com/sharedfiles/filedetails/?id=191384194

- Caps-Lock/slow motion doesn't recover correctly from quicksave/load, the game is stuck in the opposite mode to what the keyboard says.
blackguard Nov 2, 2013 @ 10:42am 
Bad sky banding, worse ground banding. This is with luminosity at 5th bar from the left.

http://cloud-2.steampowered.com/ugc/487806724408347460/CDA2681C5F49C5328922D2CA1B8D6AD8D05FA123/

EDIT: More banding.

http://cloud-2.steampowered.com/ugc/487806724410302807/E7214ADD33E11B2702DD440ECF6E6F7E571C7815/

EDIT 2: More bad shading/shadowing on Malik's VTOL, this time on the way back from Montreal, when you're dropped off on the roof of the Chiron building.

http://cloud-2.steampowered.com/ugc/487806724410600580/7E5E261AA163883F09B7542208AD6F10C4FCADAD/

http://cloud-2.steampowered.com/ugc/487806724410603771/4A6861F7DEA0AA798350EB698E644699912F5157/
Last edited by blackguard; Nov 2, 2013 @ 11:50am
Kondrakin Nov 2, 2013 @ 6:05pm 
Motherly ties quest - the part where you need to talk to Chet Wagner in the police station lobby.
I've been in the back way and knocked out most people, collected the incriminating evidence from his computer to get him to talk, yet when I finally go to talk to him in the lobby all I get is the response "you got what you wanted".
What happened to my damn conversation?
< >
Showing 226-240 of 981 comments
Per page: 15 30 50