Deus Ex: Human Revolution - Director's Cut

Deus Ex: Human Revolution - Director's Cut

View Stats:
OdanUrr Oct 24, 2013 @ 3:36am
List of bugs, missing items, etc. (Updated 31/03/2014)
Per request of Jerion from the Eidos' forum I'm adding a link to a thread that will aim to provide official clarifications and responses to issues people have been experiencing with the DC:

Human Revolution Director's Cut: Answers from the team[]

-- Nomenclature --

*SAE - Problem Solved According to Eidos

*FiET - Fix can be found in the Eidos thread

-- Original post --

I thought it'd be a good idea if we kept a list of bugs, missing items, etc., that we've encountered while playing the DC so as not to be forced to search dozens of threads. I'll try and update this post as I'm able. I've yet to start playing but I've already found that the promised strategy guide is missing and, apparently, the Tactical-Pattern Recognition System augment is not in the game. If someone could confirm the latter, I'd appreciate it.

So, what other discrepancies have you found?

List of missing features/bugs:

1) No official strategy guide (Wii U exclusive)
2) No Tactical-Pattern Recognition System augment (Wii U only)
3) No touchscreen hacking
4) Frame rate drops
5) Broken carpet pattern in Detroit's apartment buildings (SAE)
6) Texture problem on the base of Detroit convenience shops (SAE)
7) Holding W+A or W+D results in movement speed increase
8) Cloaks and Daggers' quest: floating cup bug
9) Before the "security" tutorial: you can walk into the wall on the left
10) One of the male hobo NPCs in Detroit City Sewers (right at the bottom of the manhole behind DPD) can revert to the default "arms raised sideways" position and will stay as such. Screen | Screen | Screen
11) Problems opening/loading the game
12) Black posters on company lobby after intro (SAE)
13) Flashing dots on the characters if you turn on the Tesselation (may be Nvidia-related)
14) Text-Language option is missing (SAE)
15) Cursor jumping in main, hacking and picking items menus (FiET)
16) Superimposed audio tracks
17) Characters frozen in places
18) Problems with SSAO, bloom/HDR, and other lighting and shadowing effects
19) Achievements don't work in PAL version
20) Music looping causes fast-forwarding of conversations
21) Kitchens in Hengsha apartments have broken/missing textures (show up as bright green) (SAE)
22) Problems with dirt texture in outdoor planters and in Adam's apartment (SAE)
23) Incoming audio signal for commentary even when disabled in the main options menu (SAE)
24) Polish and Russian languages are missing (Not supported)
25) Inventory: using an automatic unlocking device for a quest consumes two
26) One of the NPCs in the garden pods is standing in mid air.
27) Sometimes after a quickload, those reflections in windows will be distorted so instead of seeing the reflection of the room behind me it's just a broken mosaic of colors.
28) When increasing the FOV, the quick-slot inventory at the bottom of the screen disappears completely. (Update)
29) Sometimes menu buttons stop working and become unresponsive.
30) In China after Belltower attacks the Alice Garden Pods, I escaped, then went to the LIMB clinic. Right after I exited the limb clinic, the background music / ambience started skipping. When the glitch is present, you are unable to talk to Malik's friend from the LIMB clinic after he heads outside.
31) Alice Gardens: floating man glitch
32) Civillian NPCs' voices are muffled when they reply if you interact with them with your weapon drawn.
33) Can't use ä or ö on Steam chat when the game is running and when leaving the game it'll crash and gamepad won't work afterwards.
34) Cutscene glitches on NPC faces when using localization (not a tesselation issue)
35) Low quality textures in places[]
36) Alt+TAB frequently crashes the game
37) Possible bug with Foxiest of the Hounds achievement
38) Texture problems in Jensen's apartment (SAE)
39) Stun gun glitch in DLC
40) Hostile police officers in Detroit
41) Crash during Missing Link
42) Strange window texture glitch
43) Missing textures in Tai Yong Medical (SAE)
44) Graphics glitch in laser room
45) Low res + oversaturation (?)
46) Missing pictures in Zhao's penthouse
47) Screen clipping in Tai Yong Medical
48) Flashing water texture in Hengsha sewers
49) Missing Link: see-through wall
50) Missing Link: broken email
51) Missing Link: missing quotation mark in dialogue with Keitner
52) NG+: Missing money and weapons at start (Gear doesn't carry over)
53) Issue with dual monitors when running DXHR:DC: second monitor goes black
54) Switching hacked turrets from disabled/enemies (friendly to you) to normal (hostile to you) results in the map going alert for a second.
55) You can hack a wall safe multiple times
56) Destroying walls will kill enemies leaning on them (is that a bug?)
57) Stuttering when accessing security hubs
58) Lighting problems on Malik's VTOL
59) Texture problems at the FEMA facility
60) Issue with the hacking menu
61) Misaligned iron sight on revolver
62) Wider cone of fire when zooming with certain weapons
63) Laser pointer results in iron sight innacuracy/misalignment
64) Badly mirrored textures on the immovable crates in the first elevator of the TYM building | Screen
65) Floating geometry w/texture in the room after the elevator in the previous screenshot | Screen | Screen | Screen
66) Odd white glow
67) Possible lighting issue: black toilets
68) Vanishing gang member on Derelict Row
69) Death by tranquilizer dart (Confirmed) (Isolated?)
70) Initial music in Megan's office continues playing over next track (SAE)
71) News broadcasts reset for no apparent reason
72) Insufficient energy warning overstays its welcome
73) Decal issue with Purity First graffitis in the Sarif Manufacturing Plant
74) Frozen character makes progression impossible (Solved)
75) Looping dialogue during the Typhoon presentation makes progression impossible (Solved)
76) Bullet decal flickering
77) Malik's VTOL has shading issues...
78) ... and oversaturation ones
79) After the Barrett boss fight if you go up the ladder to hack the terminal in the area the boss fight music triggers again.
80) Windmill texture issues
81) Unable to select DX11 options
82) Missing MCB NPC
83) Windows/Steam client error
84) 360º X-Ray cameras
85) Vanishing blood during intro
86) Missing blood in Hive torture room (?)
87) Broken textures in Alice Garden Pods
88) Invisible Belltower Guard
89) Slow motion issue on quick load
90) Sky/ground banding issues
91) Malik's VTOL: bad shading/shadowing pt. 2
92) Bugged conversation with Chet Wagner during the Motherly Ties quest
93) Jenny Alexander's missing from her spot; unable to complete quest
94) Yelena doesn't react to your presence during the fight
95) Leaves suspended in the air in sewers
96) Problem with Dr. Wing's eyes
97) Texture issue in Hengsha sewers
98) Mirrored number in Missing Link
99) Using a crate to hack Burke's office shortens the camera's surveillance arc
100) Lighting issues with mine during the "Smash the State" side quest
101) Loud sound drowns Federova death cutscene
102) Talion A.D. quest still bugged
103) Upon completion of the "Smash the State" side quest the door to the Police Station becomes accessible...
104) And the dialogues repeat themselves.
105) Greg Thorpe's Seurat dialogue repeats in Detroit 2
106) Bugged "Motherly Ties" quest during conversation with Cassandra Reed
107) Possible UI bug
108) Bug with NPCs at Jensen's apartment upon completion of "Motherly Ties" quest
109) Problems shutting down the game
110) CASIE dialogue options wrongly assigned (Confirmed) (SAE)
111) Unable to complete "Motherly Ties": Chet Wagner is missing (SAE)
112) Lighting creeps through breakable wall in Harvester Hideout...
113) ...and in Derelict Row
114) During the Namir boss fight: battle music stops in camera/security hub room
115) Clipping issues while using iron sight, crouched, at FOV 80 (apparently only happens when Jensen's wearing his trench coat)
116) Stuck Belltower guard outside LIMB clinic in Hengsha
117) Broken LOD/draw distance in the Old Noodle Factory
118) Glowing toilet in Old Noodle Factory (Tracer's cell)
119) Possible texture glitch: pinned paper pieces in Hong Hua bar
120) Steam ingame overlay doesn't work
121) Game crashes when Alt-TABing while using Steam overlay and when clicking on Windows on 2nd monitor
122) The game doesn't use the system settings for the keyboard, so in the case of German keyboards the Y and Z are swapped.
123) Bugged outlines in the first room of TML
124) Death by non-lethal takedown of another guard
125) Light bleeding through doors in TML
126) Odd end (not a bug): If you had 200 HP before ML, you keep the 200 HP even though it doesn't make sense within the context of what happened in the game.
127) Audio bug in TML when picking up weapons and gear
128) Guard in TML dies when dragged through a doorway (aka The Doorway of Doom)
129) Game won't start in Italian despite being fully supported
130) Missing weapon in TML
131) Missing yellow highlight from openable door
132) Draw distance/lod issue in TML
133) Game crash when trying to exit the LIMB clinic in Hengsha
134) Problem with hacking panel in TML
135) Problems interacting with Quinn in TML
136) Any transaction in Hengsha results in crashes
137) Draw distance issue in Kavanagh's lab
138) Dragging unconscious soldiers in Omega Ranch, then saving and reloading results in them dying
139) Floating geometry+textures in Hangar 18
140) Save/load killing bug also in Detroit (Also here and here)
141) Burke stuck in one spot
142) Burke's taunts are cut off when moving through tunnel (bug?)
143) Namir battle music stops when reloading
144) Floating box in Panchea tower
145) Hyron Project boss starts again after fight
146) Game hangs when loading after the ending
147) Issue with cover boundaries in LEO shuttle room
148) Inaccurate date/time stamp on saved games (verify: bug or date format?)
149) Guard goes into alarm mode when exiting a locker
150) Factory Zero achievement bugged
151) Sitting NPC hovering outside LIMB clinic in Hengsha
152) Stuck: unable to escape in TML
153) Tai Yong Medical: bottom laser fails to flicker
154) Missing pictures of achievements
155) Discovered password doesn't show up when hacking terminal
156) Civilians with arms extended permanently in the Convention Centre.
157) If you fail to talk Sandoval down, he has a pocket secretary with him. However, there is no pocket secretary if you do manage to talk him down and later proceed to stun/shoot him.
158) Can't pick up weapon upgrade in Belltower Docks even if you have enough inventory space.
159) In TML-CIC Ground Floor, an unconscious guard will suddenly die when dragged through a door.
160) In TML, the screens in the CIC room are simply empty frames that allow you to see the ceiling and walls.
161) Audio delay when shooting.
162) Some items leave their outline when removed from the quickbar.
Last edited by OdanUrr; Mar 31, 2014 @ 8:34am
< >
Showing 1-15 of 981 comments
blackguard Oct 24, 2013 @ 4:27am 
The carpet pattern (either the texture or its scaling) in Detroit's apartment buildings is broken.

Don't expect the TPRS augment to show up in the game. There's no easy way to calibrate a normal display with a normal tablet (and by that I mean you won't be able to use it as smartvision), which is why I assume they didn't implement it. That aug is WiiU only. Tablet will probably stay as hacking-only. We'll see. Maybe they really did forget to implement it.
Last edited by blackguard; Oct 24, 2013 @ 4:32am
OdanUrr Oct 24, 2013 @ 6:33am 
I don't know if this can be considered a bug or not but, apparently, the "rebalanced energy system" means that instead of the leftmost bar automatically recharging (as it was in the original version) now you get the two leftmost bars automatically recharging.

As you can see on the link, some people claim it breaks the energy management system even further.
Last edited by OdanUrr; Oct 24, 2013 @ 6:35am
thkim Oct 24, 2013 @ 6:37am 
From what I know, that´s intentional, except on Give me Deus Ex, where it´s still only the leftmost bar.

Originally posted by OdanUrr:
I don't know if this can be considered a bug or not but, apparently, the "rebalanced energy system" means that instead of the leftmost bar automatically recharging (as it was in the original version) now you get the two leftmost bars automatically recharging.
blackguard Oct 24, 2013 @ 6:37am 
Going by a thread on reddit, it seems that the number of batteries that recharge is based on the difficulty. GMDE=1 battery.

Yeah, it didn't solve much.

EDIT: got ninja'd :(
Last edited by blackguard; Oct 24, 2013 @ 6:38am
Sh1nRa358 Oct 24, 2013 @ 8:31am 
No official strategy guide is not a missing feature -_-
Touchscreen hacking would be nice though if it used a second monitor to display it on.
OdanUrr Oct 24, 2013 @ 8:37am 
Originally posted by shinra35888:
No official strategy guide is not a missing feature -_-

Is that also a Wii U exclusive?
Cryptocurrenstein Oct 24, 2013 @ 9:27am 
I noticed holding W and either A or D increases your movement speed by a good amount. I remember this being a bug that was rectified in a patch shortly after release. I'm also experiencing frame rate stuttering as I did shortly after release of the original version; an issue also fixed shortly after release with a patch.

How do you manage to reintroduce problems?
OdanUrr Oct 24, 2013 @ 9:34am 
Originally posted by Spooky Mettil:
How do you manage to reintroduce problems?

Easy, you work on an unpatched version.
JuicyCrunchy Oct 24, 2013 @ 9:58am 
Originally posted by OdanUrr:
Originally posted by shinra35888:
No official strategy guide is not a missing feature -_-

Is that also a Wii U exclusive?

No. It's advertised as being in all versions of the game.
JuicyCrunchy Oct 24, 2013 @ 10:02am 
The gigantic, bright, white laser-dot flashlight is obviously a Wiimote thing and looks stupid and needs to be reverted.

The reds are way too saturated.

Ideally, the lighting scheme now would be blended with the original lighting scheme, because they went too far in the right direction and missed how the artists originally intended some scenic details to look.

Originally posted by OdanUrr:
some people claim it breaks the energy management system even further.

Maybe they should listen to those people. I don't know because I haven't played the game enough.
Last edited by JuicyCrunchy; Oct 24, 2013 @ 10:05am
JuicyCrunchy Oct 24, 2013 @ 11:47am 
Originally posted by OdanUrr:
Originally posted by Spooky Mettil:
How do you manage to reintroduce problems?

Easy, you work on an unpatched version.

I'd curious as to how this happened too. It's not a completely unpatched version because the patches did more than fix the stutter and other performance problems. They fixed gameplay bugs like the card that could fall through a desk and be lost or scripted events not happening when they should. I'd be interested to know if those are back too. One of the patches also added the menu option to switch to Windowed mode, which is here in version
Cryptocurrenstein Oct 24, 2013 @ 12:06pm 
In the Cloak and Daggers side quest, when going to the apartment to capture or kill T-Baller or whatever his name is, I spied a gang member drink from a glass in the kitchen. When he was finished, the cup froze in front of his face and floated in mid air, but the NPC went through the animation of putting it back on the counter. He then proceded to walk through the still floating glass.

I know it's a really minor thing, but it really is starting to seem like it's an unpatched version or something.
awave Oct 24, 2013 @ 12:12pm 
this is one:

i wasnt lagging or anything. just straight jesus'ed through the wall.
blackguard Oct 24, 2013 @ 1:35pm 
One of the male hobo NPCs in Detroit City Sewers (right at the bottom of the manhole behind DPD) can revert to the default "arms raised sideways" position and will stay as such.
Last edited by blackguard; Oct 24, 2013 @ 1:43pm
Brownstone Oct 24, 2013 @ 3:36pm 
I compared the screenshots and is this version less yellow?
< >
Showing 1-15 of 981 comments
Per page: 15 30 50