Deus Ex: Human Revolution - Director's Cut

Deus Ex: Human Revolution - Director's Cut

View Stats:
Failed to Initialize Directx3D
I keep getting this error, any help would be greatly appreciated!!!!
< >
Showing 1-6 of 6 comments
Kauldwin May 17, 2014 @ 7:21pm 
Usual questions/suggestions - have you tried verifying the game files and/or updating all your drivers? Failing that, have you tried re-installing?

If you've tried all of the above, what are your system specs?
Pentium (R) Dual-Core CPU E5300 @ 2.60 GHz 2.60 GHz
3.00 GB RAM
Intel (R) G33/G31 Express Chipset Family 256 MB Memory
Chip Type: Intel(R) GMA 3100
Kauldwin May 17, 2014 @ 8:40pm 
Since you didn't say, I'll assume you've already tried the fixes I listed. Not sure what OS you're running, but here is a potential fix I found (credit to Archfiend for the guide).

------

How to fix the Direct3D error for Windows 7 (DirectX 11)
We're going to need "Registry Editor" to fix this error.

Go to the Start menu, and search for "regedit."

Run the program.


We need to find the right folder and file to edit.

Open the dropdown menu for "HKEY_CURRENT_USER."

Open the dropdown menu for "Software."

Open the dropdown menu for "Eidos."

Open the dropdown menu for "Deus Ex: HRDC."

Go to the "Graphics" folder.


There's a million files in this folder, and at first it may look intimidating. However, all we need is to open the file named "EnableDirectX11." When you open it, you'll see a box in which "1" is displayed. This means DirectX 11 is enabled when running the game. Set this to 0 and click "Ok."

If you try running DX: HRDC now, the Direct3D error should be resolved. The game should start like it's supposed to, and you should never have to worry about DX freaking out like this again.
KarlAnthonyFrowns May 17, 2014 @ 10:46pm 
I disabled my Intel display adapter, tried disabling DirectX11 and still it won't start on my laptop running an i7 4700, GeForce 860M and Windows 8.1.

This is the error text:

Wrong DRM version data 0, code 15 rebuild of pc-w\anchor_bench.drm needed

I've given up and that sucks.
Originally posted by twig3721:
Since you didn't say, I'll assume you've already tried the fixes I listed. Not sure what OS you're running, but here is a potential fix I found (credit to Archfiend for the guide).

------

How to fix the Direct3D error for Windows 7 (DirectX 11)
We're going to need "Registry Editor" to fix this error.

Go to the Start menu, and search for "regedit."

Run the program.


We need to find the right folder and file to edit.

Open the dropdown menu for "HKEY_CURRENT_USER."

Open the dropdown menu for "Software."

Open the dropdown menu for "Eidos."

Open the dropdown menu for "Deus Ex: HRDC."

Go to the "Graphics" folder.


There's a million files in this folder, and at first it may look intimidating. However, all we need is to open the file named "EnableDirectX11." When you open it, you'll see a box in which "1" is displayed. This means DirectX 11 is enabled when running the game. Set this to 0 and click "Ok."

If you try running DX: HRDC now, the Direct3D error should be resolved. The game should start like it's supposed to, and you should never have to worry about DX freaking out like this again.

__ I do apologize for not specifying:

I am running Windows 7 x64 bit OS
I have tried this registry edit and it has not worked for me.

Do you reccommend anything else?
Originally posted by Koowey:
I disabled my Intel display adapter, tried disabling DirectX11 and still it won't start on my laptop running an i7 4700, GeForce 860M and Windows 8.1.

This is the error text:

Wrong DRM version data 0, code 15 rebuild of pc-w\anchor_bench.drm needed

I've given up and that sucks.
That's very unsettling. Your computer is clearly powerful than mine (I have a HP Pavillion Slimline). Does Steam know of this issue? I'm guessing this is the same as the OpenGL issue with Doom 3 BFG Edition...
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: May 17, 2014 @ 6:42pm
Posts: 6