The Banner Saga

The Banner Saga

View Stats:
 This topic has been pinned, so it's probably important
Manifold Jan 12, 2014 @ 9:03pm
The official BUG THREAD for The Banner Saga
Post here if you have a bug for the devs.

The Banner Saga is a fairly large and complex game with lots of branching variables. We tested as much as humanly possible for a small team, but inevitably there may be bugs. We don't expect tons, but if you run across something and would like to notify us, please post any issues you find here so we can easily keep track of them in a single thread, and we'll address them in the next patch.

If you run across an uncommon problem that is hard to reproduce, please include the steps you took before the bug occurred. Thank you very much and may your experience be bug-free!
< >
Showing 811-825 of 1,184 comments
Aleonymous Nov 7, 2016 @ 12:12am 
Originally posted by Moon Grin:
For some reason Rook is invisible, and all his actions are delayed for a few moments.

Happens from time to time. I haven't seen this one in a long time. Does it happen consistently for you, on just a couple of times? Do a verification of the game cache integrity, just to rule out corrupted files. If problem persists, you should email Stoic support with this.
KromeDragon Nov 29, 2016 @ 5:07pm 
On the intro cutscene, in the beginning of the game it drops to like 4 fps, but gameplay is near 60 fps.
Squiba Dec 1, 2016 @ 7:03pm 
When playing with a controller the selected menu item on the main screen does not appear highlighted. I can move through the menu guessing what option i'm on, but there is no visible indication of what i'm picking.
Aleonymous Dec 2, 2016 @ 12:12am 
Originally posted by Squiba:
When playing with a controller the selected menu item on the main screen does not appear highlighted. I can move through the menu guessing what option i'm on, but there is no visible indication of what i'm picking.

Does the game play otherwise well with the controller? Try verifying the integrity of the game cache.
Gestaltzerfall Dec 2, 2016 @ 12:29pm 
Affected Version: 2.36.02

The string reference 'title_tbs1' went missing in some locales.
The Bug occurs when trying to exit the game with these locales activated. Propably the string is also referenced in other parts of the game.

Affected Languages:
German: \assets\common\locale\de\strings.json.z
Polish: \assets\common\locale\pl\strings.json.z
Japanese: \assets\common\locale\jp\strings.json.z
Italian: \assets\common\locale\it\strings.json.z
Khatie Dec 3, 2016 @ 6:01am 
Thank you, Gestaltzerfall, the team will look into this issue asap.
Psycho_Duck Dec 3, 2016 @ 1:11pm 
Hello! It's problem on second mission. If i right understand, enemy must to kill our prince, when enemy attack, he give 10 damage. But early i was in training room and made for prince +1 to hp and now he has 11 hp.
And now when enemy attack me - script doesn't work and all stop.
What me do now? pic: there
Last edited by Psycho_Duck; Dec 3, 2016 @ 1:22pm
Aleonymous Dec 3, 2016 @ 1:52pm 
Originally posted by Psycho_Duck:
Hello! It's problem on second mission. If i right understand, enemy must to kill our prince, when enemy attack, he give 10 damage. But early i was in training room and made for prince +1 to hp and now he has 11 hp.
And now when enemy attack me - script doesn't work and all stop.
What me do now? pic: there

This is obviously a bug! That big Dredge enemy is supposed to knock-out Ludin (the prince) in one hit, so that the battle can move-on. Try reloading from your last save. If that doesn't fix it, try verifying the integrity of the game cache before reloading your last save.
Giopeppe Dec 3, 2016 @ 2:29pm 
Originally posted by Aleonymous:
Originally posted by Psycho_Duck:
Hello! It's problem on second mission. If i right understand, enemy must to kill our prince, when enemy attack, he give 10 damage. But early i was in training room and made for prince +1 to hp and now he has 11 hp.
And now when enemy attack me - script doesn't work and all stop.
What me do now? pic: there

This is obviously a bug! That big Dredge enemy is supposed to knock-out Ludin (the prince) in one hit, so that the battle can move-on. Try reloading from your last save. If that doesn't fix it, try verifying the integrity of the game cache before reloading your last save.

I reported this in the beta: It's a case limit. That Dredge has that precise potential damage, so, giving luding +1 armor/str after a bit of training in the tent, break the script.

It's better to reload BEFORE you promote ludin or restart the game.

Anyway, it's the only case in the entire game in which a similar thing should happen.
Last edited by Giopeppe; Dec 3, 2016 @ 2:30pm
second town, i pomoted price before we get in, so when the auto-fight, dredge couldnt one blow kill the prince... and ,it stucked...forever :steamfacepalm:
Originally posted by Psycho_Duck:
Hello! It's problem on second mission. If i right understand, enemy must to kill our prince, when enemy attack, he give 10 damage. But early i was in training room and made for prince +1 to hp and now he has 11 hp.
And now when enemy attack me - script doesn't work and all stop.
What me do now? pic: there
I am having the same problem lol
Gestaltzerfall Dec 3, 2016 @ 3:55pm 
You can avoid these bug, editing your savegame.
Scroll down and look for an entry like this below:

"ludin": { "stat_ups": { "ARMOR": 1, "KILLS": 2, "RANK": 1, "STRENGTH": 1 } },

That describes your upraded 'hero' Ludin.
Backup that savefile and delete the entry. Save the file. Reload.
Now Ludin is again a rookie.
Go through that scene...
Save.
Open your savefile and copy the earlier deleted text sequence.
[LINUX] Seven Dec 3, 2016 @ 4:24pm 
after the update the game won't start on Linux
ubuntu 16.10
nvidia 367.57
the game launches but there is nothing to see, i have to quit the game in systemmonitor
Caedus Dec 3, 2016 @ 5:07pm 
Same issue as previous poster here. Game launches, but no window pops up and I have to kill the process via the terminal.

Ubuntu 16.04 (64 bit)
Nvidia 370.28
< >
Showing 811-825 of 1,184 comments
Per page: 15 30 50