Transistor

Transistor

View Stats:
Chuck Daniels Nov 23, 2015 @ 2:28pm
ALSA 1.1.0 crashes the game
I'm running Arch Linux and I updated ALSA packages recently from version 1.0.29 -> 1.1.0.

Game crashes with this ALSA version if you start it on Steam. It works if you launch he game using the Linux executable from a terminal.

If you downgrade this package game will work again. I've noticed several Steam crashes when changing sound device too, not sure if they are related to ALSA new version.
Last edited by Chuck Daniels; Nov 23, 2015 @ 2:29pm
< >
Showing 1-8 of 8 comments
Chuck Daniels Nov 23, 2015 @ 2:39pm 
It is related with this Steam bug: https://github.com/ValveSoftware/steam-for-linux/issues/4139#issuecomment-159088958

It can be fixed by now launching steam from terminal this way:
LD_PRELOAD="/usr/lib/libasound.so.2:/usr/lib64/libasound.so.2" steam
flibitijibibo Nov 23, 2015 @ 6:47pm 
Ah, this explains a FEZ bug report I got a couple days ago too. This actually isn't the first time the Steam runtime has failed from their runtime, not sure why that lib is particularly painful for them.
Chuck Daniels Nov 24, 2015 @ 3:44am 
I hope this fix that error for you (in FEZ too).
ambidot Nov 25, 2016 @ 3:30am 
pacman -Rdd alsa-plugins see below
Last edited by ambidot; Nov 27, 2016 @ 3:31pm
Chuck Daniels Nov 26, 2016 @ 12:34pm 
@ambidot You can break some stuff doing that.
Last edited by Chuck Daniels; Nov 26, 2016 @ 12:41pm
ambidot Nov 26, 2016 @ 2:34pm 
a bunch of my♥♥♥♥♥♥is broken already (thanks Arch); this makes a few games work and doesn't seem to break anything else.
Chuck Daniels Nov 27, 2016 @ 3:24pm 
Breaking system dependencies is definitely not a good advice.
ambidot Nov 27, 2016 @ 3:30pm 
removing /usr/lib/alsa-lib/libasound_module_pcm_pulse.so also works per se. the assumption here is that there's no pulseaudio. because pulseaudio is♥♥♥♥♥♥
Last edited by ambidot; Nov 27, 2016 @ 3:30pm
< >
Showing 1-8 of 8 comments
Per page: 15 30 50