Realms of Arkania: Blade of Destiny

Realms of Arkania: Blade of Destiny

View Stats:
Zaphear Mar 8, 2014 @ 12:02pm
Can't believe I gave it another shot..
Got almost excited after watching a little bit of the Let's Play and reading some forum threads about the patch. Got a party started.. left the temple. Walked up to the Weapon market stall, and got stuck.. couldn't click anything, no windows popped up.. nothing. I saved/reloaded and same crap. !@#$$ this was the last game I ever bought that was in "early access" and I'll never do it again. Can't believe this crap exists.
< >
Showing 1-15 of 19 comments
Zaphear Mar 8, 2014 @ 12:09pm 
Aaaand even tried it again with another party, walked up to the weapon stall and clicked. Can't move, and nothing works now. This game is AWESOME.
Marcelo Sampaio Mar 8, 2014 @ 12:14pm 
Have you tried right-clicking anywhere in the screen? The ring menu will appear when you do that, allowing you to buy/sell things, leave, etc.
BlackDev Mar 8, 2014 @ 1:11pm 
nice trolling guys..

just giving it a try to at this moment, same problem.
right click on the screen anywhere wont work with this bug. u can open the inventory by clicking on the character portraits and you can open the option menu but u cant move, u cant right click, u cant trade with the trader and u cant leave the "trade" process neither.

i'm currently running the game in window mode, maybe this causes the problem... maybe not but its annoying as it is the first thing you "do" in the game and it breaks it..
BlackDev Mar 8, 2014 @ 1:13pm 
nope, same problem in full-screen mode
urartu Mar 8, 2014 @ 1:25pm 
Checked now. Apparently latest patch has broken a few things over there.

Healers also look funny, over-blurry. But "being unable to click" only happened at market stalls.
Last edited by urartu; Mar 8, 2014 @ 1:25pm
BlackDev Mar 8, 2014 @ 1:26pm 
yea, indoor traders are working correctly
Chris Firefox  [developer] Mar 8, 2014 @ 2:08pm 
Sorry, slipped through on last patch, fix should be up in about half an hour
BlackDev Mar 8, 2014 @ 2:10pm 
U guys won't even get sleep on weekends huh? ^^
Chris Firefox  [developer] Mar 8, 2014 @ 2:20pm 
Not when a patch is released, nope.
Zaphear Mar 8, 2014 @ 2:39pm 
No trolling intended.. I gave these guys 20.00 almost a year ago for a game I haven't been able to play for more then a hour. Slightly irked when I see "Progress!! a Patch!" and it's still an unplayable mess.
BlackDev Mar 8, 2014 @ 2:47pm 
the "trolling" wasnt adressed to you Zaphear
Chris Firefox  [developer] Mar 8, 2014 @ 2:49pm 
It is definitely NOT an unplayable mess if you stumble upon a single stupid bug introduced 5 Minutes before you started playing by a patch that fixed a myriad of other things and even added several new features. The Release was nine months ago, and the hotfix for making the market stalls functional again went live this minute. On Saturday, local time 10 minutes to midnight. Thanks for your feedback anyways.
nathelbiya Mar 8, 2014 @ 3:21pm 
Thanks for fixing the issue that fast, even on a weekend.
FastJack Mar 8, 2014 @ 3:25pm 
The game IS quite playable and enjoyable so to say it is an unplayable mess is not accurate.
Zaphear Mar 8, 2014 @ 6:20pm 
Single stupid bug? EVERY RPG I've ever played the first thing I do is check out the closest vendors. This "single stupid bug" makes that entire process impossible.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Mar 8, 2014 @ 12:02pm
Posts: 19