HITMAN™

HITMAN™

View Stats:
HITMAN™ > Tech Support > Topic Details
j.k.p Jun 22, 2017 @ 11:23am
Linux version fails to start after June update
HitmanPro segfaults with following (incomplete) stack
Thread 1 "HitmanPro" received signal SIGSEGV, Segmentation fault. 0x00007fffd5bb9500 in ?? () (gdb) bt #0 0x00007fffd5bb9500 in ?? () #1 0x00007fffdfbde4c9 in ?? () from /usr/lib64/nvidia/libGL.so.1 #2 0x00007fffdfbd8dc9 in ?? () from /usr/lib64/nvidia/libGL.so.1 #3 0x00007fffdfbcb266 in glXGetProcAddress () from /usr/lib64/nvidia/libGL.so.1 #4 0x00007ffff682e7bb in X11_GL_LoadLibrary () from /mnt/data/jan/games/steam/steamapps/common/Hitman™/bin/../lib/x86_64/libSDL2-2.0.5.so #5 0x00007ffff67e959b in SDL_CreateWindow_REAL () from /mnt/data/jan/games/steam/steamapps/common/Hitman™/bin/../lib/x86_64/libSDL2-2.0.5.so ...
Last edited by j.k.p; Jun 22, 2017 @ 11:24am
< >
Showing 1-5 of 5 comments
j.k.p Jun 26, 2017 @ 3:24am 
No idea how relevant is that but it appears X11_GL_LoadLibrary is called twice. First call passes successfully:
#0 X11_GL_LoadLibrary (_this=0x5b172c0, path=0x0) at /usr/src/debug/SDL2-2.0.5/src/video/x11/SDL_x11opengl.c:153 #1 0x00007ffff681d836 in SDL_GL_LoadLibrary_REAL (path=path@entry=0x0) at /usr/src/debug/SDL2-2.0.5/src/video/SDL_video.c:2729 #2 0x00007ffff681f779 in SDL_CreateWindow_REAL (title=title@entry=0x7ffff684b1e0 "OpenGL test", x=x@entry=-32, y=y@entry=-32, w=w@entry=32, h=h@entry=32, flags=flags@entry=10) at /usr/src/debug/SDL2-2.0.5/src/video/SDL_video.c:1371 #3 0x00007ffff681f3cf in ShouldUseTextureFramebuffer () at /usr/src/debug/SDL2-2.0.5/src/video/SDL_video.c:210 #4 SDL_VideoInit_REAL (driver_name=<optimized out>, driver_name@entry=0x0) at /usr/src/debug/SDL2-2.0.5/src/video/SDL_video.c:529 #5 0x00007ffff67839f7 in SDL_InitSubSystem_REAL (flags=16433) at /usr/src/debug/SDL2-2.0.5/src/SDL.c:173
while the second does not:
#0 X11_GL_LoadLibrary (_this=0x5b172c0, path=0x0) at /usr/src/debug/SDL2-2.0.5/src/video/x11/SDL_x11opengl.c:153 #1 0x00007ffff681d836 in SDL_GL_LoadLibrary_REAL (path=path@entry=0x0) at /usr/src/debug/SDL2-2.0.5/src/video/SDL_video.c:2729 #2 0x00007ffff681f779 in SDL_CreateWindow_REAL (title=0x37f3b11 "", x=<optimized out>, y=0, w=1, h=1, flags=26) at /usr/src/debug/SDL2-2.0.5/src/video/SDL_video.c:1371
j.k.p Jun 26, 2017 @ 10:40am 
The issue seems to be caused by interleaving OpenGL and Vulkan calls with NVIDIA binary driver. Minimal reproducer follows:
#include <SDL.h> #include <vulkan/vulkan.h> int main(int argc, char* argv[]) { if (SDL_Init(16433) != 0) { return 1; } vkGetInstanceProcAddr(0, "vkEnumerateInstanceExtensionProperties"); vkGetInstanceProcAddr(0, "vkEnumerateInstanceLayerProperties"); vkGetInstanceProcAddr(0, "vkCreateInstance"); uint32_t count; vkEnumerateInstanceLayerProperties(&count, 0); VkLayerProperties *layers = malloc(sizeof (VkLayerProperties) * count); vkEnumerateInstanceLayerProperties(&count, layers); vkEnumerateInstanceExtensionProperties(0, &count, 0); VkExtensionProperties *extensions = malloc(sizeof (VkExtensionProperties) * count); vkEnumerateInstanceExtensionProperties(0, &count, extensions); SDL_CreateWindow("", 1920, 0, 1, 1, 26); return 0; }
If vulkan calls are moved before SDL_init then program exits normally.
j.k.p Jun 26, 2017 @ 11:07am 
After removing vulkan icd file provided by nvidia driver (so that Hitman cannot find and invoke vulkan at all) I've managed to start Hitman but didn't manage to get too far. Looks like it quickly and randomly aborts right after starting some thread (sometimes it's not even possible to start a game):
#0 0x00007ffff09bae60 in raise () from /lib64/libc.so.6 #1 0x00007ffff09bc62a in abort () from /lib64/libc.so.6 #2 0x00000000004f1a99 in ?? () #3 0x00000000004f1aa9 in ?? () #4 0x0000000002d31cae in ?? () #5 0x00007ffff6c96300 in start_thread () from /lib64/libpthread.so.0 #6 0x00007ffff0a769bf in clone () from /lib64/libc.so.6 #7 0x0000000000000000 in ?? ()
Major Gnuisance Jun 26, 2017 @ 11:54am 
Have you contacted Feral Support as it says in the stickied thread?
I don't think they're looking for bug reports in this forum.

Also, some information about your system would probably help.
j.k.p Jun 30, 2017 @ 4:10pm 
Feral Interactive support pointed out it's an issue with vulkan ICD file which contains incorrect library path on non glvnd enabled distributions (on which it should be libGL.so.1 instead of default libGLX_nvidia.so.0)
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

HITMAN™ > Tech Support > Topic Details
Date Posted: Jun 22, 2017 @ 11:23am
Posts: 5