Anomaly 2
Kamilko47 May 19, 2013 @ 12:31am
Anomaly 2 loading freeze
Hi, I downloaded A2, launch and I have freeze loading when I launch first mission.

My spec:


OS
Debian GNU/Linux testing (jessie) (64 bitów)
Nazwa kernela: Linux
Wersja kernela: 3.2.0-4-amd64
Dostawca serwera X: The X.Org Foundation
Wydanie serwera X: 11204000
Menedżer okien X: compiz
Wersja biblioteki Steam: steam-runtime-release-i386_2013-04-16

Grapic:
Sterownik: NVIDIA Corporation GeForce GTS 250/PCIe/SSE2

Wersja sterownika: 3.3.0 NVIDIA 304.88
Głębia kolorów pulpitu: 24 bitów na piksel
Częstotliwość odświeżania monitora: 59 Hz
Ident. producenta: 0x10de
ID urządzenia: 0x615
Liczba monitorów: 1
Liczba logicznych układów graficznych: 1
Rozdzielczość głównego ekranu: 1280 x 768
Rozdzielczość pulpitu: 1280 x 768
Rozmiar głównego ekranu: 39,37" x 21,65" (44,92" diag)
100,0cm x 55,0cm (114,1cm diag)
Szyna: PCI Express 16x
Ilość pamięci VRAM: 512 MB
Obsługiwane tryby MSAA: 2x 4x 8x 16x

Karta dźwiękowa:
Dźwięk: SigmaTel STAC9750,51

Pamięć:
RAM: 3964 MB



Last edited by Kamilko47; May 19, 2013 @ 12:32am
< >
Showing 1-15 of 23 comments
Syrio Forel May 19, 2013 @ 2:42am 
I have the same issue - Mint 14 / P4 3.4Ghz / 9500 / 3 GB
thesub_jet May 27, 2013 @ 1:48am 
Same here using amd64 + Intel Atom D525 + NVIDIA ION2 (Xubuntu 12.10).
Also, managed to see segfault on my wife's notebook (i7 3610QM, Intel 4000 HD, NVIDIA GeForce GT 650M 2Gb, 8Gb RAM) both using Intel and Nvidia graphics (Bumblebee on Ubuntu 12.04 and 13.04).
Devs, please, help!
Last edited by thesub_jet; May 27, 2013 @ 1:56am
witham.ian May 29, 2013 @ 1:52am 
Same issue on Gnome remix Ubuntu 13.04. Unable to load the final level at all. Also while playing, the game will hang for a few seconds and then afterwards right clicking is disabled... quite important for this game!

Processor Information:
Vendor: GenuineIntel
Speed: 3901 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 13.04 (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-22-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11303000
X Window Manager: GNOME Shell
Steam Runtime Version: steam-runtime-release-i386_2013-05-08

Video Card:
Driver: NVIDIA Corporation GeForce GT 640/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 313.30
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xfc1
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 45.28" x 25.59" (51.97" diag)
115.0cm x 65.0cm (132.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC887-VD

Memory:
RAM: 7930 Mb

Miscellaneous:
UI Language: English
LANG: en_NZ.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 781818 Mb
Largest Free Hard Disk Block: 595018 Mb

Installed software:

Recent Failure Reports:

thesub_jet May 29, 2013 @ 5:03am 
Finally managed to play using Intel graphics by installing latest mesa.
Though confirm "right click disappearing" issue.
Shadow Jun 14, 2013 @ 12:12pm 
I have the same problem. Any luck ?

The game hangs after few seconds when loading first mission.
I have tried changing options like:
- graphic details
- fullscreen mode
- difficulty level
but none of them worked for me.
The strange part is that the game cursor is fully responsive while the loading spinner hangs.

The only thing I can do is to kill the game process.

Here's my hardware:
(I've temporarily changed Steam UI language from Polish to English)

Processor Information:
Vendor: AuthenticAMD
Speed: 3300 Mhz
6 logical processors
6 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
"Mageia 3" (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.13-desktop-1.mga3
X Server Vendor: The X.Org Foundation
X Server Release: 11304000
X Window Manager: KWin
Steam Runtime Version: steam-runtime-release-i386_2013-05-08

Video Card:
Driver: NVIDIA Corporation GeForce 9800 GT/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 319.17
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x605
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1280 x 1024
Desktop Resolution: 1280 x 1024
Primary Display Size: 14,80" x 11,85" (18,94" diag)
37,6cm x 30,1cm (48,1cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 512 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: CA0106

Memory:
RAM: 7969 Mb

Miscellaneous:
UI Language: English
LANG: pl_PL.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 80632 Mb
Largest Free Hard Disk Block: 41841 Mb

Installed software:

Recent Failure Reports:

akaIDIOT Jun 16, 2013 @ 11:38am 
I have a similar issue which is proving hard to google. Sometimes a mission will load and I can play the game (hoping the whole thing won't segfault before I reach the end, but that's another issue, I think), but often it will spin for a while as the protagonist tells a story and then stop. Audio continues for as long as it takes, cursor is responsive. Haven't been able to stop the game other than killing the process.

----

Processor Information:
Vendor: GenuineIntel
Speed: 3003 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Unsupported

Operating System Version:
Linux Mint 15 Olivia (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-25-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11303000
X Window Manager: Mutter (Muffin)
Steam Runtime Version: steam-runtime-release-i386_2013-05-08

Video Card:
Driver: NVIDIA Corporation GeForce GTS 250/PCIe/SSE2
Driver Version: 3.3.0 NVIDIA 310.44
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x615
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1200
Desktop Resolution: 3200 x 1200
Primary Display Size: 20,39" x 12,76" (24,02" diag) 51,8cm x 32,4cm (61,0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x
Last edited by akaIDIOT; Jun 16, 2013 @ 11:38am
Sweet Prince Sep 15, 2013 @ 8:17pm 
Having the same issue, experienced both level failing to load and the right click breaking mid level.

Processor Information:
Vendor: AuthenticAMD
CPU Family: 0x10
CPU Model: 0xa
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 3200 Mhz
6 logical processors
6 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Unsupported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 13.04 (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-27-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11303000
X Window Manager: GNOME Shell
Steam Runtime Version: steam-runtime-release_2013-09-05

Video Card:
Driver: NVIDIA Corporation GeForce GTX 560/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 313.30
OpenGL Version: 4.3
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1201
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3840 x 1080
Primary Display Size: 20.51" x 11.54" (23.50" diag)
52.1cm x 29.3cm (59.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC889

Memory:
RAM: 16050 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 209088 Mb
Largest Free Hard Disk Block: 32249 Mb

Installed software:

Recent Failure Reports:

Kamilko47 Sep 15, 2013 @ 9:38pm 
A developer say - "We support only Ubuntu"
Hellkeepa Oct 3, 2013 @ 8:06am 
Well... This problem exists on Ubuntu too. Deadlocks at 100+ % CPU util when loading maps once every few loads, except for the last map which sems to cause this every time. Difference between other load crashes and the last map, is that the other maps crashes before I get the mission briefing, while the last map crashes on the briefing itself.

Processor Information:
Vendor: AuthenticAMD
CPU Family: 0x10
CPU Model: 0x4
CPU Stepping: 0x3
CPU Type: 0x0
Speed: 3200 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Unsupported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.3 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-53-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11103000
X Window Manager: KWin
Steam Runtime Version: steam-runtime-release_2013-09-05

Video Card:
Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2

Driver Version: 4.2.0 NVIDIA 304.88
OpenGL Version: 4.2
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xe22
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3840 x 1080
Primary Display Size: 20.91" x 11.77" (23.98" diag)
53.1cm x 29.9cm (60.9cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 7983 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 60317 Mb
Largest Free Hard Disk Block: 1808 Mb

Installed software:

Recent Failure Reports:
Last edited by Hellkeepa; Oct 3, 2013 @ 8:08am
Kamilko47 Oct 3, 2013 @ 8:18am 
I buy new card - GTX650 and anomaly works :)
wintermute Oct 5, 2013 @ 12:28am 
Same issue here. Freezes on mission 14 every damn time. Good job on messing up the last mission.

Fix it, after all we pay money for the game!
It's been over a year since last post and on (supported) Ubuntu 14.04 and NVidia (with latest 340 drivers) it's still won't let me even to see the menu. Not nice, 11 bit studio. I was thinking about buying TWOM but since you do nothing to fix the annoying bug I won't because I don't want to flush my money down the toilet again.
Kamilko47 Nov 17, 2014 @ 8:29pm 
In TWOM on 340 is white screen bug (or was after yesterday update). You must upgrade to 343.
I had Anomaly bug like You. When i buy GTX650 game works :)
Slick Dec 27, 2015 @ 12:05pm 
Problem persists. Black screen on startup on Ubuntu 15.10
Kamilko47 Dec 27, 2015 @ 11:37pm 
What driver, spec?
< >
Showing 1-15 of 23 comments
Per page: 15 30 50