DARK SOULS™ II

DARK SOULS™ II

View Stats:
Coe Apr 24, 2014 @ 3:34pm
Crash on Startup - Gathering of Fixes Thread
Things that worked for some people:


CONFIRMED WORKING FOR MANY::: ATI --- AMD video cards . Go to the control centre, Properties (Digital flat-panel) and enable GPU scaling. Apply and re-start the game.

This requires you to have AMD's "CCC"; The Cataclyst Control Center. You can download it here: http://support.amd.com/en-us/download


1. Unplugging your monitor, starting the game and then plugging it back in.

2. Running as administrator.

3. Using Windows + P.

4. Disabling sound drivers that could be conflicting.

5. Changing TV connection ports.

6. Re-running/repairing the distribution installation software located at steam\steamapps\common\Dark Souls II\_CommonRedist

7. Re-running/repairing the associated DirectX installation files located at C:\Program Files (x86)\Steam\SteamApps\common\Dark Souls II\_CommonRedist\DirectX\Jun2010

8. Running in a lower resolution. This can be done by either right-clicking and going into properties or right-clicking and selecting "Troubleshoot Compatibility".

9. Disabling secondary displays.

10. Running in Big-Picture mode.

11. Poking around in your CCC 3D settings. Restoring everything to default is worth a try.

12. Reinstalling sound/graphics-drivers and rebooting your PC with everything on default.
Last edited by Coe; Apr 24, 2014 @ 4:18pm
< >
Showing 1-15 of 61 comments
Coe Apr 24, 2014 @ 3:36pm 
Updated.
PraQnick Apr 24, 2014 @ 3:37pm 
+1
poop magnet Apr 24, 2014 @ 3:38pm 
if using tv with hdmi

1. remove hdmi from tv

2. use dvi monitor

3. start darksouls II

4. plug in tv with hdmi

5. praise the sun
Coe Apr 24, 2014 @ 3:39pm 
Only works for some. Loads of people with DVI are reporting this issue, unplugged and not.
Coe Apr 24, 2014 @ 3:43pm 
Updated.
Coe Apr 24, 2014 @ 3:47pm 
Updated. List keeps growing.
Ghinsu Apr 24, 2014 @ 3:48pm 
Number 1 makes it run for me but then I don't have sound.. WTF???? i don't have a DVI option!
Coe Apr 24, 2014 @ 3:51pm 
You shouldn't need one. This volume of users experiencing critical errors is absolutely unacceptable after waiting an additional whopping month of delay.
Coe Apr 24, 2014 @ 3:53pm 
Updated with a high probability ATI fix
juan Apr 24, 2014 @ 3:54pm 
none of these work for me. :'(
n2deep Apr 24, 2014 @ 3:55pm 
i only use dvi and it doesnt work for me
_brand0n Apr 24, 2014 @ 3:55pm 
nvidia user

1 works for me but to make it fullscreen i start in big picture mode

sitll no sound though
audaxviator42 Apr 24, 2014 @ 3:55pm 
I had the same issue and fixed it by disabling my second display and setting my main display to 1920 X1080. I suggest playing with your resolution settings and see if that helps.
Coe Apr 24, 2014 @ 3:56pm 
Updated. Keep the feedback coming.
juan Apr 24, 2014 @ 3:57pm 
can i get a better explanation... there is no "properties" in control panel
< >
Showing 1-15 of 61 comments
Per page: 15 30 50

Date Posted: Apr 24, 2014 @ 3:34pm
Posts: 61