Legends of Dawn

Legends of Dawn

View Stats:
My First Impressions

I have played this game for less than an hour, so these are really my initial impressions. Haven't seen enough of the game to judge it as a whole. That said, Let's start.

Part 1: Running the game.

The first thing I noticed was that the game did not start in full-screen as most do. It actually started windowed, with the window not really centered on my monitor. The problem was: I couldn't move it. It was displaying the intro movie, so I simply watched it (the part I could see, upper-left) and, when it was finished, the window simply gone dark and... nothing. It stood there, nothing showing up, despite of my clicks, esc hits and anything. So, I tried Alt+F4 to try and restart the game, but it did not answer to it. I tried to close it by every shortcut I could, but eventually decided to finish the process... Tried to run it again, similar problem, but the window actually gone full screen at the end... Still, the game froze once more.

Long (er) story short (ened), it took around 9 tries for the game to run, just opened it 9 times and it eventually launched.

Part 2: Creating character.

When I started creating a character, there were 3 races that didn't look that much different between each other, despite of a reputation modifier that I have no idea of what stands for. Afraid that this reputation could have a major importance, I chose the human race.

Now, I have to distribute my attribute points. Problem is, there's no explanation for them, I had no idea of what I was doing. What exactly does intelligence do? no idea. I simply gone for a max STR VIT and res on DEX. "It must be really cliché after all". Did not want to lose too much time here.
After some back and next clicks, I noticed the human limit for STR is 16, while the third race was 19. So, the races have differences that the game doesn't show at all when we are choosing ours.

Cosmetic! You can choose between a lot of different ugly hairs and faces. Also, you can change the color of your top hair (but your beard will stay default color). If you chose a color, it'll taint the hair with a really darker version. White actually gave me a gray hair and red/blue/brown were not really that different, almost black. So I decided to ignore the cosmetic altogether.

Part 3: Starting the game.

The char spawned on a pier, a boat was docked as the game started. I had to ALT+TAB out of it to answer a message... had to end the process manually again...

Trying again,
The char spawned on a pier, a boat is docked was as the game started for the second time. The game, resembling games like diablo, has mouse click as a movement order. So, I clicked on the boat, in order to my char to go aboard so I can talk to NPCs and all that RPG basic stuff.

Can you guess what happened?

My char started to walk stupidly in a straight line from its old position towards the point I clicked. There's absolutely no path finding, so mouse controlled movement is really bad. I then clicked on the ramp to access the boat, and when my char was over it I clicked on the boat itself.

And now, can you guess what happened?

My char walked to the side of the ramp, and, differently from before where he kept running in place despite of the lack of a wall to hold him, he fell down to the "water".
After a moment there was the sound of him dying. "You Have Been Defeated!"
Oh god, defeated by flawed controls.
So, the game is inconsistent whether you can or not fall from edges, in this case we can't fall from the dock's edges, nor from the ship's edges, but can fall from the ramp that connects both. Yeah, I should have guessed!

The mouse walk is simply ridiculous. The char walks to the point where you clicked, so you have to keep on clicking (like, 5 clicks per second.), since click+hold won't work as in diablo. I don't even know why they didn't remove it, hope they intent to fix this mouse movement sooner or later. WASD all the way from now.

I clicked Regenerate, to respawn and play further. My char started on a random titan quest-ish checkpoint, with two paths, one right and one left.
Where therell am I? Why did I not respawn at the starting position? Where are the docks?

I had no idea of where I was or where to go, so I took the path to the right (50-50 right?).
There was a cemetery, big iron doors and all that. There was a bookstand or something on its entrance, so I interacted with it. While I was reading, the game started to rotate the camera, so every time we interact with this kind of stuff we have to rotate the camera back to place where it was. This is surely an inconvenience, not sure why it works this way.

After I brought my camera rotation back to its original position, I entered the cemetery. There was a statue, and I examined it. Again the game rotated the camera. This is really getting annoying. A little further, there was a crypt. As I approached, an automatic dialog started and AGAIN the game rotated my camera.

I entered the crypt, hoping to discover what I should do (yeah, there was no story or NPC to talk, I was still walking randomly) and opened the first coffin. It opened a window with some unlock mechanism I didn't quite understand. I went further and opened the second one. Same thing. Opened the third, now I had some items to loot, a couple of weapons and some crappy stuff. looted the whole crypt and left it.

I noticed some graves around the crypt, and examined them to try and get a quest or anything, but the only thing they did was rotate my camera and show some random info.

I equipped a weapon looted from the crypt and continued on the path. There was an... ice turret... turret... there was a cliff right between the camera and the char. Usually, games adjust the camera automatically or make these obstructions transparent. This game did none of these; not to mention that trying to click to move now makes the char move towards the cliff despite of where you click.

I killed 2 ice turrets, some random spiders or roaches or don't know what these were and still hadn't the slightest idea of what I was supposed to do! There was no quest, no NPC, absolutely nothing to guide me.

Is that all there's to it? Walking forward and clicking everything to death?

Giving up on the game for now, maybe a few months from here they'll have fixed this game and it'll be in a playable state.
Last edited by dejaime=D-Newbie; Sep 2, 2013 @ 3:34pm
< >
Showing 1-5 of 5 comments
ArchAngel Sep 1, 2013 @ 4:43am 
Welcome to LoD, game where you are punished if you are just hoping the game will guide you like a 5 year old.
1) Read the Manual, most of the stuff you mentioned here is in the manual.
2) WASD movement is default, mouse movement was added later because of outcry from the players
3) Dying by droping into water in unfortunate and you are not alone in dying like that. The respawn was just outside the city where the docks are. There are plenty of people there to talk to, but as you said you had 50% to pick wrong way and you did :)
4) This is a sandbox game similar to Elder Scrolls games. You are encouraged to go out and explore and find stuff and quests and secrets. There is no constant guidance that will lead you by hand from start to finish.
The thing is, the game is basically just broken, unless you want to drag yourself through a shi tstorm of bad design choices and a game made by obviously very very bad programmers who don't know how to handle f ucking UNITY (I mean c'mon) then just drop the game and play something much better like Underrail, it was made by only one person (and still in alpha) but it's thousands of times better than this.

I mean, I backed this game, I really wanted to enjoy it, but the developers are just too amateur to make a game of this scale, it's like they read a beginners book in C++ and jumped straight to making a game the scale of ES, it's doomed to fail.

What stands out is their complete incompetence when patching the game, they simply lack the knowledge to add the feature that the game is lacking, like pathfinding, if they really wanted to please the costumers, they would have read up on pathfinding and implemented it, but it's like they went "well I don't know how to code pathfinding so I'll just leave it to the player" (hence the *click-click* around obstacles).

Be honest dreamatrix, your coders just don't know what they are doing, they lack the experience, the knowledge or the passion to please the players, they are lazy and squeeze in sub-par features that even a beginner programmer would have left out because it would've been shameful to leave it in. Shame on you.

Shame. On. You.
Last edited by Tiotusenvoltmannen; Sep 2, 2013 @ 2:50pm
julip Sep 2, 2013 @ 3:56pm 
If you are getting frustrated by lack of guidance in the game it might be better to wait until a walk through is made. I'm sure someone will make one soon. There were times I got stuck but I just revisited places I had already been to check of I missed something. A good plac for beginners to start is in Korden's Fall and just walk around and talk to every NPC you can find. They will give you quests that will direct you on how the game is played. Eventually you will be exploring underground caves/ dungeons without a quest but instead to find the pieces of the artifacts. It's basically a game that unfolds at your own pace you can do things when you want to not when someone is telling you to do something. It gets better once you get over the initial bump of figuring how the game play is. It's not everybodies taste in games but it's still good if you enjoy adventures and exploring. You might want to try playing it only an hour each day instead of totally giving up on it.
dejaime=D-Newbie Sep 2, 2013 @ 4:18pm 
The fact that the game doesn't guides me to any quests is a minimum factor. It'd only tell me to click things to death somewhere anyway!

The biggest problem with this game is that the controls and interface are flawed, that interface is grotesque... God, why rotate my camera when I'm examining something? Did a living soul ever think this was a good idea? Usually a mouse hover tooltip shows what something (like an attribute) does, but no, this game has a... manual... The game is so awfully flawed that one has to read the manual to play, even in its simplicity. And yes, it is a really simple game now that I've gone over the ice "turrets". Inconsistencies like falling to death or not over an edge is just a reminder that the map was poorly implemented, to say the least.

It revolts me that they had the guts to put this up for sale as a finished and complete game.
julip Sep 2, 2013 @ 4:28pm 
Yes I understand your frustration. I changed all the key bindings in the beginning and used the number pad on my keyboard to controld my camera. What I didn't like was in the beginning it moved ver slow so when you were looking around it took forever. I made it a little faster by changing the mouse sensitivity I put it to maximum so it went much faster. That might make it more bearable for you. I guess what I found useful about the camera rotate was somtimes there was a chest hidden in the corner you might miss but yes it would be nice if the camera just followed the direction you were facing. I only used the mouse click for combat the rest of the direction movement I used the arrow keys it's closer to the camera contrl makes it a little bit easier.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50